pairing issue with MS Bluetooth Notebook Mouse 5000

Bug #368500 reported by Przemysław Kochański on 2009-04-28
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
bluez-gnome (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: bluez-gnome

After I use bluez "add new device" wizard it says that parsing succeeded, but mouse is still in "search-mode" and do not work. Removing and adding it again and rebooting the system do not work. The solution is to before adding it in bluez run "sudo apt-get install bluez-compat" and after adding run "sudo hidd --search". That worked out of the box in 8.10.
The mouse is "Microsoft Bluetooth Notebook Mouse 5000" and i use Lenovo n200 build-in bluetooth.

summary: - parsing mouse don't work on 9.04 (worked on 8.10)
+ pairing mouse don't work on 9.04

I have the same problem since recently. Pairing used to work, but yesterday I lost pairing with the mouse and could not ever pair again no matter how much I tried (inc. reboots). It says pairing successful, but in fact the mouse does not control the X pointer.

The solution by Przemysław worked perfectly just now. Thanks Przemysław!

The same bug still occurs with gnome-bluez-1.8, this time on Sabayon 4.2.
I don't have a "hidd" tool on that distro, so I cant connect my mouse anymore.
The output of bluetooth-applet remains clear.

Please, if someone have Microsoft Bluetooth Mouse 5000 confirm it.

Gustavo Carneiro (gjc) wrote :

I have Microsoft Bluetooth Mouse 5000 and had that problem. Making automatic pairing work is a pain. I got mine working again through the GUI, luck, and reboots. Also had to turn the mouse off and on many times, and press the reset button. It was _hard_ to get it to work.

You can get hidd by installing the package bluez-compat.

At 9.10 installing package gnome-bluetooth which deletes gnome-bluez and replace him (nice, better interface IMHO BTW) solves the problem. Console command are no longer needed.

It's a wont-fix. bluez-gnome is dead upstream and will be replaced by gnome-bluetooth in 9.10 Karmic.

Changed in bluez-gnome (Ubuntu):
status: New → Invalid
Changed in bluez-gnome (Ubuntu):
status: Invalid → Confirmed
hipitihop (denis-johnson) wrote :

Still a problem in 9.10 to get my Microsoft wireless mouse 8000 and wireless keyboard 7000 connected. I also have blueman and the bluez-compat package installed. I must place each device into discovery mode, one at a time, and then run "sudo hidd --search" only then will each pair and can be used.

Unfortunately, if I do not use the mouse or keyboard for a few minutes, the connection is dropped and I must repeat the procedure , so not only do I require hidd to pair them properly but I also need to find where to change settings so that they do not disconnect

Could someone try with gnome-bluetooth which has replaced bluez-gnome, and see if it fixed?

Thanks

summary: - pairing mouse don't work on 9.04
+ pairing issue with MS Bluetooth Notebook Mouse 5000
StefanF (stefan) wrote :

I had no such problems in the past years. But now I am also affected.
During the last 4 weeks, I noticed that the mouse cursor did not move and the buttons did not react sporadically for a while even the mouse was displayed as "connected". The problem alsways disappeard itself after a few minutes - until today.

Because of the sporadic outages, I tried to remove the mouse from the KDE module in the task bar and then tried to search it again. The mouse appears in the search dialog, then I am asked whether I want to connect it as a HID device (keyboard/mouse). After that, the mouse still does not work and the LED is still blinking red and green which indicated that the pairing process has not finished.

Howeever, when I endter "sudo hidd --scan", the mouse work immediately (until next reboot).

OS: Ubuntu 12.04
Desktop: KDE 4.8.5
Kernel: 3.2.0-32-generic-pae

libbluedevil: 1.9.1-0ubuntu1
bluedevil: 1.2.2-0ubuntu1
libbluetooth3: 4.98-2ubuntu7
bluez-compat: 4.98-2ubuntu7
gnome-bluetooth: not installed
Plugins for alsa, cups and pulseaudio: not installed

Since the mouse still works finde with Windows, and also connection to mobile phones function well, I'm sure that it is not a hardware issue.

StefanF (stefan) wrote :

I tested this on another Notebook - same Linux version, same problem also.

StefanF (stefan) wrote :

Falling back to the previous Kernel did not work.
But using Gnome instead of KDE makes adifference. The mouseworks fine in Gnome, but not in KDE.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers