[FFE] please upgrade bluez-gnome to 0.21

Bug #190405 reported by Baptiste Mille-Mathias
18
Affects Status Importance Assigned to Milestone
bluez-gnome (Ubuntu)
Wishlist
Unassigned

Bug Description

New description:
The latest bluez-gnome (0.21) supports file transfer with use of obex-data-server apis. gnome-bluetooth has removed file send support in favour of this method. The bluez-gnome method will make user experience better by having file transfer integrated.

Older description:
Version 0.18 is out
I started to package it; the new version can replace gnome-obex-send from package gnome-bluetooth; but it seems it lacks a dependency on obex-data-server not packaged at this time.

Revision history for this message
Baptiste Mille-Mathias (bmillemathias) wrote :

I'm also in the process of packaging obex-data-server, if someone is interested to review it quickly before the freeze I'm interested

Revision history for this message
Baptiste Mille-Mathias (bmillemathias) wrote :

debdiff files;

it would be cool if it could be reviewed before the freeze on Tuesday

Revision history for this message
Baptiste Mille-Mathias (bmillemathias) wrote :

see bug 190503 for obex-data-server package; if someone is interest to review it.

Thanks

Revision history for this message
Baptiste Mille-Mathias (bmillemathias) wrote : Re: please upgrade bluez-gnome to 0.18
description: updated
description: updated
Revision history for this message
Baptiste Mille-Mathias (bmillemathias) wrote :
Revision history for this message
Matti Lindell (mlind) wrote :

bluez-gnome 0.18 is now in Debian unstable.

Revision history for this message
Tomasz Dominikowski (dominikowski) wrote :

Actually, it would be nice to see bluez-gnome 0.21.

Revision history for this message
Tomasz Dominikowski (dominikowski) wrote :

obex-data-server is optional and needed for sending and receiving files. For these purposes the obex backend of nautilus and gnome-obex-server should be sufficient for now, but having obex-data-server in universe wouldn't hurt.

Revision history for this message
Baptiste Mille-Mathias (bmillemathias) wrote :

obex-backend for nautilus doesn't work at this time due to GIO port of nautilus; that's why obex-data-server + bluez-gnome were a good replacement.

Changed in bluez-gnome:
importance: Undecided → Wishlist
Revision history for this message
Onkar Shinde (onkarshinde) wrote :

Now that obex-data-server is in 'New' queue, I have tried packaging the latest bluez-gnome version 0.21 and also done some marginal testing (pairing and PC-to-phone transfer via the 'Send file ...' menu in applet). I hope Baptiste you don't mind me hijacking your work. :-)

Please note that even though package builds it will not be installed unless obex-data-server is accepted from the 'New' queue and makes way to repository. I had done a manual installation.
Also someone will have to make a 'Main Inclusion Report' for it so that it gets included on CD.

I have added a patch to disable the menu item 'Browse Device ...' until gome-vfs-obexftp is ported to gvfs. The dependency on gnome-vfs-obexftp is still there in the hope that it will work in near future.

Please find attached .diff.gz. Comments/suggestions welcome.

Changed in bluez-gnome:
status: New → Confirmed
Revision history for this message
Baptiste Mille-Mathias (bmillemathias) wrote :

Hi Onkar,

No problem that you took my job :) I'm happy someone cares to use obex-data-server.
Who can do the request of Main inclusion Report ? should I contact someone ?

If bluez-gnome now depends on obex-data-server, it would be good to update gnome-bluetooth to 0.11 (I've uploaded a package on REVU)

Cheers

Revision history for this message
Matti Lindell (mlind) wrote :

There's interesting patch evolving upstream about implementing obex-ftp backend for GVFS. As noted, GVFS doesn't support gnome-vfs-obex and so we're currently without working obex-ftp functionality :( This is a somewhat irritating regression from Gutsy.

I tested a bit with obex-data-server (0.2 version from upstream) and bluez-gnome 0.21. I was able to get file transfers work from both phone<->computer, but not without problems. obex-data-server needs still some love..

Here's a debdiff I've been using for sometime now. Maybe we should merge with Debian if exception is granted for this.
Thanks Baptiste for packaging obex-data-server btw!

Revision history for this message
Matti Lindell (mlind) wrote :

I forgot to say that the upstream bug with a patch is http://bugzilla.gnome.org/show_bug.cgi?id=509621.

Revision history for this message
Onkar Shinde (onkarshinde) wrote :

@mlind,

Can you test my .diff.gz. I prefer an update to latest version (0.21) instead of a merge with Debian because we will need an FFE in any case.

Revision history for this message
Onkar Shinde (onkarshinde) wrote :

@Baptiste,

The process for MIR is documented here - https://wiki.ubuntu.com/MainInclusionProcess
Sine you packaged obex-data-server I think you are in better position to provide all the information.

description: updated
Revision history for this message
Matti Lindell (mlind) wrote :

Onkar, I had a look of your debdiff and it looks good to me. obex-data-server should be Recommends or Suggests as main inclusion is in doubt. I reckon we should merge with Debian and apply our changes at the top as most of the stuff is already on Debian package provided by Filippo.

obex-data-server (>= 0.3) is probably safe bet as the bluez-gnome was changed recently to cope with the new 0.3 API. Disabling the 'Browse Device' menu item seems to work and it's probably okay too until gio/gvfs gets the obex-ftp bluetooth support.

I included your changes in the merge, what do you think?
I'll attach the whole stuff as a .tar archive.

Once this looks okay, we should subscribe the archive for a review.

Revision history for this message
Basilio Kublik (sourcercito) wrote :

by the way, the inclusion of the current bluez-utils will also solve bug #144751

Revision history for this message
Matti Lindell (mlind) wrote :

bluez-gnome (0.23-0ubuntu1) hardy; urgency=low

  [ Onkar Shinde ]
  * debian/control
    - Add 'obex-data-server' instead for file transfer support.
    - Remove gnome-icon-theme dependency as the application now has its own
      Tango friendly icon.
    - Add 'Homepage' field and remove url from description.
    - Update 'Standards-Version' to 3.7.3.
  * debian/patches/
    - 01_dont_run_update-mime-database.patch, 02_MenusRevisited.patch -
      Refreshed for new release.
    - 03_disable_browse_menu.patch - Disable 'Browse Device...' menu in the
      applet as gnome-vfs-obexftp is not working currently.
  * debian/watch
    - Copied from the version in Debian unstable.

  [ Tollef Fog Heen ]
  * New upstream release

 -- Tollef Fog Heen <email@hidden> Mon, 25 Feb 2008 08:14:27 +0100

Changed in bluez-gnome:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.