'Browse device...' in the bluetooth applet is useless without gnome-vfs-obexftp

Bug #131530 reported by C. Cooke
96
Affects Status Importance Assigned to Milestone
bluez-gnome (Debian)
Fix Released
Unknown
bluez-gnome (Ubuntu)
Medium
Unassigned
nautilus (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: bluez-gnome

Information:
The Gnome Bluetooth applet finally has a feature which scans for and allows you to connect to devices. However, the only method of connection it supports is obex, which is not supported by Ubuntu by default. Trying to connect to any of the devices shown brings up an error message complaining about the lack of Obex support.

Steps to reproduce:
Install Gutsy on a machine with a supported bluetooth device
Make sure the bluetooth applet is running
Right click on the bluetooth applet and select "Browse device..."
Make sure a bluetooth device is in range, then try to connect to it.

Resolution:
Adding a dependency on gnome-vfs-obexftp would solve this issue. The package is currently in universe, however, so this may be tricky.

Versions:
bluez-gnome 0.11-0ubuntu1
gnome-vfs-obexftp 0.4-1

Related branches

Revision history for this message
Siegfried Gevatter (rainct) wrote :

Perhaps

Changed in bluez-gnome:
importance: Undecided → Low
Revision history for this message
Siegfried Gevatter (rainct) wrote :

(Sorry, bad click. That's what I wanted to say:)

Perhaps instead of adding a dependency the applet could be patched so that when the user tries this function it explains him that an additional package is required to use it and asks to install it automatically.

I don't have much (any) experience with this applet; if this is it's major functionality of course the dependency should be added. Also I don't know how difficult my suggestion is, but I think I've already seen something like that somewhere else.

Revision history for this message
Andrew Jorgensen (ajorg) wrote :

There's a brief discussion on bluez-users about this right now. http://news.gmane.org/gmane.linux.bluez.user

Revision history for this message
Saivann Carignan (oxmosys) wrote :

I confirm this bug for me too, it would be great if gnome-vfs-obexftp was just added to the dependencies.

Revision history for this message
Matti Lindell (mlind) wrote :

bluez-gnome should probably Recommends gnome-vfs-obexftp.

Changed in bluez-gnome:
importance: Low → Medium
status: New → Confirmed
Revision history for this message
Jake Anderson (jake-vapourforge) wrote :

Confirming this bug, the error message given is very non "intuitive" and your average user wont have any idea how to fix it. (heck it was only that i had played with the old version of bluez that i had a clue)

I believe the error message is generated by nautilus or gnome in some form or fashion, not bluez. A patch on that would be best, and could be made fairly general purpose, IE if it knows it can speak OBEX with a plugin then inform the user of this at least, and offer to install it at best. Something like how totem works with codecs.

In the near term I'm for adding the dependency, its all of 200kb or so however everything else is included in the default install so I'm not too sure how easy that is to get done (IE adding stuff to the install/live CS).

Changed in bluez-gnome:
status: Unknown → New
Revision history for this message
Sebastien Bacher (seb128) wrote :

that's not a nautilus issue and 1 task is enough

Changed in nautilus:
status: New → Invalid
Revision history for this message
Saivann Carignan (oxmosys) wrote :

bluez-gnome is in main and gnome-vfs-obexftp is in universe, maybe that can give problems.

I also think that gnome-vfs-obexftp should be just added to the dependencies of bluez-gnome because the actual bluez-gnome uses functionnalities of gnome-vfs-obexftp and fail to work if it's not installed.

I made a debdiff which fixes the depencies problem.

Revision history for this message
Andrew Jorgensen (ajorg) wrote :

I personally think the best way to solve this is to:

A) Use something like the mime-type handler and codec finding services we already have but for service types. This would take the most time to implement but would provide the best user experience.

B) Make the menu item conditional on gnome-vfs providing a handler for the obex service. There's probably a way to query it.

Revision history for this message
Saivann Carignan (oxmosys) wrote :

This is a good idea, but it would be complicate to implement and we can't expect that feature for Gutsy. Maybe a blueprint could be created for this.

I suggest a temporary solution : bluez-gnome should detect if gnome-vfs-obexftp is installed or not and tell people to install it when clicking on browse device.. , or simply install it by itself ( Only if gnome-vfs-obexftp gets into the main repository ).

I agree that adding dependencies would add stuff on the CD that isn't necessary needed. And I think that it would be more appropriate if gnome-vfs-obexftp was on the main repository and not universe.

Revision history for this message
Onkar Shinde (onkarshinde) wrote :

I think gnome-vfs-obexftp should be added to 'Recommends' of bluez-gnome instead of 'Depends'.

By the way, has anyone checked if the 'Browse Device ..' feature works after installing gnome-vfs-obexftp?

Revision history for this message
Franck (alci) wrote :

Hi,

I kind of tested the 'Browse Device' feature, and it kind of works :)
In fact I can see devices, connect to it and 'Browse device...' opens Nautilus with obex: aa:aa:aa:aa:aa as path.
It also shows a file that I can copy from my phone to the desktop.

The only point is that I have no idea where on the phone I am located, so I can't test the other way (from Ubuntu to phone device).

Does anyone know what directory Obexftp is supposed to browse ?

Revision history for this message
Saivann Carignan (oxmosys) wrote :

I tested this.. the Browse Device feature works only after installing gnome-vfs-obexftp. If gnome-vfs-obexftp isn't installed, we can see devices but we can't browse them with nautilus.

Actually, Browse device.. just open the device at his root folder ( obex://[00:00:00:00:00:00] ) The root folder of the OBEX service only depends on the device itself and not on gnome-vfs-obexftp.

Adding gnome-vfs-obexftp to recommands would be appropriate, in my point of view.

Revision history for this message
Onkar Shinde (onkarshinde) wrote :

@Franck,

gnome-vfs-obexftp shows the root of your phone's file system i.e. what you see in your phone's file manager.

Revision history for this message
Martin Pool (mbp) wrote :

I think this should be considered for gutsy (at least adding a dependency if nothing else). The appearance of the bluetooth applet by default in Gutsy is new (at least on my laptop), and that will invite people to try it out and explore. When I try it with my phone, the only bt device I have, it's useless until I install the obex support, and it works well with it.

Revision history for this message
Franck (alci) wrote :

@Onkar,

following your tip I have found the place I was browsing on the device, it is a directory called 'shared' available in the 'messages' application.
I must admit I don't really know the Symbian OS very well. But anyway, browsing when gnome-vfs-obexftp is installed works for me !

Revision history for this message
Matti Lindell (mlind) wrote :

Could someone perhaps write a main inclusion report (https://wiki.ubuntu.com/UbuntuMainInclusionRequirements) about this one as this seems somewhat important for Average Joe to get their bluetooh stuff working properly?

Revision history for this message
Steven Wagner (stevenwagner) wrote :

I was getting the error, and installed the gnome-vfs-obexftp package as recommended. Now I just get a different error.

Couldn't display "obex://[xx:xx]".
Check if the service is available.

I am trying to connecting to a bluetooth keyboard.

Revision history for this message
Guillermo Jano (guillermo-jano) wrote :

@Steven,

A bluetooth keyboard device is not supposed to be browseable, i.e. you don't have files on the keyboard. Pairing is a completely different issue.

Revision history for this message
Khoo Kah Ken (gossipze) wrote :

libopenobex1 does not appear to be available from the main Gutsy repositories. One place to retrieve it from is here: https://launchpad.net/ubuntu/gutsy/i386/libopenobex1/1.3-3ubuntu1

Revision history for this message
Onkar Shinde (onkarshinde) wrote :

@Khoo,

libopenobex1 is available in gutsy repositories.

Revision history for this message
Clusty (clusty1) wrote :

Well I still get the problem Steve is describing but with a cell phone. Can it be that cell phone does not support browsing?

Revision history for this message
Saivann Carignan (oxmosys) wrote :

Clusty : Some cell phones doesn't support browsing. Pairing and browsing are different things. I suggest you to look at the documentation of your cell phone or to test your cell phone on another computer to see if you can browse files on it, so you'll be sure that your problem is or isn't really a bug. Also, if you get problems with browsing, you can look if you can find another bug report which describe the same problem than yours ( because this one is more about not-installed-by-default gnome-vfs-obexftp ).

Don't forget that you must install gnome-vfs-obexftp in order to browse devices.

Revision history for this message
zeddock (zeddock) wrote : Re: [Bug 131530] Re: 'Browse device...' in the bluetooth applet is useless without gnome-vfs-obexftp

Must I still install gnome-vfs-obexftp if I am on Gusty?

zeddock

On Nov 6, 2007 1:58 PM, Saïvann Carignan <email address hidden> wrote:

> Clusty : Some cell phones doesn't support browsing. Pairing and browsing
> are different things. I suggest you to look at the documentation of your
> cell phone or to test your cell phone on another computer to see if you
> can browse files on it, so you'll be sure that your problem is or isn't
> really a bug. Also, if you get problems with browsing, you can look if
> you can find another bug report which describe the same problem than
> yours ( because this one is more about not-installed-by-default gnome-
> vfs-obexftp ).
>
> Don't forget that you must install gnome-vfs-obexftp in order to browse
> devices.
>
> --
> 'Browse device...' in the bluetooth applet is useless without
> gnome-vfs-obexftp
> https://bugs.launchpad.net/bugs/131530
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Revision history for this message
Saivann Carignan (oxmosys) wrote :

zeddock : Yes, but please ask for your questions on forums, or by email ( I will be always pleased to help you ) but not on a bug report which aim to help developers and contain vital information about bugs. Thanks :)

Revision history for this message
Fabián Rodríguez (magicfab) wrote :

I installed gnome-phone-manager, gnome-vfs-obexftp and libopenobex1 and the message I now get is:
 Nautilus cannot display "obex://[xx:xx:xx:xx:xx:xx].
 Please select another viewer and try again.

This is for any type of device (phone, computer, mouse, etc.).

I think the "Connect" butto is misleading as it gives the impression we're actually doing the " pairing" of a device.

Revision history for this message
Laurent GUERBY (laurent-guerby) wrote :

For some reason I also had to :

sudo apt-get install obextool

to be able to get things working

Revision history for this message
robertsaron (dickvader) wrote :

This is one area where KDE rules. It has superb bluetooth. I have a kyocera lingo, and Kubuntu had no problems detecting my device. When in Gnome I have spent a week trying to figure this out, and still no luck.

Changed in bluez-gnome:
status: New → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

I just promoted gnome-vfs-obexftp to main, so please go ahead and add the dependency.

Changed in bluez-gnome:
status: Confirmed → Triaged
Revision history for this message
Saivann Carignan (oxmosys) wrote :

I subscribed ubuntu-main-sponsors. According to Martin Pitt recommendation, I would like to add dependency for gnome-vfs-obexftp in the bluez-gnome package in order to fix this bug. debdiff is attached

Revision history for this message
Matti Lindell (mlind) wrote :

Sorry Saïvann for duplicating your effort :(
I left a request for main-sponsors to get a new upstream version release in Bug #181304 and applied fix to this issue as well. Would you like to combine your changes to my debdiff?

Revision history for this message
Saivann Carignan (oxmosys) wrote :

mlind : Thanks for your work! I think that it's great work like that. ubuntu-main-sponsors will take the decision about the 0.15 new upstream release. It's important that the gnome-vfs-obexftp dependency is added even if bluez-gnome is or isn't updated to 0.15. If my debdiff is applied before your one, I suggest that you update your debdiff to remove the changelog line about gnome-vfs-obexftp. Is that a good idea?

Revision history for this message
Daniel Holbach (dholbach) wrote :

The patch in bug 181304 does that too and updates to the newest version. I'd close this bug as a duplicate of bug 181304 - any objections?

Revision history for this message
Saivann Carignan (oxmosys) wrote :

If bug 181304 will be fixed by ubuntu-main-sponsors for Hardy, I would say go for it! Otherwise, since this is not really the same bug so I suggest to let it open until it really get fixed. Thanks!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez-gnome - 0.15-0ubuntu1

---------------
bluez-gnome (0.15-0ubuntu1) hardy; urgency=low

  * New upstream release (LP: #176664, LP: #181304):
    - Use buttons in notification popups.
    - Use CreateSecureDevice for input device setup.
    - Add remove button for network connections.
    - Enable connect/disconnect button for network devices.
    - Enable singleton support.
    - Update device selection widget.
    - Make tooltips HIG compliant (LP: #138085).
  * debian/control:
    - bluez-gnome: Depends on gnome-vfs-obexftp (LP: #131530).
    - bluez-gnome: Change home page link in description (LP: #135501).

 -- Matti Lindell <email address hidden> Tue, 08 Jan 2008 18:41:00 +0200

Changed in bluez-gnome:
status: Triaged → Fix Released
Revision history for this message
Adam (adam-parchimowicz) wrote :

Cool that the bug is fixed. Wouldn't this be nice though to put a separate button for pairing the device? How do you perform it anyway? Also maybe the 'browse' button should be disabled if the device wasn't browseable (i.e. a keboard).

Revision history for this message
Ramesh Thiruchelvam (ramesht) wrote :

It works after installing gnome-vfs-obexftp, but it only pairs obexftp service devices. Audio / Input devices are displayed in the list but when trying to pair it gives an error.

Couldn't display "obex://[00:19:1f:3b:e0:87]".
Check if the service is available.

Changed in bluez-gnome:
status: Fix Committed → Fix Released
Revision history for this message
Ondra (xorwen) wrote :

I confirm this for my headset. This is still unpairable.

Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

The same I've... Then I can't push in any way a file to a remote device... I must use kbtobexclient to do this... :/

Revision history for this message
bentree (bentree89) wrote :

i installed "libopenobex1" as well and it solved all my problems. I'm using hardy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.