Callee hears loud noise after 5-10 minutes, using bluetooth headset

Bug #50600 reported by mole0815 on 2006-06-21
2
Affects Status Importance Assigned to Milestone
bluez-btsco (Ubuntu)
Medium
Bluetooth

Bug Description

Binary package hint: bluez-btsco

When establishing a connection to the bt-headset all works fine. After 5-10 minutes the callee heres a very loud noise. The microphone gauge indicate this. This happens in several SIP-Clients (ekiga, xten, kphone...).

Before upgrading to Dapper all works fine with the self-compiled btsco module.

My headset is: Jabra BT130 and i have a build-in bluetooth device.

Did you need any output files?

Daniel_G (dg-online) wrote :

I have exactly the same problem using a Logitech headset together with a "level one" BT dongle.
In Breezy everyting worked fine with the self-compiled btsco module. I have searched the Net for several days now but can't find a way to solve this problem.

Daniel Holbach (dholbach) wrote :

I just uploaded a new release to Edgy. Please, if you can make it somehow - please test it and see if the bugs were fixed.

Changed in bluez-btsco:
assignee: nobody → bluetooth
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Daniel_G (dg-online) wrote :

I've downloaded the file from https://launchpad.net/distros/ubuntu/+source/bluez-btsco/14112005cvs-2build1

As I was running dapper drake 6.06 at the time I installed the a.m. Edgy file and its dependencies onto my dapper system. This did not solve the problem.

Although the update seemed to alter the symptoms. Prior to the update, the person I had called heard a loud noise after a varying amount of time. Now this only happened sometimes. Other times the audio signal from the callee just dropped dead and I wasn't able to hear the person when in fact the other party didn't notice any change at all in the connection and could hear me speak.

Because the new bluez-btsco release didn't provided any significant improvement under Dapper Drake I installed Edgy last night and will return with a test report for the "right" Kubuntu version shortly.

Daniel_G (dg-online) wrote :

You're right, I happened to put the wrong URL in my previous message.

Nevertheless, I installed Edgy with “bluez-btsco”, version “1:0.42-0ubuntu1” and at first anything seemed to work well again.
Unfortunately I only managed to make a few shorter calls before there was a system update by which several bluetooth related packages were updated. (Don't know if that really has anything to do with the reappearing problems...)
Now I'm stuck with noise (at callees end) and discontinued inbound audio (less frequent) occurring at random times again.

Is there any log file I can post here or any process I can start in order to monitor what's going on in order to help?

My /var/log/messages file e.g. shows this amongst others (This is only a small excerpt there are several hundred lines stating snd-bt-sco, but I think the entries could have occurred at or near by an audio error):

Oct 22 23:24:06 localhost kernel: [17230806.548000] snd-bt-sco: capture_prepare
Oct 22 23:24:06 localhost kernel: [17230806.548000] snd-bt-sco: prepare ok bps: 16000 size: 32768 count: 26
Oct 22 23:24:06 localhost kernel: [17230806.548000] snd-bt-sco: capture_trigger 1
Oct 22 23:24:06 localhost kernel: [17230806.548000] snd-bt-sco: setting capture to bspcm
Oct 22 23:25:52 localhost kernel: [17230913.300000] snd-bt-sco: Shift problem detected! Fixing to 1.
Oct 22 23:25:53 localhost kernel: [17230914.252000] snd-bt-sco: Shift problem detected! Fixing to 0.

Arne Caspari (arne-datafloater) wrote :

This happens to me also after about 1 Minute with a Nokia HS-26W headset on the latest Ubuntu Feisty.

Timo Kosig (tiomo) wrote :

I experienced the same thing, the inbound audio is discontinued after some time although the callee can still hear me clearly.

Hardware used: Motorola H350 bluetooth headset, Sitecom CN-500 USB Bluetooth Dongle with CSR chipset

I also tried the new implementation of the bluetooth-alsa project called plugz. I could get it to work in terms of recording sound from my headset and playing that file on the headset via aplay but i can't use it since my main interest of using a bluetooth headset lies within placing calls over skype.
Since i'm using the amd64 version of Feisty i can't get skype to work properly with the new bluetooth-alsa implementation, it keeps complaining that it is missing the library libasound_module_pcm_sco.so. I copied the contents of a debian deb package for bluetooth-alsa and libsbc into /usr/lib32 but still no luck.

Timo Kosig (tiomo) wrote :

Update: i was able to get plugz to work with skype eventually using a set of 32bit sound libraries from gentoo. So skype stops complaining about the missing library but when i do a test call to the skype test call service my recorded voice is pretty garbled and therefore it's quite useless to me. The problem seems to be lying within the alsa drivers though as skype works well with the snd-bt-sco kernel module and btsco but for the discontinued audio after some minutes. Bad luck and pretty annoying :( .

Thank you for reporting this bug.

Is this an issue in Lucid?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers