Screensaver starts after a few seconds

Bug #483474 reported by garythornton1956 on 2009-11-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
blueproximity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-screensaver

After last night's update (15/11/09) my screensaver kicks in after a few seconds of inactivity. The power settings are the same as they have always been (15mins) and it always worked fine before today. I have reset the Power settings and restarted the computer but to no avail.

WeatherGod (ben-v-root) wrote :

Thank you for taking the time to report this bug. We would like to gather more information about this issue. Could you please run the command 'apport-collect -p gnome-power-manager 483474' in the terminal. This will help collect additional information about your computer and its power settings.

Changed in gnome-screensaver (Ubuntu):
status: New → Incomplete

Architecture: i386
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: gnome-power-manager 2.28.1-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_GB.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
Uname: Linux 2.6.31-15-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin netdev plugdev powerdev sambashare scanner uml-net video

Changed in gnome-screensaver (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

Since I posted this morning I have set all my screensaver and power settings to 'never', which did stop the problem then I went to ~/gconf.d and deleted the contents and rebooted.
The problem has not occurred now for 5 hours so perhaps is fixed (let's see) but I have no idea what the cause was. I am going to put my settings back to 15 minutes and see if anything changes.

This problem now seems to be NOT associated with gnome-screensaver or gnome-power!
I noticed last night that if my phone was close to the computer (i.e. in my poket) that the problem occurred and if the phone was some distance away (in the kitchen) that it did not. If I disable bluetooth on my phone (or on the pc) then the problem is gone! I now suspect that the problem is something to do with bluetooth affecting some setting on my computer so I am closing this bug.

Changed in gnome-screensaver (Ubuntu):
status: New → Fix Released
WeatherGod (ben-v-root) wrote :

Moving this to the bluetooth package as it appears that bluetooth is *somehow* interferring.

Changed in gnome-screensaver (Ubuntu):
status: Fix Released → New
affects: gnome-screensaver (Ubuntu) → bluez (Ubuntu)

Just to add to WeatherGod's comment, I have got a bit further with it. I had installed a feature called BlueProximity which, when I looked at it, has some gnome-screen-commands as default actions. I'm still not sure why it was affecting my computer though because my phone is not paired to the computer.

MarcRandolph (mrand) wrote :

Thanks for reporting this bug and supporting getting more information. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in bluez (Ubuntu):
importance: Undecided → Low
status: New → Triaged
affects: bluez (Ubuntu) → blueproximity (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers