Ubuntu

Blueman: tethering using PAN doesn't work

Reported by tim474 on 2011-11-01
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
blueman (Debian)
Fix Released
Unknown
blueman (Fedora)
Unknown
Unknown
blueman (Ubuntu)
Undecided
Unassigned

Bug Description

I can not use mobile phone as modem through bluetooth using PAN ("Network Access Point" in context menu in blueman) in blueman. If in "Local Services" I choose using Network Manager, when I try to connect, blueman writes:

Соединение невозможно или разорвано: Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "<string>", line 2, in ServiceProxy
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/DBusService.py", line 121, in ServiceProxy
    self.Applet.Plugins.RunEx("service_connect_handler", cb, interface, object_path, _method, args, ok, err)
  File "/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py", line 231, in RunEx
    ret = getattr(inst, function)(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/NMPANSupport.py", line 333, in service_connect_handler
    conn = self.find_active_connection(d.Address, "panu")
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/NMPANSupport.py", line 290, in find_active_connection
    nma_connection = self.find_connection(address, type)
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/NMPANSupport.py", line 278, in find_connection
    conns = self.nma.ListConnections()
AttributeError: 'NoneType' object has no attribute 'ListConnections'

If I don't use NM, there is connection "bnep0", but it is not configured. If I can turn off this connection in Blueman, Blueman hungs.

In Ubuntu 11.04 it had worked. I tried to install previous version of blueman from Natty repositories and newer (1.23) version from ppa. But there is some trouble with these versions.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: blueman 1.22~bzr707-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.21~ppa4~loms~oneiric-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Tue Nov 1 12:55:26 2011
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: blueman
UpgradeStatus: No upgrade log present (probably fresh install)

tim474 (tim474) wrote :
Robert Roth (evfool) on 2011-11-01
affects: ubuntu → blueman (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in blueman (Ubuntu):
status: New → Confirmed
tim474 (tim474) wrote :

Why nobody answers (not only on this site)? Is this problem affect only me? Or nobody uses telephone as modem via Bluetooth?

Gary Richards (ashak) wrote :

No useful input from me i'm afraid, just that Debian Wheezy seems to exhibit the exact same problem.

Including it here on the chance that someone there works out what the problem is

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=658572

Jani Uusitalo (uusijani) wrote :

Here's a patch that worked for me. It adds some lines to what becomes /usr/share/pyshared/blueman/plugins/applet/NMPANSupport.py during installation, to set up variables that are otherwise left initialized to 'None', hence the error when they're used later on.

Note that I don't know anything about DBus, have barely glimpsed at Python prior to this, and in particular have no knowledge of how Blueman's developer intended for things to work, so apply at your own risk.

The attachment "initialize self.nma and self.nm as they are on watch_name_owner events" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in blueman (Debian):
status: Unknown → New
netAction (launchpad-netaction) wrote :

The patch from Jani Uusitalo works here. Ubuntu 12.04, Galaxy S3 / CyanogenMod 9

Changed in blueman (Debian):
status: New → Fix Released
Honza Javorek (honzajavorek) wrote :

Come on! Why this is not in the newest Xubuntu? I upgraded whole system just to get this repaired. It is so annoying that I can't use tethering with my phone only because of this little bug and releasing it's fix takes ages!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.