Blueman: tethering using PAN doesn't work

Bug #884651 reported by tim474 on 2011-11-01
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
blueman (Debian)
Fix Released
Unknown
blueman (Fedora)
Fix Released
Medium
blueman (Ubuntu)
Undecided
Unassigned

Bug Description

I can not use mobile phone as modem through bluetooth using PAN ("Network Access Point" in context menu in blueman) in blueman. If in "Local Services" I choose using Network Manager, when I try to connect, blueman writes:

Соединение невозможно или разорвано: Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "<string>", line 2, in ServiceProxy
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/DBusService.py", line 121, in ServiceProxy
    self.Applet.Plugins.RunEx("service_connect_handler", cb, interface, object_path, _method, args, ok, err)
  File "/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py", line 231, in RunEx
    ret = getattr(inst, function)(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/NMPANSupport.py", line 333, in service_connect_handler
    conn = self.find_active_connection(d.Address, "panu")
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/NMPANSupport.py", line 290, in find_active_connection
    nma_connection = self.find_connection(address, type)
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/NMPANSupport.py", line 278, in find_connection
    conns = self.nma.ListConnections()
AttributeError: 'NoneType' object has no attribute 'ListConnections'

If I don't use NM, there is connection "bnep0", but it is not configured. If I can turn off this connection in Blueman, Blueman hungs.

In Ubuntu 11.04 it had worked. I tried to install previous version of blueman from Natty repositories and newer (1.23) version from ppa. But there is some trouble with these versions.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: blueman 1.22~bzr707-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.21~ppa4~loms~oneiric-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Tue Nov 1 12:55:26 2011
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: blueman
UpgradeStatus: No upgrade log present (probably fresh install)

abrt 1.0.9 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/blueman-applet
component: blueman
executable: /usr/bin/blueman-applet
kernel: 2.6.32.12-115.fc12.x86_64
package: blueman-1.21-4.fc12
reason: NMPANSupport.py:267:find_connection:AttributeError: 'NoneType' object has no attribute 'ListConnections'
release: Fedora release 12 (Constantine)

backtrace
-----
NMPANSupport.py:267:find_connection:AttributeError: 'NoneType' object has no attribute 'ListConnections'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/blueman/plugins/applet/RecentConns.py", line 298, in on_item_activated
    self.Applet.DbusSvc.ServiceProxy(item["service"], item["device"].GetObjectPath(), "Connect", item["conn_args"], reply, err)
  File "<string>", line 2, in ServiceProxy
  File "/usr/lib/python2.6/site-packages/blueman/plugins/applet/DBusService.py", line 119, in ServiceProxy
    self.Applet.Plugins.RunEx("service_connect_handler", cb, interface, object_path, _method, args, ok, err)
  File "/usr/bin/blueman-applet", line 278, in RunEx
    ret = getattr(inst, function)(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/blueman/plugins/applet/NMPANSupport.py", line 322, in service_connect_handler
    conn = self.find_active_connection(d.Address, "panu")
  File "/usr/lib/python2.6/site-packages/blueman/plugins/applet/NMPANSupport.py", line 279, in find_active_connection
    nma_connection = self.find_connection(address, type)
  File "/usr/lib/python2.6/site-packages/blueman/plugins/applet/NMPANSupport.py", line 267, in find_connection
    conns = self.nma.ListConnections()
AttributeError: 'NoneType' object has no attribute 'ListConnections'

Local variables in innermost frame:
self: <blueman.plugins.applet.NMPANSupport.NMPANSupport object at 0x29a0a10>
t: 'panu'
address: dbus.String(u'04:1E:64:70:AD:DC', variant_level=1)

Created attachment 423153
File: backtrace

The crash happens as soon as the Ihpone ( 3GS ) paires .
I have deletet the units on both sides, restart the PC, restart the Iphone and repairing again in order to find out which part of the bluetoth SW causes the crash.
Most of the cases it is the blueman-manager but as in this case the aplet

This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we may not be able to fix it before Fedora 12 is end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora please change the 'version' of this
bug to the applicable version. If you are unable to change the version,
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

tim474 (tim474) wrote :
Robert Roth (evfool) on 2011-11-01
affects: ubuntu → blueman (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in blueman (Ubuntu):
status: New → Confirmed
tim474 (tim474) wrote :

Why nobody answers (not only on this site)? Is this problem affect only me? Or nobody uses telephone as modem via Bluetooth?

blueman-1.23-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/blueman-1.23-1.fc17

blueman-1.23-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/blueman-1.23-1.fc16

blueman-1.23-1.fc16 has been pushed to the Fedora 16 stable repository. If problems still persist, please make note of it in this bug report.

blueman-1.23-1.fc17 has been pushed to the Fedora 17 stable repository. If problems still persist, please make note of it in this bug report.

Gary Richards (ashak) wrote :

No useful input from me i'm afraid, just that Debian Wheezy seems to exhibit the exact same problem.

Including it here on the chance that someone there works out what the problem is

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=658572

Jani Uusitalo (uusijani) wrote :

Here's a patch that worked for me. It adds some lines to what becomes /usr/share/pyshared/blueman/plugins/applet/NMPANSupport.py during installation, to set up variables that are otherwise left initialized to 'None', hence the error when they're used later on.

Note that I don't know anything about DBus, have barely glimpsed at Python prior to this, and in particular have no knowledge of how Blueman's developer intended for things to work, so apply at your own risk.

The attachment "initialize self.nma and self.nm as they are on watch_name_owner events" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in blueman (Debian):
status: Unknown → New
netAction (launchpad-netaction) wrote :

The patch from Jani Uusitalo works here. Ubuntu 12.04, Galaxy S3 / CyanogenMod 9

Changed in blueman (Debian):
status: New → Fix Released
Honza Javorek (honzajavorek) wrote :

Come on! Why this is not in the newest Xubuntu? I upgraded whole system just to get this repaired. It is so annoying that I can't use tethering with my phone only because of this little bug and releasing it's fix takes ages!

Changed in blueman (Fedora):
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.