blueman-applet crashed with KeyError in io_event(): 2

Bug #762554 reported by BAB SWAIN on 2011-04-16
82
This bug affects 14 people
Affects Status Importance Assigned to Milestone
blueman (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: blueman

wireless and blue-tooth not working and disabled.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: blueman 1.21-4.1build1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Sat Apr 16 13:47:57 2011
ExecutablePath: /usr/bin/blueman-applet
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110329.1)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/bin/blueman-applet
ProcEnviron:
 LANGUAGE=en_IN:en
 LANG=en_IN
 LC_MESSAGES=en_IN.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/blueman-applet']
SourcePackage: blueman
Title: blueman-applet crashed with KeyError in io_event(): 2
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

BAB SWAIN (uswain) wrote :
tags: removed: need-duplicate-check
Marc Deslauriers (mdeslaur) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

security vulnerability: yes → no
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in blueman (Ubuntu):
status: New → Confirmed
Marcelo M (mottalli) wrote :

This is also happening on Xubuntu 12.04 install CD right after I install the "Boradcom STA wireless" driver.

José Lou Chang (obake) wrote :

I am running a LiveUSB with a Xubuntu 64-bit daily iso that I downloaded today.
Upon installing the Broadcom STA Wireless driver there was an icon on the top panel that showed an "app has crashed".

When I tried to send an crash/bug report, it sent me to this page saying that the bug has already been reported.

Dave H (dave-hills-2009) wrote :

Also happended me with a new install of Xubuntu 12.04 beta1 right after I install the "Boradcom STA wireless" driver.

Dave H (dave-hills-2009) wrote :

Occurred again following new install of Xubuntu 12.04 beta 2 on a Lenovo S10e Netbook. Installed the broadcom restiected driver, cash immediately after. Not fixed yet then?

Dave H (dave-hills-2009) wrote :

Update on #7: Although there was the crash on completion of the install of the Broadcom wireless driver, wireless networking works perfectly. No other problems.

Tom Earp (earp-tom) wrote :

Happened to me whilst running the Xubuntu 12.04 LiveCD on an HP 6735b laptop, straight after activating the Broadcom STA driver in the Additional Drivers dialog. Wireless networking (wifi only, haven't tried any bluetooth) appears to work without any problems.

tags: added: precise
Changed in blueman (Ubuntu):
importance: Undecided → Medium
Robie Basak (racb) wrote :

Still affects: 12.10, blueman 1.23-0ubuntu3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers