Can't turn Bluetooth back on

Bug #411481 reported by Siegfried Gevatter on 2009-08-10
220
This bug affects 47 people
Affects Status Importance Assigned to Milestone
Blueman
Fix Released
Undecided
Unassigned
blueman (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: blueman

I've installed blueman to try it out, used the "Turn Bluetooth Off" and now there is no way to turn it back on.

__setattr__ (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/PowerManager.py:91)
bt_off False
_________
__setattr__ (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/PowerManager.py:91)
off True False
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/blueman/plugins/applet/PowerManager.py", line 39, in <lambda>
    self.item.connect("activate", lambda x: self.on_bluetooth_toggled())
  File "/usr/lib/python2.6/dist-packages/blueman/plugins/applet/PowerManager.py", line 77, in on_bluetooth_toggled
    self.bluetooth_off = not self.bluetooth_off
  File "/usr/lib/python2.6/dist-packages/blueman/plugins/applet/PowerManager.py", line 100, in __setattr__
    adapter.SetProperty("Powered", not value)
  File "/usr/lib/python2.6/dist-packages/blueman/bluez/utils.py", line 28, in warp
    raise errors.parse_dbus_error(exception)
blueman.bluez.errors.DBusFailedError: Unknown error 132

Changed in blueman (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Valmantas Palikša (walmis) wrote :

Looks like a bluez issue.

Valmantas Palikša (walmis) wrote :

What happens if you try to run "sudo hciconfig hci0 up" after you turned off bluetooth?

Angel Guzman Maeso (shakaran) wrote :

For me:
$ sudo hciconfig hci0 up
Can't init device hci0: Unknown error 132 (132)

Looks like it works here.

--
Siegfried-Angel Gevatter Pujals (RainCT)
Ubuntu Developer. Debian Contributor.

Changed in blueman:
status: New → Triaged
Valmantas Palikša (walmis) wrote :

Ok i've installed karmic and figured this out.
It appears that blueman tries to turn on adapter before the killswitch is disabled, and hence the unknown error.
A fix will be soon comitted to svn.

Changed in blueman:
status: Triaged → Fix Committed
nh2 (nh2) wrote :

Is this solved in Karmic? I experience the same, can't turn back on.

Kiwinote (kiwinote) wrote :

no, it isn't yet..

On Fri, Sep 4, 2009 at 7:53 PM, nh2 <email address hidden> wrote:

> Is this solved in Karmic? I experience the same, can't turn back on.
>
> --
> Can't turn Bluetooth back on
> https://bugs.launchpad.net/bugs/411481
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Valmantas Palikša (walmis) wrote :

You can enable the dailies repository to get the latest snapshot. This bug is fixed there.

https://edge.launchpad.net/~blueman/+archive/blueman-dailies

Kai Blin (kai.blin) wrote :

As a workaround, manually switching on the device with "sudo rfkill unblock <idx of bluetooth dev>" helped me.

Andrew Kohlsmith (akohlsmith) wrote :

I get this crash when enabling bluetooth for the first time after logging in. The blueman systray icon is dark, and if I click on it it asks me if I'd like to start bluetooth. I say yes, and it crashes.

aslakjo (aslakjo) wrote :

If i turn the bluetooth via blueman off and then on again, ill get this error. However if i do a "sudo rfkill unblock bluetooth" the blueman applet starts bluetooth and i do get the correct service

Changed in blueman:
status: Fix Committed → Fix Released

I am having the same problems highlighted above. I tried installing the fix from the dailies repository (https://edge.launchpad.net/~blueman/+archive/blueman-dailies):

mittv@mittv-desktop:~$ apt-cache policy blueman
blueman:
  Installed: 1.22+r646+200911300759~karmic
  Candidate: 1.22+r646+200911300759~karmic
  Version table:
 *** 1.22+r646+200911300759~karmic 0
        500 http://ppa.launchpad.net karmic/main Packages
        100 /var/lib/dpkg/status
     1.10-3ubuntu1 0
        500 http://us.archive.ubuntu.com karmic/universe Packages

However, I am still unable to turn on Bluetooth. I launch blueman-applet, and the icon that appears says 'Bluetooth: Disabled'. I right click and I right click and select 'Turn on Bluetooth', and nothing happens. I can keep trying to no effect. Here is the log from the app:

_________
update_state (/usr/lib/python2.6/dist-packages/blueman/main/KillSwitchNG.py:162)
State: False
_________
on_switch_changed (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/KillSwitch.py:75)
Global state: False
switch.soft: 1
switch.hard: 0
_________
on_power_state_query (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/KillSwitch.py:88)
False
_________
UpdatePowerState (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/PowerManager.py:146)
off True
foff False
on False
current state False
new state False

Clément (clement-lagrange) wrote :

Had the same problem.
Solution provided in Bug #496733 worked for me !
(RememberPowered = false in /etc/bluetooth/main.conf)

Blueman 1.21

Daniele (ammostro) wrote :

Still experiencing this behaviour in Ubuntu 10.04 with latest blueman daily build. Also giving a 'sudo rfkill unblock x' is a fine workaround.

auxbuss (launchpad-auxbuss) wrote :

Tried on Ubuntu 10.10.

After loading there are 3 bluetooth process: blueman-applet, bluetoothd, blueman-mechani

About 15 second after bluetooth is deactivated via the widget, first blueman-mechani fails, then almost immediately bluetoothd.

Because of this I get:

$rfkill list
1: sony-bluetooth: Bluetooth
 Soft blocked: yes
 Hard blocked: no

and to get things working it is necessary to:
$ sudo rfkill unblock bluetooth

as attempts to load blueman result in the msg:

  Connection to BlueZ failed
  Bluez daemon is not running, blueman-manager cannot continue.

Song Zhao (zhaosong414) wrote :

It seems that there was a solution in comments of Bug #496733. It is a duplicated bug report of this one.

May be some hints can be found in that black box solution.

Changed in blueman (Ubuntu):
status: Confirmed → Incomplete
Angel Guzman Maeso (shakaran) wrote :

Cannot reproduce the bug using Ubuntu 14.04 Trusty (with blueman version package 1.23+update1-2ubuntu1)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers