FFe: Please merge blueman 2.0-1 (universe) from Debian stretch (main)

Bug #1482626 reported by Martin Wimpress 
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
blueman (Ubuntu)
Wishlist
Sean Davis

Bug Description

Reason for FFe: bluez5 landed very late (this past week) and this was needed for blueman 2.0, obexd which was the alternative was removed from Debain and probably needs to be removed from Ubuntu as well (will be handled separately)

Please merge blueman 2.0-1 (universe) from Debian stretch (main)

Blueman 2.0 introduces many bug fixes, has been migrated gsettings.
It is significantly improved over the 1.99 alpha1 version in the
Ubuntu wily archive.

Changelog entries since current wily version 1.99~alpha1-1ubuntu1:

blueman (2.0-1) unstable; urgency=low

  * New upstream release

 -- Christopher Schramm <email address hidden> Sun, 24 May 2015 10:08:00 +0200

blueman (2.0~rc1-1) unstable; urgency=low

  * New upstream release (Closes: #757633)

 -- Christopher Schramm <email address hidden> Wed, 13 May 2015 17:08:00 +0200

blueman (1.99~alpha2-1) unstable; urgency=low

  * New upstream release (Closes: #779613, #764635, #762526, #762527, #549274,
                          #652005, #761284, #761286)

 -- Christopher Schramm <email address hidden> Fri, 06 Mar 2015 10:12:00 +0200

Revision history for this message
Artur Rona (ari-tczew) wrote :

Blueman 2.0 needs to have in archive merged obexd. Unfortunately, it's not easy to do. See bug #1263260.

I'm subscribing Micah, as he has interest in this case.

Setting status as incomplete for now.

Changed in blueman (Ubuntu):
importance: Undecided → Wishlist
status: New → Incomplete
Revision history for this message
Micah Gersten (micahg) wrote :

This is actually blocked by Bug #1162781 as obexd has been merged into bluez, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=772094

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks, unsure if that's the summary which is confusing or if the info is missing, but could you explain why it's ok to drop the ubuntu changes there?

Revision history for this message
Martin Wimpress  (flexiondotorg) wrote :

If that question from comment #3 is directed at me, then the summary was autogenerated by requestsync, I haven't changed what requestsync generated with regard to dropping patches.

That said I have directed upstream at the patches Ubuntu has been carrying to see what are still relevant and can be upstreamed.

Revision history for this message
Sebastien Bacher (seb128) wrote :

" - debian/patches/01_dont_autostart_lxde.patch:
      + Don't autostart the applet in LXDE."

that change looks like it's a least still relevant, somebody should do a merge rather than a sync then

the new version also supports still both bluez4&5 so it can be uploaded directly to wily, no need to use the transition ppa for that one

Revision history for this message
Martin Wimpress  (flexiondotorg) wrote :

When you say someone should do a merge, to whom are you referring?

Revision history for this message
Sean Davis (bluesabre) wrote :

It looks like 03_filemanager_fix.patch can be dropped since it's no longer applicable (file manager paths are not hard-coded). I agree that 01_dont_autostart_lxde.patch is still relevant.

I've put together a merge in my PPA here: https://launchpad.net/~bluesabre/+archive/ubuntu/bluez5

blueman (2.0-1ubuntu1) wily; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/patches/03_filemanage_fix.patch:
      + Dropped, no longer needed.
    - debian/patches/dhcpclient_priority
    - debian/patches/01_dont_autostart_lxde.patch
      + Refreshed patches

 -- Sean Davis <email address hidden> Thu, 20 Aug 2015 22:53:28 -0400

blueman (2.0-1) unstable; urgency=low

  * New upstream release

 -- Christopher Schramm <email address hidden> Sun, 24 May 2015 10:08:00 +0200

blueman (2.0~rc1-1) unstable; urgency=low

  * New upstream release (Closes: #757633)

 -- Christopher Schramm <email address hidden> Wed, 13 May 2015 17:08:00 +0200

blueman (1.99~alpha2-1) unstable; urgency=low

  * New upstream release (Closes: #779613, #764635, #762526, #762527, #549274,
                          #652005, #761284, #761286)

 -- Christopher Schramm <email address hidden> Fri, 06 Mar 2015 10:12:00 +0200

Revision history for this message
Sean Davis (bluesabre) wrote :

debdiff: Ubuntu to Ubuntu

Revision history for this message
Sean Davis (bluesabre) wrote :

debdiff: Debian to Ubuntu

Micah Gersten (micahg)
summary: - Sync blueman 2.0-1 (universe) from Debian stretch (main)
+ FFe: Please merge blueman 2.0-1 (universe) from Debian stretch (main)
Changed in blueman (Ubuntu):
status: Incomplete → Confirmed
description: updated
Sean Davis (bluesabre)
tags: added: wily
Revision history for this message
Iain Lane (laney) wrote :

I assume you've tested it (for future FFes please clarify that)

Go ahead.

Revision history for this message
Sean Davis (bluesabre) wrote :

Yes, already tested. Works well with my bluetooth headphones and mouse, no issues with normal usage.

Will add the clarification for future FFes. Thanks!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package blueman - 2.0-1ubuntu1

---------------
blueman (2.0-1ubuntu1) wily; urgency=low

  * Merge from Debian unstable (LP: #1482626). Remaining changes:
    - debian/patches/03_filemanage_fix.patch:
      + Dropped, no longer needed.
    - debian/patches/dhcpclient_priority
    - debian/patches/01_dont_autostart_lxde.patch
      + Refreshed patches

blueman (2.0-1) unstable; urgency=low

  * New upstream release

blueman (2.0~rc1-1) unstable; urgency=low

  * New upstream release (Closes: #757633)

blueman (1.99~alpha2-1) unstable; urgency=low

  * New upstream release (Closes: #779613, #764635, #762526, #762527, #549274,
                          #652005, #761284, #761286)

 -- Sean Davis <email address hidden> Mon, 07 Sep 2015 12:48:18 -0400

Changed in blueman (Ubuntu):
status: Confirmed → Fix Released
Pasi Lallinaho (knome)
Changed in blueman (Ubuntu):
assignee: nobody → Sean Davis (bluesabre)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.