bluefish default browser is galeon

Bug #348408 reported by marco.pallotta on 2009-03-25
2
Affects Status Importance Assigned to Milestone
bluefish (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: bluefish

In Bluefish 1.0.7 (Hardy Heron) if you try to press the button "view in browser" you will not see anything. In fact if you launch bluefish from cli you will see that the default browser is galeon but it's not installed by default in Ubuntu. You can fix this adding a new entry in "edit" -> "preferences" -> "external programs" -> "browser", typing a new label for firefox with the appropriate command (you can use the command "firefox -remote 'openURL(%s, new-window)' || firefox %s&") and then dragging it to the top of the list.
Now you can view your html projects inside firefox browser simply pressing the above button.

I think Ubuntu should include this entry (positioning it to the top of the browser list) by default as this is an usability bug.

Nicola Ferralis (feranick) wrote :

The attached patch adds a Firefox entry in the list of viewers. Since it's placed as first on the list, it is the default. Patch tested and binaries available for karmic here:

https://launchpad.net/~karmic-bleed/+archive/ppa

Changed in bluefish (Ubuntu):
status: New → Confirmed
Changed in bluefish (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluefish - 2.0.1-1

---------------
bluefish (2.0.1-1) unstable; urgency=low

  * New upstream release - the first release of the 2.0 series for Debian
    (closes: #570731; LP: #540126). This release fixes these reported issues:
    - Better settings handling (closes: #548272).
    - Improved filebrowser (LP: #45927).
    - Improved syntax highlighting engine (LP: #108628).
    - Improved file operations (LP: #181110).
    - Translated menu descriptions (LP: #371318, #371322). The chosen menu
      name is fine.
    - Improved browser commands and handling (LP: #158891, #348408).
  * Updated and adjusted packaging files.
  * debian/bluefish_icon.xpm: Renamed to debian/bluefish.xpm.
  * debian/bluefish.install: Adjusted.
  * debian/bluefish.menu (icon): Adjusted.
  * debian/bluefish-data.install, debian/bluefish-plugins.install: Added.
  * debian/control: Added bluefish-data, bluefish-dbg and bluefish-plugins.
    (Build-Depends): Dropped deprecated build-dependencies libaspell-dev,
    libgnomeui-dev, libgnomevfs2-dev, libpcre3-dev and dpatch. Added intltool,
    libtool, libenchant-dev and libgucharmap2-dev.
    (Standards-Version): Bumped to 3.8.4.
    (Depends, Suggests): Adjusted. Added gvfs-backends as dependency.
  * debian/copyright: Updated.
  * debian/rules: Rewritten. Dropped dpatch.
    (LDFLAGS): Dropped -Wl,-z,defs because of plugins.
    (config.status:): Adjusted configure switches.
    (install): Install to debian/tmp and list missing files.
    (binary-indep): Added for bluefish-data.
    (binary-arch): Adjusted. Put debugging symbols into bluefish-dbg.
  * debian/watch: Added support for RCs.
  * debian/README.Debian: Dropped (useless with 2.0).
  * debian/README.source: Dropped together with dpatch.
  * debian/patches/: Dropped (obsolete).
  * debian/reportbug/: Dropped.
 -- Lorenzo De Liso <email address hidden> Tue, 29 Jun 2010 21:40:10 +0200

Changed in bluefish (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers