Can not unmount USB volume, if some file was opened from it and the used application is still running

Bug #181110 reported by Jarno Suni on 2008-01-07
6
Affects Status Importance Assigned to Milestone
bluefish (Ubuntu)
Low
Unassigned

Bug Description

I tried this in Xubuntu Gutsy.

Steps to reproduce:
1) attach USB flash drive
2) mount (if neccessary)
3) open some file from the drive for editing in Mousepad or Bluefish
4) close the file in the editor
5) try to unmount the USB drive (in Thunar)

Unmounting does not work before you close the application. It is not enough to close the file in the application.

Jesus Gamio (jgamio) wrote :

I follow the steps but the unmount works for me, have you the problem all the time ?.

For me the image of the pendrive is there but the pendrive is unmounted.

Vincent (vinnl) wrote :

Confirmed on Xubuntu 7.10 with Bluefish.

Changed in thunar:
status: New → Confirmed
Vincent (vinnl) wrote :

Changed package to gnome-mount as I believe that's what used by Thunar to mount. Might be a problem with Bluefish/Mousepad too though, but I don't suppose it's Thunar's fault.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, that's not a gnome-mount specific issue though, linux doesn't allow to unmount media which are in use

Changed in gnome-mount:
importance: Undecided → Low
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

there is bug #19586 about better communicating the issue in nautilus

Jarno Suni (jarnos) wrote :

But media should not be in use, if user has closed the file in all applications.

Sebastien Bacher (seb128) wrote :

could be due to a buggy application, you can use lsof to try figuring what is still open on the device

Jarno Suni (jarnos) wrote :

Ok. It is still problem for Bluefish in Intrepid. Could this bug be filed against Bluefish, then. (Mousepad 0.2.14 is fine.)

Vincent (vinnl) on 2009-03-06
Changed in gnome-mount:
status: Invalid → Confirmed
Changed in bluefish (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluefish - 2.0.1-1

---------------
bluefish (2.0.1-1) unstable; urgency=low

  * New upstream release - the first release of the 2.0 series for Debian
    (closes: #570731; LP: #540126). This release fixes these reported issues:
    - Better settings handling (closes: #548272).
    - Improved filebrowser (LP: #45927).
    - Improved syntax highlighting engine (LP: #108628).
    - Improved file operations (LP: #181110).
    - Translated menu descriptions (LP: #371318, #371322). The chosen menu
      name is fine.
    - Improved browser commands and handling (LP: #158891, #348408).
  * Updated and adjusted packaging files.
  * debian/bluefish_icon.xpm: Renamed to debian/bluefish.xpm.
  * debian/bluefish.install: Adjusted.
  * debian/bluefish.menu (icon): Adjusted.
  * debian/bluefish-data.install, debian/bluefish-plugins.install: Added.
  * debian/control: Added bluefish-data, bluefish-dbg and bluefish-plugins.
    (Build-Depends): Dropped deprecated build-dependencies libaspell-dev,
    libgnomeui-dev, libgnomevfs2-dev, libpcre3-dev and dpatch. Added intltool,
    libtool, libenchant-dev and libgucharmap2-dev.
    (Standards-Version): Bumped to 3.8.4.
    (Depends, Suggests): Adjusted. Added gvfs-backends as dependency.
  * debian/copyright: Updated.
  * debian/rules: Rewritten. Dropped dpatch.
    (LDFLAGS): Dropped -Wl,-z,defs because of plugins.
    (config.status:): Adjusted configure switches.
    (install): Install to debian/tmp and list missing files.
    (binary-indep): Added for bluefish-data.
    (binary-arch): Adjusted. Put debugging symbols into bluefish-dbg.
  * debian/watch: Added support for RCs.
  * debian/README.Debian: Dropped (useless with 2.0).
  * debian/README.source: Dropped together with dpatch.
  * debian/patches/: Dropped (obsolete).
  * debian/reportbug/: Dropped.
 -- Lorenzo De Liso <email address hidden> Tue, 29 Jun 2010 21:40:10 +0200

Changed in bluefish (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers