Ubuntu

Bluefish won't open Firefox as external viewer.

Reported by oskar on 2007-10-31
4
Affects Status Importance Assigned to Milestone
Bluefish
Fix Released
Medium
bluefish (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: bluefish

It worked fine in Feisty. In Gutsy It can open Opera just fine, but it won't start firefox. The line in the preferences is:
mozilla -remote 'openURL(%s, new-window)' || mozilla %s&

Choosing 'gnome-default' won't work either:
gnome-moz-remote --newwin %s&

The Firefox preview works in the Screem HTML editor. But I don't see what command it is using in the Preferences.

Daniel Leidert (dleidert) wrote :

1) `mozilla -remote ...' opens the Mozilla browser and not firefox nor iceweasel - firefox has its own entry and iceweasel can be added as:

iceweasel %s&

If you have problems with the mozilla command and an installed mozilla/iceape suite, then please tell. But /usr/bin/mozilla is not a symlink to iceweasel or firefox.

2) gnome-moz-remote is part of the gnome-bin package, a Gnome 1.4(!) package - maybe its simply not installed on your system or the browser is not set correctly. So please check out these possibilities!

However, from reading your report I can only say: both issues are not bugs.

oskar (oskar669) wrote :

1) tried changing it to 'firefox' - that doesn't work either. Iceweasel is currently not in the gutsy repositories so I can't try that.

2) The gnome-bin package was not installed, however installing it didn't fix it.
I don't know how my browser needs to be configured to allow to be started with that particular line in bluefish. Everything is Gutsy Default. I wouldn't have thought that this is something that needs extra packages and configuration, after all I can open an URL from evolution or Pigdin without problems. What Bluefish does shouldn't be very different.

Well I don't know if its a bug. But it is an important part of the program that stopped working from one Release of Ubuntu to the next. If its not a bug, where should I post it?

Daniel Leidert (dleidert) wrote :

Well, in the Bluefish preferences, you can see, which commands are executed. Simply take a local html file and then try to execute the commands on your command line (replace %s with the file name) and check, what your console tells you. I still think, the issue is somewhere on your side and not in Bluefish.

oskar (oskar669) wrote :

Well then, feel free to close it if it doesn't belong here.

Trying to open an html file from the command line with gnome-moz-remote returns this:
[code]Gnome-Message: gnome_execute_async_with_env_fds: returning -1[/code]

Interestingly, opening a html file from the command line with the modified mozilla command works despite the error, but it still doesn't work from within bluefish.

[code]$ firefox -remote 'openURL(drum.html, new-window)' || firefox drum.html&
[2] 9398
[1] Done firefox -remote 'openURL(drum.html, new-window)' || firefox drum.html
$ Error: Failed to send command: 500 command not parseable
[/code]

oskar (oskar669) wrote :

Oh damn... I forgot to click 'apply'... It does work work with the 'firefox -remote...' command now.

Daniel Leidert (dleidert) wrote :

So firefox-problem has been fixed, right?

Well, the other doesn't seem to be a bluefish problem too. If gnome-moz-remote or any of its parts or the programs it calls return an error, its not a problem of bluefish. I know it worked in the past. But gnome-moz-remote is a Gnome 1 program. We already dropped it from our current development version of bluefish and I think, most users won't need it.

oskar (oskar669) wrote :

Yes. The view-in-browser button doesn't work. I made a keyboard shortcut for the firefox line, so it works for me now.

And since I got your attention - It is kind of counter intuitive that the 'Ok' button in Preferences does not apply the changes since there is also a 'cancel' button.

But everything else is works perfectly. Keep up the good work!

Daniel Leidert (dleidert) wrote :

I forwarded your comment to the developers list.

Daniel T Chen (crimsun) on 2008-11-11
Changed in bluefish:
importance: Undecided → Low
Nicola Ferralis (feranick) wrote :

The attached patch adds a Firefox entry in the list of viewers. Since it's placed as first on the list, it is the default. Patch tested and binaries available for karmic here:

https://launchpad.net/~karmic-bleed/+archive/ppa

Changed in bluefish (Ubuntu):
status: New → Confirmed
description: updated
Nicola Ferralis (feranick) wrote :

This has been fixed upstream in both 1.x and 2.x branches.

oskar (oskar669) wrote :

hooray
go feranick!

Nicola Ferralis (feranick) wrote :
Nicola Ferralis (feranick) wrote :

Attached a debdiff to version 1.0.7-6ubuntu3.

David Futcher (bobbo) on 2010-06-11
tags: added: patch-accepted-upstream
Changed in bluefish (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluefish - 2.0.1-1

---------------
bluefish (2.0.1-1) unstable; urgency=low

  * New upstream release - the first release of the 2.0 series for Debian
    (closes: #570731; LP: #540126). This release fixes these reported issues:
    - Better settings handling (closes: #548272).
    - Improved filebrowser (LP: #45927).
    - Improved syntax highlighting engine (LP: #108628).
    - Improved file operations (LP: #181110).
    - Translated menu descriptions (LP: #371318, #371322). The chosen menu
      name is fine.
    - Improved browser commands and handling (LP: #158891, #348408).
  * Updated and adjusted packaging files.
  * debian/bluefish_icon.xpm: Renamed to debian/bluefish.xpm.
  * debian/bluefish.install: Adjusted.
  * debian/bluefish.menu (icon): Adjusted.
  * debian/bluefish-data.install, debian/bluefish-plugins.install: Added.
  * debian/control: Added bluefish-data, bluefish-dbg and bluefish-plugins.
    (Build-Depends): Dropped deprecated build-dependencies libaspell-dev,
    libgnomeui-dev, libgnomevfs2-dev, libpcre3-dev and dpatch. Added intltool,
    libtool, libenchant-dev and libgucharmap2-dev.
    (Standards-Version): Bumped to 3.8.4.
    (Depends, Suggests): Adjusted. Added gvfs-backends as dependency.
  * debian/copyright: Updated.
  * debian/rules: Rewritten. Dropped dpatch.
    (LDFLAGS): Dropped -Wl,-z,defs because of plugins.
    (config.status:): Adjusted configure switches.
    (install): Install to debian/tmp and list missing files.
    (binary-indep): Added for bluefish-data.
    (binary-arch): Adjusted. Put debugging symbols into bluefish-dbg.
  * debian/watch: Added support for RCs.
  * debian/README.Debian: Dropped (useless with 2.0).
  * debian/README.source: Dropped together with dpatch.
  * debian/patches/: Dropped (obsolete).
  * debian/reportbug/: Dropped.
 -- Lorenzo De Liso <email address hidden> Tue, 29 Jun 2010 21:40:10 +0200

Changed in bluefish (Ubuntu):
status: In Progress → Fix Released
Changed in bluefish:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.