Fix *-gdm-theme packages to work with the new GDM (xsplash themes)

Bug #442408 reported by soc on 2009-10-04
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
blubuntu-look (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Andrew Starr-Bochicchio
edgy-gdm-themes (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Andrew Starr-Bochicchio
feisty-gdm-themes (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Andrew Starr-Bochicchio
gdm-themes (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Andrew Starr-Bochicchio
mythbuntu-gdm-theme (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Andrew Starr-Bochicchio
peace-look (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Andrew Starr-Bochicchio
sabily-gdm-themes (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Andrew Starr-Bochicchio
tropic-look (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Andrew Starr-Bochicchio
ubuntu-gdm-themes (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Andrew Starr-Bochicchio
ubuntume-gdm-themes (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Andrew Starr-Bochicchio
ubuntustudio-look (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Andrew Starr-Bochicchio

Bug Description

Binary package hint: gdm

There are currently several packages with gdm-themes in the karmic repository, which don't work anymore with the new gdm in karmic.

Solutions:
a) Update the package so that it works with the new GDM
b) Depend on gdm-2.20
c) Remove the package

Offending packages:

blubuntu-gdm-theme
edgy-gdm-theme
feisty-gdm-theme
gdm-themes
peace-gdm-theme
sabily-gdm-theme
tropic-gdm-theme
ubuntu-gdm-themes
ubuntume-gdm-theme

Thanks.

description: updated
description: updated
Philip Muškovac (yofel) wrote :

And from the #ubuntu+1 discussion:
Make them depend on gdm-2.20, since they only work with that version of gdm

Changed in gdm (Ubuntu):
status: New → Confirmed
soc (simon-ochsenreither) wrote :

Thanks Philip.
Ok, sounds good.

Additionally I would suggest adding a small note to the description which mentions that:
a) these themes are for an old version of gdm
b) don't work with the newer gdm and
c) the new gdm has no theming options at the moment (so that people can stop searching for them),
so that at least those who read them see that this is probably not what they want.

affects: gdm (Ubuntu) → ubuntu
Luke Faraone (lfaraone) on 2009-10-08
affects: ubuntu → blubuntu-look (Ubuntu)
Mario Limonciello (superm1) wrote :

Um. Did you actually verify these are ALL broke?

I can guarantee you mythbuntu-gdm-theme works properly with the new GDM.

Changed in blubuntu-look (Ubuntu):
status: Confirmed → Invalid
status: Invalid → New
Changed in mythbuntu-gdm-theme (Ubuntu):
status: New → Invalid

While the ubuntustudio gdm theme currently is not usable with the new GDM, this will likely change for lucid, and the package will contain bits to work with the new gdm.

 affects ubuntu/ubuntustudio-look
 status invalid

Changed in ubuntustudio-look (Ubuntu):
status: New → Invalid

HI Luke,

then it would be wise to make the package depend on gdm-2.20 for Karmic and change it back, when the new GDM is supported again.

description: updated
summary: - Remove all *-gdm-theme packages, they don't work anymore
+ Fix dependencies of *-gdm-theme packages or remove them until they work
+ with the new GDM

Hi Mario,

sorry, you are right. mythbuntu-gdm-theme has a xsplash theme.

summary: - Fix dependencies of *-gdm-theme packages or remove them until they work
- with the new GDM
+ Fix dependencies of *-gdm-theme packages or remove the packages until
+ they work with the new GDM
Changed in ubuntu-gdm-themes (Ubuntu):
status: New → Confirmed
Changed in sabily-gdm-themes (Ubuntu):
status: New → Confirmed
Changed in tropic-look (Ubuntu):
status: New → Confirmed
Changed in edgy-gdm-themes (Ubuntu):
status: New → Confirmed
Changed in feisty-gdm-themes (Ubuntu):
status: New → Confirmed
Changed in blubuntu-look (Ubuntu):
status: New → Confirmed
Changed in ubuntume-gdm-themes (Ubuntu):
status: New → Confirmed
Changed in peace-look (Ubuntu):
status: New → Confirmed
summary: - Fix dependencies of *-gdm-theme packages or remove the packages until
- they work with the new GDM
+ Fix *-gdm-theme packages to work with the new GDM (xsplash themes)
description: updated
Changed in gdm-themes (Ubuntu):
status: New → Confirmed
Changed in ubuntustudio-look (Ubuntu):
status: Invalid → Fix Released
status: Fix Released → Invalid
Changed in mythbuntu-gdm-theme (Ubuntu):
status: Invalid → Fix Released
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package blubuntu-look - 0.3-0ubuntu1

---------------
blubuntu-look (0.3-0ubuntu1) lucid; urgency=low

  * New upstream release. (LP: #298946)
   - Drop depricated GDM theme. (LP: #442408)
   - Update theme to be based on new Human theme. (LP: #204389)
   - Use GNOME-Brave icons instead of Tango.
 -- Andrew Starr-Bochicchio <email address hidden> Sat, 02 Jan 2010 14:06:52 -0500

Changed in blubuntu-look (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers