Blender crashes with "Segmentation fault"

Bug #242882 reported by Atanas Atanasov on 2008-06-25
4
Affects Status Importance Assigned to Milestone
blender (Ubuntu)
Undecided
Unassigned

Bug Description

I try to add a simple mesh and blender crashes e.g. Add -> Mesh -> Plane. Unfortunately Apport does not catch the crash either so I cannot submit complete information. I am running Hardy on Dell Inspiron 1721 laptop with ATI Radeon X1200 and fglrx 8.47.3. This is very minimal, how can I extract more details about the crash.

Atanas Atanasov (thenasko) wrote :

I just got some information from dmesg:

[75455.221531] blender-bin[29063] general protection rip:7f69f57e844b rsp:7fff12486ef8 error:0
[75912.127096] blender-bin[29192] general protection rip:7fbd13d0444b rsp:7fff309a3418 error:0
[75919.976045] blender-bin[29588] general protection rip:7f789f13244b rsp:7fffbbd25228 error:0
[76331.757625] blender-bin[29940] general protection rip:7ff14b45c44b rsp:7fff680faae8 error:0
[76648.722823] blender-bin[30265] general protection rip:7f267f58f44b rsp:7fff9c17f698 error:0
[76737.808445] blender-bin[30365] general protection rip:7f2303de244b rsp:7fff209d2ef8 error:0
[77150.760353] blender-bin[30830] general protection rip:7f711146344b rsp:7fff2e053578 error:0
[77172.881364] blender-bin[30866] general protection rip:7fc86493c44b rsp:7fff8152ea48 error:0

Each crash generates a single line.

joux (joux) wrote :

I can confirm this behaviour on an AMD64 nx6325 Notebook on Ubuntu 8.04, with the same ATI Radeon Xpress 1200, running xorg-driver-fglrx 1:7.1.0-8-3+2.6.24.13-19.45 from the repos. Blender 2.45 (repos), 2.46 and 2.47RC1 all crash when I try to add a mesh to the scene.

/var/log/messages:
Aug 12 00:52:18 HPnotebook kernel: [15470.233706] blender-bin[11392] general protection rip:7f5c75d1944b rsp:7fff8ea11b08 error:0

Atanas Atanasov (thenasko) wrote :

I upgraded to Intrepid and blender doesn't crash anymore. I also had to change my video driver to radeonhd (since fglrx is broken). Blender is version 2.46 as before, so it must be incompatibility of blender with the proprietary driver.

joux (joux) wrote :

I tested switching back to the "radeon" drivers. Both Blender 2.45 and 2.46 worked fine this way. So it is a problem with the "fglrx" proprietary drivers. On 7.10 they used to work together.

213197 is probably a duplicate of this.

Atanas Atanasov (thenasko) wrote :

I can confirm the bug doesn't occur with fglrx version 8.54.3. I assumed the driver updates have fixed the issue.

Changed in blender:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers