[armhf] blender crashes on start with Segmentation fault

Bug #1348045 reported by Peter Bauer on 2014-07-24
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Blender
Fix Released
Unknown
blender (Ubuntu)
Undecided
Unassigned

Bug Description

-If you start blender from the CLI you get this info:

ubuntu@tegra-ubuntu:~$ blender
Color management: using fallback mode for management
connect failed: No such file or directory
Writing: /tmp/blender.crash.txt
Segmentation fault
ubuntu@tegra-ubuntu:~$ cat /tmp/blender.crash.txt
# Blender 2.69 (sub 0), Revision: unknown

# backtrace

-If you start blender via strace you get this info:
strace -e open blender

open("/dev/urandom", O_RDONLY|O_LARGEFILE|O_CLOEXEC) = 16
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x54} ---

Is there a problem with the urandom device ?

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: blender 2.69-4ubuntu2
Uname: Linux 3.10.24-gf455cd4 armv7l
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: armhf
CurrentDesktop: Unity
Date: Thu Jul 24 07:52:47 2014
SourcePackage: blender
UpgradeStatus: No upgrade log present (probably fresh install)

Peter Bauer (peba) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in blender (Ubuntu):
status: New → Confirmed
Andrew Rogers (axuak0) wrote :

It crashes on dwm (a simple tiling window manager) and unity, for me.

Konstantin Maslyuk (kalemas) wrote :

chroot 14.04 on android 4.1.1, the same

Nazo (lovesyao) on 2016-02-23
summary: - blender crashes on start with Segmentation fault when reading
- /dev/urandom
+ blender crashes on start with Segmentation fault
Changed in blender (Ubuntu):
status: Confirmed → Fix Committed
summary: - blender crashes on start with Segmentation fault
+ [armhf] blender crashes on start with Segmentation fault
Changed in blender:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.