connect failed : no such file or directory, Segmentation fault (core dumped)

Bug #1216993 reported by Sandy Nicko Mac Corzeta on 2013-08-26
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
blender (Ubuntu)
Undecided
Unassigned

Bug Description

When i want to run a blender 2.68a svn59499 there is no respond opened application when i click the app via menu.
but then, when i type the blender app via terminal it goes comes up with this this report on terminal :

connect failed: No such file or directory
Writing: /tmp/blender.crash.txt
Segmentation fault (core dumped)

and then, inside of the /tmp/blender.crash.txt is :
# Blender 2.68 (sub 2), Revision: 59499

# backtrace
/usr/lib/blender/blender() [0x8771f4f]
[0xb7728400]
/usr/lib/i386-linux-gnu/libLLVM-3.0.so.1(_ZN4llvm3ARM8SPRClassC1Ev+0x15) [0xa874a9d5]
/usr/lib/i386-linux-gnu/libLLVM-3.0.so.1(+0x25ca48) [0xa86efa48]
/lib/ld-linux.so.2(+0xeeab) [0xb7737eab]
/lib/ld-linux.so.2(+0xef94) [0xb7737f94]
/lib/ld-linux.so.2(+0x12fa6) [0xb773bfa6]
/lib/ld-linux.so.2(+0xeccf) [0xb7737ccf]
/lib/ld-linux.so.2(+0x127f4) [0xb773b7f4]
/lib/i386-linux-gnu/libdl.so.2(+0xbe9) [0xb4fd1be9]
/lib/ld-linux.so.2(+0xeccf) [0xb7737ccf]
/lib/i386-linux-gnu/libdl.so.2(+0x133a) [0xb4fd233a]
/lib/i386-linux-gnu/libdl.so.2(dlopen+0x47) [0xb4fd1c97]
/usr/lib/i386-linux-gnu/mesa/libGL.so.1(+0x3cbf0) [0xb76efbf0]
/usr/lib/i386-linux-gnu/mesa/libGL.so.1(+0x4079d) [0xb76f379d]
/usr/lib/i386-linux-gnu/mesa/libGL.so.1(+0x1a3aa) [0xb76cd3aa]
/usr/lib/i386-linux-gnu/mesa/libGL.so.1(glXQueryVersion+0x2e) [0xb76c8cee]
/usr/lib/blender/blender(_ZN15GHOST_WindowX11C1EP15GHOST_SystemX11P9_XDisplayRK10STR_Stringiijj18GHOST_TWindowStatei25GHOST_TDrawingContextTypebbt+0x11c) [0x8f4598c]
/usr/lib/blender/blender(_ZN15GHOST_SystemX1112createWindowERK10STR_Stringiijj18GHOST_TWindowState25GHOST_TDrawingContextTypebbti+0xd7) [0x8f40347]
/usr/lib/blender/blender(GHOST_CreateWindow+0xb6) [0x8f3de26]
/usr/lib/blender/blender(wm_window_add_ghostwindows+0x205) [0x87916a5]
/usr/lib/blender/blender(WM_check+0x50) [0x87731b0]
/usr/lib/blender/blender(wm_homefile_read+0x109) [0x877d259]
/usr/lib/blender/blender(WM_init+0xd2) [0x877f412]
/usr/lib/blender/blender(main+0xe7a) [0x873002a]
/lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0xb4e414d3]
/usr/lib/blender/blender() [0x87705a9]

i'm running elementaryOS 0.2 (Luna [Ubuntu 12.04 LTS based fork]) with Radeon HD3000 series open-source linux driver.
I tried once to run this blender version while using fglrx, its running. But, when i back to open-source driver, this error bother me again.

affects: mesa (Ubuntu) → blender (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in blender (Ubuntu):
status: New → Confirmed
Riki Villalba (rikivillalba) wrote :

doing
~$ ldd /usr/lib/blender/blender | grep "not found"

gives me this result:

 libavformat.so.55 => not found
 libavcodec.so.55 => not found
 libavutil.so.52 => not found
 libavdevice.so.55 => not found

it appears there are some missing libraries

Roger Morton (ttguy) wrote :

I get same list of missing libs as Riki Villalba (rikivillalba). Tried installing the dev versions of these libs
eg libavformat-dev , libavdevice-dev etc. Did not help

I have libavdevice53 installed but there is no libavdevice in synaptic

Blender 2.69+svn61239+git201401010427.d8f4cb9 on Ubuntu 12.04 (precise) 32-bit

And blender was working before on this machine. Not sure what has changed.

Nazo (lovesyao) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers