Ubuntu

blcr kernel module failed to build with kernel 3.0 : configure: error: --with-linux argument '3.0-x' is neither a kernel version string nor a full path

Reported by Kenneth Bull on 2011-07-02
This bug affects 311 people
Affects Status Importance Assigned to Milestone
blcr (Debian)
Fix Released
Unknown
blcr (Ubuntu)
High
Alan

Bug Description

blcr-dkms 0.8.2 does not work on kernels newer than 2.6.30. 0.8.4 only works with 2.6.38.
If you need this package you must revert to such a kernel, if not, simply remove it.
Since blcr 0.8.2-15ubuntu2.1, the blcr-dkms package can be safely removed without wanting to remove libcr0 and openmpi as well, see LP: #1005524.

$ sudo apt-get remove blcr-dkms

-----------------------------------------------------------------------------------------

TEST CASE:

In Ubuntu 11.10:

sudo apt-get install blcr-dkms
grep error /var/lib/dkms/blcr/0.8.2/build/make.log

And you will see the error:

configure: error: --with-linux argument '3.0.0-12-generic' is neither a kernel version string nor a full path

ORIGINAL DESCRIPTION:

I installed paraview via the synaptic package manager and it gave me this error. It says that paraview installed properly and it seems to be working perfectly. I am using Ubuntu 11.10.

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: blcr-dkms 0.8.2-15ubuntu1
ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
Uname: Linux 3.0-2-generic x86_64
Architecture: amd64
Date: Sat Jul 2 16:12:04 2011
ErrorMessage: blcr kernel module failed to build
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
PackageArchitecture: all
PackageVersion: 0.8.2-15ubuntu1
SourcePackage: blcr
Title: package blcr-dkms 0.8.2-15ubuntu1 failed to install/upgrade: blcr kernel module failed to build
UpgradeStatus: Upgraded to oneiric on 2011-07-02 (0 days ago)

Kenneth Bull (candcrun) wrote :
summary: - package blcr-dkms 0.8.2-15ubuntu1 failed to install/upgrade: blcr kernel
- module failed to build
+ blcr kernel module failed to build with kernel 3.0 : configure: error:
+ --with-linux argument '3.0-x' is neither a kernel version string nor a
+ full path
Changed in blcr (Ubuntu):
status: New → Confirmed
status: Confirmed → Triaged
importance: Undecided → High
Changed in blcr (Debian):
status: Unknown → New
Changed in blcr (Debian):
status: New → Confirmed
Alan (awoodland) on 2011-10-12
Changed in blcr (Ubuntu):
assignee: nobody → Alan Woodland (awoodland)
description: updated
tags: added: testcase
tags: added: precise
tags: added: bugpattern-written
Gego/XAREN (gustav-hartvigsson) wrote :

Ubuntu bugreporter sent me here.... I just
# aptitude update && aptitude upgrade --full-resolve
and got an error message on the screen, bespite aptitude reporting no errors.
Exept for this:
<pre>
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
</pre>

whish has noting to do with this bug.

psamuel (persaudsamuel) wrote :

Error en actualizacion de kernel linux 3.2.0.10.10

Yeri (yeri-riveyplus) wrote :

Always getting this kind of error whenever I want to upgrade the kernel

Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.2.0-10-generic /boot/vmlinuz-3.2.0-10-generic
Error! Bad return status for module build on kernel: 3.2.0-10-generic (i686)
Consult /var/lib/dkms/blcr/0.8.2/build/make.log for more information.
Setting up linux-headers-3.2.0-10-generic-pae (3.2.0-10.17) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.2.0-10-generic-pae /boot/vmlinuz-3.2.0-10-generic-pae
Error! Bad return status for module build on kernel: 3.2.0-10-generic-pae (i686)
Consult /var/lib/dkms/blcr/0.8.2/build/make.log for more information.

psamuel (persaudsamuel) wrote :

Alguna solucion???

psamuel (persaudsamuel) wrote :

PRoblemas en Kernel Linux 3.2.0-11

Sasa Paporovic (melchiaros) wrote :

This bug is there with kernel3.0.20 Ubuntu11.10 updates as also on Ubuntu12.04.

Maybe it should be linked to a precise milestone. for beta-1 it may be to late. But trigering it for beta-2 should be possible.

Joachim Protze (joachim-protze) wrote :

The configure file in /var/lib/dkms/blcr/0.8.2/build/ determines a valid kernel version by checking for
2\.[46]\.[0-9].*

This means no kernel of version 3.x may ever be recognized as valid kernel.

Mike Carnegie (mcarnegie-7) wrote :

From the blcr-0.8.2 source downloaded by apt-get source blcr

kbuild.mak.in:8:# Note: we support only 2.6.x kernels

And from their site (https://ftg.lbl.gov/projects/CheckpointRestart/)

October 11, 2011
    Version 0.8.4 is now available from the Checkpoint Downloads page.
    This version fixes some minor bugs, and extends support to kernels through 2.6.38.

gust (aenzler) wrote :

now it pop up every minute a error that reports this error on my 11.10!

Guy Taylor (thebiggerguy) wrote :

Short term fix would be to block blcr coexisting with kernel-3.0.x via deb controls.

MC Return (mc-return) wrote :

This error is still valid for 12.04 also.
It just occured once again here:

Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.2.0-21-generic /boot/vmlinuz-3.2.0-21-generic
Error! Bad return status for module build on kernel: 3.2.0-21-generic (x86_64)
Consult /var/lib/dkms/blcr/0.8.2/build/make.log for more information.

this problem still persists with 3.2.0-22.35 version of kernel :

run-parts: executing /etc/kernel/header_postinst.d/dkms 3.2.0-22-generic /boot/vmlinuz-3.2.0-22-generic
Error! Bad return status for module build on kernel: 3.2.0-22-generic (i686)
Consult /var/lib/dkms/blcr/0.8.2/build/make.log for more information.

I need the blcr package to run ghemical a critical aplication for me. This error appaently happened because the package is not propperly installed and the system tried to upgrade it.

It happened to me whilest I was installing pacages so that I could start programming in gcc and python.

rmcd (rmcd1024) wrote :

Just happened to me in 12.04 when upgrading the kernel to 3.2.0.24.

I confirm, also happened in 12.04

I hate the message saying this bug has already been reported. I wonder when will it be fixed. I can't use ghemical on U 12.04 either because of this bug.

indium (indium) wrote :

apt-get update+upgrade held back the kernel packages: after the upgrade of the non-heldback packages I installed the new kernel via aptitude and ran into the current problem of blcr. Hopefully a restart with the new kernel will not cause any serious problems....

Pavlo (pavlo-solntsev) wrote :

Conform this bug on 12.04

Linux #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

ii blcr-dkms 0.8.2-15ubuntu2 DKMS support for BLCR kernel module
ii kerneloops-daemon 0.12+git20090217-1ubuntu19 kernel oops tracker
ii libdrm-dev 2.4.32-1ubuntu1 Userspace interface to kernel DRM services -- development files
ii libdrm-intel1 2.4.32-1ubuntu1 Userspace interface to intel-specific kernel DRM services -- runtime
ii libdrm-intel1:i386 2.4.32-1ubuntu1 Userspace interface to intel-specific kernel DRM services -- runtime
ii libdrm-nouveau1a 2.4.32-1ubuntu1 Userspace interface to nouveau-specific kernel DRM services -- runtime
ii libdrm-nouveau1a:i386 2.4.32-1ubuntu1 Userspace interface to nouveau-specific kernel DRM services -- runtime
ii libdrm-radeon1 2.4.32-1ubuntu1 Userspace interface to radeon-specific kernel DRM services -- runtime
ii libdrm-radeon1:i386 2.4.32-1ubuntu1 Userspace interface to radeon-specific kernel DRM services -- runtime
ii libdrm2 2.4.32-1ubuntu1 Userspace interface to kernel DRM services -- runtime
ii libdrm2:i386 2.4.32-1ubuntu1 Userspace interface to kernel DRM services -- runtime
ii libkms1 2.4.32-1ubuntu1 Userspace interface to kernel DRM buffer management
ii linux-firmware 1.79 Firmware for Linux kernel drivers
ii linux-generic 3.2.0.24.26 Complete Generic Linux kernel
ii linux-headers-3.2.0-24 3.2.0-24.38 Header files related to Linux kernel version 3.2.0
ii linux-headers-3.2.0-24-generic 3.2.0-24.38 Linux kernel headers for version 3.2.0 on 64 bit x86 SMP
ii linux-headers-generic 3.2.0.24.26 Generic Linux kernel headers
ii linux-image-3.2.0-24-generic 3.2.0-24.38 Linux kernel image for version 3.2.0 on 64 bit x86 SMP
ii linux-image-generic 3.2.0.24.26 Generic Linux kernel image
ii module-init-tools 3.16-1ubuntu2 tools for managing Linux kernel modules
ii rsyslog 5.8.6-1ubuntu8 reliable system and kernel logging daemon
ii udev 175-0ubuntu9 rule-based device node and kernel event manager
ii virtualbox-dkms 4.1.12-dfsg-2

PS.

Frank (franklin82) wrote :

This also seems to be a problem in 12.04

humsuploh (dreamteam) wrote :

This bug - one that seems to affect only the 3.X series of kernels, is some 10 months old but apparently nothing can be done about it. Ran into it again on 12.04 this morning:

Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-24-generic-pae /boot/vmlinuz-3.2.0-24-generic-pae
Error! Bad return status for module build on kernel: 3.2.0-24-generic-pae (i686)
Consult /var/lib/dkms/blcr/0.8.2/build/make.log for more information.

humsuploh (dreamteam) wrote :
Download full text (6.1 KiB)

For what it is worth, here is the complete make.log from earlier today.

DKMS make.log for blcr-0.8.2 for kernel 3.2.0-24-generic-pae (i686)
Thu May 3 11:54:44 SGT 2012
make: Entering directory `/usr/src/linux-headers-3.2.0-24-generic-pae'
/var/lib/dkms/blcr/0.8.2/build/Kbuild:19: /var/lib/dkms/blcr/0.8.2/build/module_files: No such file or directory
cd /var/lib/dkms/blcr/0.8.2/build && env -i PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/lib/dkms ./configure --disable-maintainer-mode --with-linux=3.2.0-24-generic-pae --with-installed-libcr --with-installed-util --with-components=modules --prefix=/usr && touch /var/lib/dkms/blcr/0.8.2/build/config-stamp
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to disable maintainer-specific portions of Makefiles... no
checking for pwd... /bin/pwd
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for perl5... no
checking for perl... /usr/bin/perl
checking for gmake... no
checking for make... /usr/bin/make
checking if /usr/bin/make is GNU make... yes (3.81)
checking for ranlib... ranlib
checking whether ln -s works... yes
checking for style of include used by /usr/bin/make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking the maximum length of command line arguments... 805306365
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... (cached) ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if g...

Read more...

Daniel Ejsing-Duun (zilvador) wrote :

I got the bug two times while upgrading the kernel today.

Matheus Ramos (matheusramos) wrote :
Download full text (6.1 KiB)

I have this problem, that's my log for help:

DKMS make.log for blcr-0.8.2 for kernel 3.2.0-24-generic (x86_64)
Qui Mai 3 16:45:51 BRT 2012
make: Entering directory `/usr/src/linux-headers-3.2.0-24-generic'
/var/lib/dkms/blcr/0.8.2/build/Kbuild:19: /var/lib/dkms/blcr/0.8.2/build/module_files: No such file or directory
cd /var/lib/dkms/blcr/0.8.2/build && env -i PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/lib/dkms ./configure --disable-maintainer-mode --with-linux=3.2.0-24-generic --with-installed-libcr --with-installed-util --with-components=modules --prefix=/usr && touch /var/lib/dkms/blcr/0.8.2/build/config-stamp
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to disable maintainer-specific portions of Makefiles... no
checking for pwd... /bin/pwd
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for perl5... no
checking for perl... /usr/bin/perl
checking for gmake... no
checking for make... /usr/bin/make
checking if /usr/bin/make is GNU make... yes (3.81)
checking for ranlib... ranlib
checking whether ln -s works... yes
checking for style of include used by /usr/bin/make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking the maximum length of command line arguments... 3458764513820540925
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... (cached) ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exception...

Read more...

Matheus Ramos (matheusramos) wrote :

P.S: I was installing the packages openmpi-bin openmpi-doc libopenmpi-dev

Download full text (6.0 KiB)

Have this in log file:

DKMS make.log for blcr-0.8.2 for kernel 3.2.0-24-generic-pae (i686)
Fri May 4 13:19:48 MSK 2012
make: Entering directory `/usr/src/linux-headers-3.2.0-24-generic-pae'
/var/lib/dkms/blcr/0.8.2/build/Kbuild:19: /var/lib/dkms/blcr/0.8.2/build/module_files: No such file or directory
cd /var/lib/dkms/blcr/0.8.2/build && env -i PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/lib/dkms ./configure --disable-maintainer-mode --with-linux=3.2.0-24-generic-pae --with-installed-libcr --with-installed-util --with-components=modules --prefix=/usr && touch /var/lib/dkms/blcr/0.8.2/build/config-stamp
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to disable maintainer-specific portions of Makefiles... no
checking for pwd... /bin/pwd
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for perl5... no
checking for perl... /usr/bin/perl
checking for gmake... no
checking for make... /usr/bin/make
checking if /usr/bin/make is GNU make... yes (3.81)
checking for ranlib... ranlib
checking whether ln -s works... yes
checking for style of include used by /usr/bin/make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking the maximum length of command line arguments... 805306365
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... (cached) ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
check...

Read more...

Aatish (aatish) wrote :

Got this error when installing package mpich2

asaijo (asaijo) wrote :

BLCR currently doesn't support linux-3.* kernel.

https://hpcrdm.lbl.gov/pipermail/checkpoint/2012-January/000365.html
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=638339

I thought openMPI / MPICH2 package should build without blcr checking point modules.

I installed libmpich-shmem package for MPI programs.

Also while doing

 sudo apt-get purge openmpi-bin libopenmpi-dev

Jim McKim (jmckim) wrote :

Happened when installing openmpi-bin. openmpi-dev installs with no problem.

Frank (franklin82) wrote :

This blcr bus is also present in Ubuntu 12.04

petroo (roosen) wrote :

Happened while defining paragraph layouts in LibreOffice under Ubuntu 12.04

Talib (archaicreality) wrote :

Yeah I just got the error today its Triaged..but what do i do now?

On 22 May 2012 14:07, Talib <email address hidden> wrote:

> Yeah I just got the error today its Triaged..but what do i do now?
>

sudo apt-get purge blcr-dkms

Jingguo Yao (yaojingguo) wrote :

Happens to me when I doing update with ubuntu 12.04.

rybu (rybu) wrote :

I got this problem today on both my computers. My office computer is near vanilla. Like Aatish, I have just installed mpich2. I don't know if that's relevant.

Satish Kamath (satishs-kamath) wrote :

On Wednesday 23 May 2012 11:29 AM, rybu wrote:
> I got this problem today on both my computers. My office computer is
> near vanilla. Like Aatish, I have just installed mpich2. I don't know
> if that's relevant.
>
hey ppl,

Lots of people are encountering this error. I'm happy to see that I'm
not the only 1.

Satish Kamath

Rafael Ortega (rortegao) wrote :

Bug while instaling linux kernel 3.2.0-24-generic in ubuntu 12.04

MatatTHC (matatthc) wrote :

Same here

uname -a
Linux sirius 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Julian Taylor (jtaylor) on 2012-05-28
description: updated
Changed in blcr (Ubuntu):
status: Triaged → Fix Committed
Changed in blcr (Ubuntu):
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
Changed in blcr (Ubuntu):
status: Fix Committed → Confirmed
Phophos (k2n6) on 2012-06-22
description: updated
23 comments hidden view all 103 comments
rybu (rybu) wrote :

Performed a apt-get dist-upgrade today and the problem persists.

Angel Guzman Maeso (shakaran) wrote :

Still happening on Quantal with 0.8.4-2ubuntu1

chemwords (martinus-werts) wrote :

Also still happening on Precise Pangolin 64 bit...(regular auto update with new kernel)
I was happy to see 'Fix Committed', but it has gone back to 'Confirmed'?

This bug was initially filed a year ago, has 248 people affected, with a heat of 1784. When are we going to get a fix?

Angel Guzman Maeso (shakaran) wrote :
Download full text (16.3 KiB)

I would contribute with some advances. This is not a final result, just a WIP on my
intent to fix the problem.

Note: I am not a expert, if you try this, it is under your own risk. This could break
your operating system installation or make it unstable.

This is how I solve the issue for my particular machine, this couldn't be the same
for your machine or kernel.

1) First download the source and uncompress

sudo apt-get source blcr-dkms=0.8.4-2ubuntu1
cd blcr-*

2) As minor warning, from Perl to 5.13.5 or beyond Debian bug #650522 suggests
surrounding each use of qw(…) with rounded parenthesis: (qw(…)). There are a couple on
using on acinclude.m4. So I fixed that for avoid the warning.

Ubuntu shipped on Quantal 5.14.2, so it triggers the warning too:
perl -v | grep "(v"
This is perl 5, version 14, subversion 2 (v5.14.2) built for i686-linux-gnu-thread-multi-64int

3) I discover that the configure has a problem finding the kernel version path.

/usr/src/linux-headers-3.5.0-3-generic/include/linux/version.h

But in only search on other diferent paths with "cr_linux_dir" on acinclude.m4
 without "linux-headers", so I add:

For the first for:
 /usr/src/linux-headers-[$1] \

And for the second:
/usr/src/linux-headers-${cr_tmp_ver} \

That enable the searching on 3.x kernels on ubuntu.

4) Next problem is the instruction:

m4_define([cr_kern_maj_min_patt],[[2\.[46]\.]])[]dnl No SUBLEVEL or following

As pointed on upstream debian bug, it make fails the build (cause of this bug)

I changed to:

m4_define([cr_kern_maj_min_patt],[[3\.[0-9]\.]])[]dnl No SUBLEVEL or following

This enable only for 3.X kernels, it could be improved for allow 2.X and 3.X kernels,
but cafeful because the var cr_kern_maj_min_patt is concatenated for the third
version number.

That enable the part of:

if ((my $uts) = /=${stamp}->"(3\.[0-9]\.[0-9].*)"<-/o) {

For detect the UTS_RELEASE constant.

This constant is defined on
$ cat /usr/src/linux-headers-3.5.0-3-generic/include/generated/utsrelease.h
#define UTS_RELEASE "3.5.0-3-generic"

sudo nano acinclude.m4

sudo ./autogen.sh

5) With this, you can progress configuring the package, but I don't know if it
is a special configuration on my machine (SMP) or others, but it ends with:

======================================================================
Please review the following configuration information:
  Kernel source directory = /usr/src/linux-headers-3.5.0-3-generic
  Kernel build directory = /usr/src/linux-headers-3.5.0-3-generic
  Kernel symbol table = /boot/System.map-3.5.0-3-generic
  Kernel version probed from kernel build = 3.5.0-3-generic
  Kernel running currently = 3.5.0-3-generic
======================================================================
configure: error: Kernel source is configured uni-processor but the kernel symbol table is SMP. Consider specifying a symbol table with --with-system-map or --with-vmlinux. Or, if using kernel sources that are configured by /boot/kernel.h, you may try --with-kernel-type=SMP to force an SMP interpretation of the sources.
$ sudo ./configure --with-system-map
configure: error: Kernel source is configured uni-processor but the kernel symbol table is SMP. Consid...

Angel Guzman Maeso (shakaran) wrote :
Angel Guzman Maeso (shakaran) wrote :
Angel Guzman Maeso (shakaran) wrote :
Angel Guzman Maeso (shakaran) wrote :
Angel Guzman Maeso (shakaran) wrote :
Angel Guzman Maeso (shakaran) wrote :

The attachment "acinclude.m4.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Sasa Paporovic (melchiaros) wrote :

This is also observable on quantal.

It is indicated to get up Angles patch.

@Angle

Are the maintainers already informed? Also the upstream people?

tags: added: quantal
chemwords (martinus-werts) wrote :

During a new auto-upgrade (after vacation, on 64-bit Precise) I actually received the bclr-related error message twice.
For the rest my system is working just fine.

Hello there.
Is the proposed patch is functionnal?
Cheers,
Thibs

Le 25/08/2012 15:12, Thibault Derrien a écrit :
> Hello there.
> Is the proposed patch is functionnal?
> Cheers,
> Thibs
>
For me, apparently yes...

Wilson Jones (rubberpainting) wrote :

Will Ubuntu ever fix the many problems associated with their operating
system that the public has installed?

On Sat, Aug 25, 2012 at 12:33 PM, Xavier Besnard <email address hidden>wrote:

> Le 25/08/2012 15:12, Thibault Derrien a écrit :
> > Hello there.
> > Is the proposed patch is functionnal?
> > Cheers,
> > Thibs
> >
> For me, apparently yes...
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1014198).
> https://bugs.launchpad.net/bugs/804943
>
> Title:
> blcr kernel module failed to build with kernel 3.0 : configure: error:
> --with-linux argument '3.0-x' is neither a kernel version string nor a
> full path
>
> Status in “blcr” package in Ubuntu:
> Confirmed
> Status in “blcr” package in Debian:
> Confirmed
>
> Bug description:
> blcr-dkms 0.8.2 does not work on kernels newer than 2.6.30. 0.8.4 only
> works with 2.6.38.
> If you need this package you must revert to such a kernel, if not simply
> remove it.
>
> TEST CASE:
>
> In Ubuntu 11.10:
>
> sudo apt-get install blcr-dkms
> grep error /var/lib/dkms/blcr/0.8.2/build/make.log
>
> And you will see the error:
>
> configure: error: --with-linux argument '3.0.0-12-generic' is neither
> a kernel version string nor a full path
>
> ORIGINAL DESCRIPTION:
>
> I installed paraview via the synaptic package manager and it gave me
> this error. It says that paraview installed properly and it seems to
> be working perfectly. I am using Ubuntu 11.10.
>
> ProblemType: Package
> DistroRelease: Ubuntu 11.10
> Package: blcr-dkms 0.8.2-15ubuntu1
> ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
> Uname: Linux 3.0-2-generic x86_64
> Architecture: amd64
> Date: Sat Jul 2 16:12:04 2011
> ErrorMessage: blcr kernel module failed to build
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64
> (20110427.1)
> PackageArchitecture: all
> PackageVersion: 0.8.2-15ubuntu1
> SourcePackage: blcr
> Title: package blcr-dkms 0.8.2-15ubuntu1 failed to install/upgrade: blcr
> kernel module failed to build
> UpgradeStatus: Upgraded to oneiric on 2011-07-02 (0 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/blcr/+bug/804943/+subscriptions
>

--
*Janice*

Wilson Jones (rubberpainting) wrote :

Will Ubuntu fix the many problems associated with 12.04, that has caused so
many unfortunate users, such as my self to want to never want to use Ubuntu
again.

On Sat, Aug 25, 2012 at 12:33 PM, Xavier Besnard <email address hidden>wrote:

> Le 25/08/2012 15:12, Thibault Derrien a écrit :
> > Hello there.
> > Is the proposed patch is functionnal?
> > Cheers,
> > Thibs
> >
> For me, apparently yes...
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1014198).
> https://bugs.launchpad.net/bugs/804943
>
> Title:
> blcr kernel module failed to build with kernel 3.0 : configure: error:
> --with-linux argument '3.0-x' is neither a kernel version string nor a
> full path
>
> Status in “blcr” package in Ubuntu:
> Confirmed
> Status in “blcr” package in Debian:
> Confirmed
>
> Bug description:
> blcr-dkms 0.8.2 does not work on kernels newer than 2.6.30. 0.8.4 only
> works with 2.6.38.
> If you need this package you must revert to such a kernel, if not simply
> remove it.
>
> TEST CASE:
>
> In Ubuntu 11.10:
>
> sudo apt-get install blcr-dkms
> grep error /var/lib/dkms/blcr/0.8.2/build/make.log
>
> And you will see the error:
>
> configure: error: --with-linux argument '3.0.0-12-generic' is neither
> a kernel version string nor a full path
>
> ORIGINAL DESCRIPTION:
>
> I installed paraview via the synaptic package manager and it gave me
> this error. It says that paraview installed properly and it seems to
> be working perfectly. I am using Ubuntu 11.10.
>
> ProblemType: Package
> DistroRelease: Ubuntu 11.10
> Package: blcr-dkms 0.8.2-15ubuntu1
> ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
> Uname: Linux 3.0-2-generic x86_64
> Architecture: amd64
> Date: Sat Jul 2 16:12:04 2011
> ErrorMessage: blcr kernel module failed to build
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64
> (20110427.1)
> PackageArchitecture: all
> PackageVersion: 0.8.2-15ubuntu1
> SourcePackage: blcr
> Title: package blcr-dkms 0.8.2-15ubuntu1 failed to install/upgrade: blcr
> kernel module failed to build
> UpgradeStatus: Upgraded to oneiric on 2011-07-02 (0 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/blcr/+bug/804943/+subscriptions
>

--
*Janice*

abohasan (abohasan2) wrote :

Hello.
I think it is OK.
after update no error messages yet

Thanks

On 08/25/2012 04:12 PM, Thibault Derrien wrote:
> Hello there.
> Is the proposed patch is functionnal?
> Cheers,
> Thibs
>

chemwords (martinus-werts) wrote :

If the patch works, when will it be distributed to normal users (i.e. those who do not know how to compile kernels themselves) via the Ubuntu upgrade manager?

I received an software update today (which included a kernel update), and the bclr error message was still there (Ubuntu 12.04 LTS 64-bit, vanilla, but with many software packages installed).

The Ubuntu error handling mechanism redirected me (again) to this Launchpad page. For the rest my system is mostly fine.

Thanks

Graham Inggs (ginggs) on 2012-09-05
description: updated
Sheila Hadley (hadshe) on 2012-09-06
Changed in blcr (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Stefano Rivera (stefanor) wrote :

Sheila: Is this really fixed? Please add some explanation.

Changed in blcr (Ubuntu):
status: Fix Released → Confirmed
Jan Groenewald (jan-aims) wrote :

Well, it looks at least like installing openmpi-checkpoint or libcr0 no
longer
pulls in blcr-dkms, it only suggests it.

Regards,
Jan

On 6 September 2012 12:41, Stefano Rivera <email address hidden> wrote:

> Sheila: Is this really fixed? Please add some explanation.
>
> ** Changed in: blcr (Ubuntu)
> Status: Fix Released => Confirmed
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1002674).
> https://bugs.launchpad.net/bugs/804943
>
> Title:
> blcr kernel module failed to build with kernel 3.0 : configure: error:
> --with-linux argument '3.0-x' is neither a kernel version string nor a
> full path
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/blcr/+bug/804943/+subscriptions
>

--
  .~.
  /V\ Jan Groenewald
 /( )\ www.aims.ac.za
 ^^-^^

rybu (rybu) wrote :

I did a dist-upgrade on Sept 7th, 2012 and the bug is still there.

Jan Groenewald (jan-aims) wrote :

Probably a conflicts with kernels 3.x should be included??
0 jan@muizenberg:/var/autofs/misc/home/jan$apt-cache show blcr-dkms|grep
Conflicts
1 jan@muizenberg:/var/autofs/misc/home/jan$

On 7 September 2012 18:23, rybu <email address hidden> wrote:

> I did a dist-upgrade on Sept 7th, 2012 and the bug is still there.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1002674).
> https://bugs.launchpad.net/bugs/804943
>
> Title:
> blcr kernel module failed to build with kernel 3.0 : configure: error:
> --with-linux argument '3.0-x' is neither a kernel version string nor a
> full path
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/blcr/+bug/804943/+subscriptions
>

--
  .~.
  /V\ Jan Groenewald
 /( )\ www.aims.ac.za
 ^^-^^

Changed in blcr (Ubuntu):
status: Confirmed → Fix Committed
Graham Inggs (ginggs) on 2012-09-12
Changed in blcr (Ubuntu):
status: Fix Committed → Confirmed
Graham Inggs (ginggs) wrote :

Changing back to Confirmed as no fix has been committed.

Everone, please try this:

$ sudo apt-get remove blcr-dkms

chemwords (martinus-werts) wrote :

I have followed Graham Inggs advice, and removed the 'blcr-dkms' package. No other packages seemed to depend on it on my system. I have thus far encountered no problems after removal of said package (Ubuntu 12.04 LTS 64bit)

You will probably not see me again on this Launchpad bug page, as Ubuntu won't send me here anymore on the next update.
Thank you all for your input and good work.

Rick (rickledford) wrote :

I have this problem with Ubuntu 12.04 3.2 kernel. I removed the blcr-dkms package.

romit (romitmitra) wrote :

This error still persists.
I'm on 12.04 LTS 3.2.0-3-32

Daniel Ejsing-Duun (zilvador) wrote :

Got this error just now on 12.10

Lisa Thomas (ganysmom) wrote :

Do I need to do anything about this Alan? I don't know anything about computers.

J. Allen Crider (jacrider) wrote :

I followed the advice to remove the blcr-dkms package and have not
encountered the problem again.

On 11/30/2012 02:04 PM, Lisa Thomas wrote:
> Do I need to do anything about this Alan? I don't know anything about
> computers.
>

Lisa Thomas (ganysmom) wrote :

Thank you Allen!

-Lisa

............................

On Fri, Nov 30, 2012 at 1:55 PM, J. Allen Crider
<email address hidden> wrote:
> I followed the advice to remove the blcr-dkms package and have not
> encountered the problem again.
>
> On 11/30/2012 02:04 PM, Lisa Thomas wrote:
>> Do I need to do anything about this Alan? I don't know anything about
>> computers.
>>
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/804943
>
> Title:
> blcr kernel module failed to build with kernel 3.0 : configure: error:
> --with-linux argument '3.0-x' is neither a kernel version string nor a
> full path
>
> Status in “blcr” package in Ubuntu:
> Confirmed
> Status in “blcr” package in Debian:
> Confirmed
>
> Bug description:
> blcr-dkms 0.8.2 does not work on kernels newer than 2.6.30. 0.8.4 only works with 2.6.38.
> If you need this package you must revert to such a kernel, if not, simply remove it.
> Since blcr 0.8.2-15ubuntu2.1, the blcr-dkms package can be safely removed without wanting to remove libcr0 and openmpi as well, see LP: #1005524.
>
> $ sudo apt-get remove blcr-dkms
>
> -----------------------------------------------------------------------------------------
>
> TEST CASE:
>
> In Ubuntu 11.10:
>
> sudo apt-get install blcr-dkms
> grep error /var/lib/dkms/blcr/0.8.2/build/make.log
>
> And you will see the error:
>
> configure: error: --with-linux argument '3.0.0-12-generic' is neither
> a kernel version string nor a full path
>
> ORIGINAL DESCRIPTION:
>
> I installed paraview via the synaptic package manager and it gave me
> this error. It says that paraview installed properly and it seems to
> be working perfectly. I am using Ubuntu 11.10.
>
> ProblemType: Package
> DistroRelease: Ubuntu 11.10
> Package: blcr-dkms 0.8.2-15ubuntu1
> ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
> Uname: Linux 3.0-2-generic x86_64
> Architecture: amd64
> Date: Sat Jul 2 16:12:04 2011
> ErrorMessage: blcr kernel module failed to build
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
> PackageArchitecture: all
> PackageVersion: 0.8.2-15ubuntu1
> SourcePackage: blcr
> Title: package blcr-dkms 0.8.2-15ubuntu1 failed to install/upgrade: blcr kernel module failed to build
> UpgradeStatus: Upgraded to oneiric on 2011-07-02 (0 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/blcr/+bug/804943/+subscriptions

Changed in blcr (Debian):
status: Confirmed → Fix Released
Changed in blcr (Ubuntu):
status: Confirmed → Fix Released
Paul H. Hargrove (phhargrove) wrote :

What "fix:" has been released?
As the upsteam maintainer I am not aware of any released support for 3.0 or later kernels in blcr.
I am actively working on exactly such support and expect a Beta release of blcr-0.8.5 for testing sometime this week.

The only "fix" detailed in this bug report is to REMOVE the blcr-dkms package, which is NOT a "fix" for the reported problem "blcr kernel module failed to build...". Installing Windows 8 "fixes" the problem in the same manner, but I don't see that as a recommended course of action.

Alan Woodland's release of blcr-0.8.4-3 in Debian is also not a "fix" as it just drops the blcr-dkms package build from the source package. The remaining packages built from the blcr source package now do NOTHING useful except to satisfy a link dependency from some other packages - but cannot provide the intended FUNCTIONALITY without the kernel module.

-Paul

Changed in blcr (Debian):
status: Fix Released → Confirmed
Changed in blcr (Debian):
status: Confirmed → Fix Committed
Changed in blcr (Debian):
status: Fix Committed → Fix Released

There is NO FIX !!! Going back in kernels is NOT A FIX !!!!!

NOT FIXED

N O F I X

CHANGE STATUS -> NOT FIXED

https://upc-bugs.lbl.gov/blcr/doc/html/BLCR_Admin_Guide.html

Berkeley Lab Checkpoint/Restart (BLCR) Administrator's Guide
This guide describes how to install, configure, and maintain Berkeley Lab Checkpoint/Restart (BLCR) for Linux. For usage instructions please see the companion BLCR User's Guide.
1. System Requirements
BLCR consists of two kernel modules, some user-level libraries, and several command-line executables. No kernel patching is required.

BLCR has been engineered to work with a wide range of Linux kernels:

    Many major vendor distributions of Linux. Those tested historically have include SuSE 9.x and OpenSuSE 10.0 though 11.0, CentOS 3.1, and Fedora Core 2 through 10 (Note: this list is NOT exclusive).
    Many "vanilla" Linux 2.6.x kernels (from kernel.org) have also been tested with many glibc versions (2.2 through 2.9).
    We believe vanilla versions 2.6.0 through 2.6.38 all work.
    BLCR uses a set of autoconf-based feature tests to probe the kernels it builds against. It is thus likely that a custom kernel based on one of the above kernel sources will work with BLCR, provided that patches applied to the kernel don't invalidate assumptions BLCR has made.

BLCR uses assembly code to save some program state (most notably the CPU registers). This means that the BLCR kernel modules are not portable across CPU architectures "out of the box". BLCR has long supported the x86 and x86_64 architectures. The 0.6.0 release was the first to include experimental support for PowerPC64 and for ARM, while the 0.7.0 release added experimental support for 32-bit PowerPC. Currently x86 and x86_64 systems are the most fully tested with BLCR, with the other architectures tested heavily only at release time. Porting BLCR to a different CPU is not a large software effort if one has sufficient Linux kernel experience and knowledge of the target CPU's ABI and instructions. Please contact us if you are interested in contributing a port. We are especially interested in somebody with the time and equipment to complete the unfinished port to SPARC64.

We need new status, Product Not Compatible,....
.... there is no solution to problem until someone dose new blcr version,...

Having blcr-* packages at distribution is miss leading and those should be removed
from ditribution OR CLEARLY MARKED AS:

UN-FUNCTIONAL, package held to keep depencyes,... still if some software
needs functionality this practice causes again problems,... best pratice to remove
blcr until it's functional.

YES, blcr could be if possibel depend oleder version, 2.38.**** and down,...

Paul H. Hargrove (phhargrove) wrote :

Joni-Pekka,

For those folk that saw this error when upgrading their system, but only had BLCR's kernel modules installed due to a "recommends" from another package, removal of the blcr-dkms package was (and still is) a viable solution. For those who need a *functional* BLCR, it was initially reasonable to expect them hold back updates of their kernel - but too much time has passed for that to be a good solution anymore. While not "fixes" in the sense of making BLCR work on the current kernels, these were both well-intentioned and appropriate work-arounds when they were posted.

If you had consulted the mailing list for the BLCR project, you would know that support for kernels through 3.7.1 is currently in Beta testing. [See https://hpcrdm.lbl.gov/pipermail/checkpoint/2013-January/000550.html for the latest]

If you had followed the link at the top of this bug report to the corresponding Debian bug (#638339), or had consulted packages.debian.org, you would know that the blcr-0.8.5~b2 (beta) is already in Debian Experimental. This is the reason for the Bug Update Watcher item that immediately precedes your first comment. I understand that Alan plans to upload the latest (0.8.5~b4) this weekend.

I understand your frustration at the limited expressiveness of Status, and as the lead developer of BLCR I had also complained (in comment #96, the last human-generated comment before yours) that dropping the blcr-dkms from the distribution (to satisfy lib dependencies in other packages w/o rebuilding them) was not a Fix. HOWEVER things have progressed since then and, as I understand it, the acceptance of the BLCR beta into Debian Experimental completely justifies the current "Fix Released" status.

So, if you are in need of a working BLCR your best course of action at this time is NOT to post multiple angry messages to this bug report. Instead, you should contribute to the testing of the Beta release - and report your success or failure here, on the Debian bug system, or on the BLCR mailing list. Sufficient testing is the best way to help this package progress out of Experimental.

-Paul

Download full text (21.1 KiB)

dear Paul,

I'am not angry. Linux is volunteer based system
and if someone ( quite many ) dose something
that's great.

Even I have read bug report, been Alan's pages as
weel BLRC home,.... I could not figure out there
is experimental version available !!

I have wordblindness but that only help's me that
I do not see small errors.

This case I got uncorrect information.

But what you write 200% true, thanks paul
i will download test expreimental version!!!

Experimental version did not work at my machine
also removing it was painful !

joni

===============

#ubuntu 12.4 LTS
sudo apt-get update
sudo apt-get upgrade
#sudo apt-get install linux-sources linux-header
wget https://upc-bugs.lbl.gov/blcr-dist/blcr-0.8.5_b4.tar.gz
#we assume you have kernel at default location
make clean
sudo ./configure --with-system-map=/boot/System.map-3.2.0-35-generic
sudo make
sudo make install
sudo chmod -R 775 /mpi3/C2/blcr-0.8.5_b4

=================

host: mpi1

==================================================================================================
mpiexec options:
----------------
  Base path: /mpi3/C2/mpich2-1.5/bin/
  Launcher: (null)
  Debug level: 1
  Enable X: -1

  Global environment:
  -------------------
    MUMPS=/mpi3/S2/MUMPS_4.10.0
    LC_PAPER=fi_FI.UTF-8
    LC_ADDRESS=fi_FI.UTF-8
    SSH_AGENT_PID=3750
    LC_MONETARY=fi_FI.UTF-8
    MUMPS_I=/mpi3/C2/MUMPS_4.10.0
    GPG_AGENT_INFO=/tmp/keyring-qtrpvR/gpg:0:1
    TERM=xterm
    SHELL=/bin/bash
    XDG_SESSION_COOKIE=6d6390cb56a32b6678c10da600000412-1358089517.620726-1634397259
    JPK_NETGEN=/mpi3/C2/netgen_623
    JPK_VER_S=S2
    HYDRA_CKPOINTLIB=blcr
    HYDRA_CKPOINT_INTERVAL=10
    WINDOWID=50331655
    LC_NUMERIC=fi_FI.UTF-8
    HYDRA_CKPOINT_PREFIX=/mpi3/chekpoint/default.chk
    GNOME_KEYRING_CONTROL=/tmp/keyring-qtrpvR
    JPK_ELMER=/mpi3/C2/elmer_6003
    PARDISO_LIC_PATH=/mpi3/C2/pardiso
    METIS_INCLUDE_DIR=/mpi3/C2/ParMetis-3.2.0
    JPK_NETGEN_S=/mpi3/S2/netgen_623
    USER=joni
    LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*...

junior0 (igor-travov-gmail) wrote :

I installed/reinstalled blcr-dkms because my bluetooth acer mouse on my Acer S7 Intel® Core™ i7-3517U CPU @ 1.90GHz × 4 and Ubuntu 12.04 LTS doesn-t works. Sometime after some mantras it(mouse) appier in bluetooth configurator (installer), but
almost all times it (mouse) not installed (not determinated). The functio -- install new bluetooth unit -- does not wors.!

Displaying first 40 and last 40 comments. View all 103 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.