Ubuntu

[apport] blam.exe crashed with SIGSEGV

Reported by Sunn3K7aas on 2007-03-21
8
Affects Status Importance Assigned to Milestone
blam (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: blam

Blam crashes when trying to update feeds in the freedesktop.org channel.
Ubunutu 7.04 (Feisty Fawn)
blam 1.8.4

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Wed Mar 21 13:11:24 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/lib/blam/blam.exe
InterpreterPath: /usr/bin/mono
Package: blam 1.8.4-0ubuntu1
PackageArchitecture: i386
ProcCmdline: blam /usr/lib/blam/blam.exe
ProcCwd: /home/alex
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
 LANGUAGE=en_US:en
Signal: 11
SourcePackage: blam
Stacktrace:
 #0 0x0808df9c in ?? ()
 #1 0xb1f55b28 in ?? ()
 #2 0xb6079f59 in ?? () from /usr/lib/firefox/libgtkembedmoz.so
 #3 0x08605f40 in ?? ()
 #4 0x00000000 in ?? ()
StacktraceTop:
 ?? ()
 ?? ()
 ?? () from /usr/lib/firefox/libgtkembedmoz.so
 ?? ()
 ?? ()
Uname: Linux sokka 2.6.20-12-generic #2 SMP Sun Mar 18 03:07:14 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev scanner video

Sunn3K7aas (shiroi-tsubasa) wrote :

StacktraceTop:mono_arch_ip_from_context (sigctx=0x0) at exceptions-x86.c:748
sigsegv_signal_handler (_dummy=11, info=0x1548, context=0x0) at mini.c:11106
nsProfileLock::FatalSignalHandler (signo=11) at nsProfileLock.cpp:210

?? ()

Changed in blam:
importance: Undecided → Medium
Simone Tolotti (simontol) wrote :

Same here on Gutsy!
It crashes several times when doing normal operations such as update feeds.

Platform Hardy i386

I launched blam. Read some news. It crashed.
I reloaded blam and it crashed soon after it displayed its windows.

Carlos Martín Nieto (cmn) wrote :

From the trace, it looks like it fails in the xul/firefox library.

Daniel T Chen (crimsun) wrote :

I can't confirm this symptom in 9.04. Please set the status to:
1) New if reproducible in a supported or development Ubuntu version, or
2) Invalid if you cannot reproduce it in a supported or development Ubuntu version.

Changed in blam:
status: New → Incomplete
Simone Tolotti (simontol) wrote :

On Intrepid blam (1.8.5-1ubuntu1) libgecko2.0-cil (0.13-1ubuntu2) it crashes on startup:
simone@simone-desktop:~$ blam

** (Blam:8629): WARNING **: The following assembly referenced from /usr/lib/blam/blam.exe could not be loaded:
     Assembly: gecko-sharp-dependent (assemblyref_index=13)
     Version: 2.0.0.0
     Public Key: ccf7d78a55e9f021
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/usr/lib/blam).

** (Blam:8629): WARNING **: Could not load file or assembly 'gecko-sharp-dependent, Version=2.0.0.0, Culture=neutral, PublicKeyToken=ccf7d78a55e9f021' or one of its dependencies.

Unhandled Exception: System.TypeLoadException: A type load exception has occurred.
  at Imendio.Blam.Application..ctor (System.String[] args, System.Object[] props) [0x00000]
  at Imendio.Blam.Application.Main (System.String[] args) [0x00000]

Changed in blam:
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers