[FFe] Please merge Blam 1.8.6 from Debian Unstable

Bug #339863 reported by Jo Shields on 2009-03-09
6
Affects Status Importance Assigned to Milestone
blam (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: blam

Despite having been updated for the Mono 2.0 transition, Blam appears to still have 1.0 dependencies. This has been tracked down - to a binary-only library on orig.tar.gz. This has been replaced in the latest upstream with some equivalent (but incompatible) source.

In addition, the rendering engine has been switched from the troublesome (and abandoned upstream) Gecko#, to the up-and-coming Webkit# (which has fringe benefits such as easier compilation and becoming arch-all instead of arch-any).

I'm requesting a FFe for Blam, primarily to address the first issue (where the second issue comes in as a consequence).

I've tested compilation, installation & execution in a Jaunty VM, and it seems fine; it has no rdeps. I don't forsee any problems (or at the very least I can't see it being made worse than it is now, with binary-only components shipped in the package source)

Related branches

Jo Shields (directhex) wrote :

Merge patch attached

Jo Shields (directhex) wrote :

Upstream changelog diff attached

Jo Shields (directhex) wrote :

Build log attached

Luca Falavigna (dktrkranz) wrote :

Fine for me, ACK #1.

Changed in blam:
importance: Undecided → Wishlist
Jo Shields (directhex) wrote :

Install log attached

Jo Shields (directhex) wrote :

Screenshot attached

Iulian Udrea (iulian) wrote :

ACK #2

Exception granted.

Changed in blam:
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

Jo: you seem to be throwing a bunch of changelog history away:
daniel@bert:~$ diff -ruN blam-1.8.{5,6}/debian/changelog | diffstat
 changelog | 115 ++++++++++++++++++++++----------------------------------------
 1 file changed, 41 insertions(+), 74 deletions(-)
daniel@bert:~$

Jo Shields (directhex) wrote :

You're right, I did. Try this one instead

Daniel Holbach (dholbach) wrote :

Looks good. The only thing you're missing seems to be debian/patches/PlanetUbuntu.patch

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package blam - 1.8.6-2ubuntu1

---------------
blam (1.8.6-2ubuntu1) jaunty; urgency=low

  * Merge from Debian Unstable (LP: #339863), remaining Ubuntu changes:
    + debian/control:
      - Update for Gnome# 2.24 transition
    + debian/patches/PlanetUbuntu.patch: add planet.ubuntu.com.

blam (1.8.6-2) unstable; urgency=low

  * debian/rules:
    + Call dh_clideps for arch:all packages too, as blam went from arch:any
      to arch:all. All binary dependecies were missing because of this.
    + Added call for dh_clistrip and dh_clifixperms and removed manual the
      chmod +x call.
  * debian/control:
    + Bumped cli-common-dev build-dep to >= 0.4.9 as we use dh_clistrip of
      it now.

blam (1.8.6-1) unstable; urgency=low

  [ Carlos Martín Nieto ]
  * New upstream release.
    - Do not ship RSS.NET.dll anymore (Closes: #473626).
    - Don't use libxul anymore (Closes: #480790).
    - Resize the channel title column (Closes: #292461).
    - Register with GNOME session manager (Closes: #319302).
    - Show a conetext menu (Closes: #326993, #342226).
  * debian/control: Don't depend on anything gecko. Blam is now Arch: all.
    Make the dependecies arch-independent.
  * debian/rules: Remove lib/RSSFeed.dll upon cleanup.
  * debian/control: Transition to Mono 2.0 (depend on mono-devel) (Closes: #518416).
  * debian/control: Transfer package to CLI Applications Team.

  [ Mirco Bauer ]
  * debian/control:
    + Added Vcs-* fields.
    + Pass MCS and GMCS overrides to configure call.

 -- Jo Shields <email address hidden> Mon, 09 Mar 2009 10:55:41 +0000

Changed in blam:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers