BKchem using python2.6 crashed with SIGSEGV in Tcl_CreateHashEntry()

Bug #380346 reported by Matthias Mailänder on 2009-05-25
80
This bug affects 12 people
Affects Status Importance Assigned to Milestone
bkchem (Ubuntu)
Medium
Unassigned
blt (Debian)
Fix Released
Unknown

Bug Description

Binary package hint: bkchem

Whenever I click "file-properties", "info" or "options" (all of them open a new window) I get a segmentation fault on Ubuntu 9.04 using BKchem 12.2 (tried 0.12.6, 0.12.5, 0.12.4, 0.13.0 too).

ProblemType: Crash
Architecture: i386
Dependencies:
 libgcc1 1:4.3.3-5ubuntu4
 zlib1g 1:1.2.3.3.dfsg-12ubuntu2
 gcc-4.3-base 4.3.3-5ubuntu4
 findutils 4.4.0-2ubuntu4
 libc6 2.9-4ubuntu6
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/python2.6
Package: python2.6-minimal 2.6.2-0ubuntu1
ProcCmdline: python -m bkchem/bkchem
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: python2.6
StacktraceTop:
 ?? () from /usr/lib/libtcl8.5.so.0
 Tcl_CreateHashEntry () from /usr/lib/libtcl8.5.so.0
 Tcl_FindHashEntry () from /usr/lib/libtcl8.5.so.0
 Tcl_FindNamespaceVar () from /usr/lib/libtcl8.4.so.0
 TclLookupSimpleVar () from /usr/lib/libtcl8.4.so.0
Title: python2.6 crashed with SIGSEGV in Tcl_CreateHashEntry()
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin mythtv plugdev sambashare scanner tape video

visibility: private → public

This is just an apport crash report for https://savannah.nongnu.org/bugs/index.php?26622

We tracked down the error. If there is an older version of Tcl (8.4) in the system which conflicts with the new 8.5 version then BKchem crashes. So the package tk8.4 could be added to the bkchem debian package as a conflict.

Changed in bkchem (Ubuntu):
status: New → In Progress

These reports are IMO all related and the culprit seems to be blt (via python-pmw):

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=525860
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=524149
https://bugs.launchpad.net/ubuntu/+source/blt/+bug/359857

I'm not in favor of introducing a conflicts-relationship, just because a package has bugs.

Other reported crashes for bkchem are reproducible in this scenario too and have been marked as duplicates of this report.

StacktraceTop:HashVarKey (tablePtr=0x96ed098, keyPtr=0xb66194ef)
Tcl_CreateHashEntry (tablePtr=0x96ed098,
Tcl_FindHashEntry (tablePtr=0x96ed098,
Tcl_FindNamespaceVar (interp=0x96f2a08,
TclLookupSimpleVar (interp=0x96f2a08,

Changed in bkchem (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
newbuntu (dsglass) wrote :

Matthias Mailänder: Thanks, I removed tk8.4 and that fixed the problem. Both tk8.4 and tk8.5 were installed.

Changed in blt (Debian):
status: Unknown → New
Changed in blt (Debian):
status: New → Fix Released
Harbin (harbin) wrote :

I confirm that the patch above works on Ubuntu 9.10.

Made following modifications to /usr/lib/blt2.4/pkgIndex.tcl file:

if {[package vcompare [info tclversion] 8.2] < 0} {
 set taillib ${version}.so.8.0
} elseif {[package vcompare [info tclversion] 8.3] < 0} {
 set taillib ${version}.so.8.2
} elseif {[package vcompare [info tclversion] 8.4] < 0} {
 set taillib ${version}.so.8.3
} elseif {[package vcompare [info tclversion] 8.5] < 0} {
 set taillib ${version}.so.8.4
} else {
 set taillib ${version}.so.8.5
}

Sorry for not sending a diff, that one should do.

Fixed in blt 2.4z-4.2.

Changed in bkchem (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.