Missing package dependencies in bittorrent-gui

Bug #66795 reported by Quinn Weaver on 2006-10-18
18
Affects Status Importance Assigned to Milestone
bittorrent (Ubuntu)
High
anyos
Gutsy
High
Unassigned
Hardy
High
Unassigned

Bug Description

Binary package hint: bittorrent-gui

SRU Request:

1) This bug makes the bittorrent package completely unusable as reported by many users in this and some other bug reports.
2) A fix has been already uploaded for the current development branch (hardy). Version uploaded is 3.4.2-11ubuntu3 and the debdiff used can be found at this link: http://launchpadlibrarian.net/10156004/bittorrent_3.4.2-11ubuntu3.debdiff
3) A debdiff for gutsy-proposed has been already prepared and can be found at http://launchpadlibrarian.net/10156009/bittorrent_3.4.2-11ubuntu3%7E7.10.debdiff
4) To reproduce the bug, just follow this small steps:
4a. apt-get install gutsy package (version 3.4.2-11ubuntu2)
4b. open up your terminal and run btdownloadgui.bittorrent
4c. you'll receive this output:

Could not load wxPython. In order to use this script,
you must have wxPython installed. It is available in
the package libwxgtk2.4-python.

I am now going to attempt to run xmessage to alert
GUI users.
/usr/share/bittorrent/nowxmsg: Nessun file o directory
xmessage: problems reading message file
Traceback (most recent call last):
  File "/usr/bin/btdownloadgui.bittorrent", line 27, in <module>
    sys.exit(-1)
NameError: name 'sys' is not defined

Alex Sutcliffe (alex.sutcliffe) wrote :

Hi Quinn,
Can you tell which versions of Ubuntu and bittorrent-gui you're using?

I'm using edgy and 3.4.2-6ubuntu3. An apt-cache show gives

..
Depends: python (>= 2.4), python (<< 3), bittorrent (>= 3.4.2-1), python-wxgtk2.
4 | python-wxgtk2.6
..

When I first installed bittorrent-gui it pulled in python-wxgtk2.4 and it worked fine. However I was able to re-create the error by doing installing python-wxgtk2.6 and then removing python-wxgtk2.4. bittorrent-gui dependencies were still met but I got the same error as above.

Looking at /usr/bin/btcompletedirgui.bittorrent this seems to be the problem:

...

try:
        import wxversion
        wxversion.select('2.4')
        from wxPython.wx import *
except:
        print 'Could not load wxPython. In order to use this script,'
        print 'you must have wxPython installed. It is available in'
        print 'the package libwxgtk2.4-python.'
...

I'm afraid I don't know the correct way to resolve this.

Changed in bittorrent:
status: Unconfirmed → Confirmed

On Wed, Oct 18, 2006 at 08:33:09PM -0000, Alex Sutcliffe wrote:
> Hi Quinn,
> Can you tell which versions of Ubuntu and bittorrent-gui you're using?
>
> I'm using edgy and 3.4.2-6ubuntu3. An apt-cache show gives
>
> ..
> Depends: python (>= 2.4), python (<< 3), bittorrent (>= 3.4.2-1), python-wxgtk2.
> 4 | python-wxgtk2.6
> ..
>
> When I first installed bittorrent-gui it pulled in python-wxgtk2.4 and
> it worked fine. However I was able to re-create the error by doing
> installing python-wxgtk2.6 and then removing python-wxgtk2.4.
> bittorrent-gui dependencies were still met but I got the same error as
> above.

You're right... I already had python-wxgtk2.6 installed at the point
when I installed bittorrent-gui, so I ended up with the problem
behavior.

The problem is that bittorrent-gui requires python-wxgtk2.4 _or_
python-wxgtk2.6. However, as you pointed out, the code insists on
version 2.4:

> Looking at /usr/bin/btcompletedirgui.bittorrent this seems to be the
> problem:
>
> ...
>
> try:
> import wxversion
> wxversion.select('2.4')
> from wxPython.wx import *
> except:
> print 'Could not load wxPython. In order to use this script,'
> print 'you must have wxPython installed. It is available in'
> print 'the package libwxgtk2.4-python.'
> ...
>
> I'm afraid I don't know the correct way to resolve this.

I think we should trust the code. If it's asking for version 2.4,
it's probably doing so for a good reason. The dependencies should
be changed so that bittorrent-gui requires python-wxgtk2.4 specifically,
not "python-wxgtk2.4 or python-wxgtk2.6". That's just my take...

Quinn Weaver (quinnweaver) wrote :

On Wed, Oct 18, 2006 at 08:33:09PM -0000, Alex Sutcliffe wrote:
> Hi Quinn,
> Can you tell which versions of Ubuntu and bittorrent-gui you're using?

Oops, forgot to say: Ubuntu Dapper and bittorrent-gui 3.4.2-6ubuntu2
(from universe).

Martin Pool (mbp) wrote :

Confirmed in feisty. If you just install bittorrent-gui, it's not usable, and when run from the gui (eg as a mime handler from firefox) it silently fails:

mbp@hope% Could not load wxPython. In order to use this script, ~/movies 11:53AM
you must have wxPython installed. It is available in
the package libwxgtk2.4-python.

I am now going to attempt to run xmessage to alert
GUI users.
/usr/share/bittorrent/nowxmsg: No such file or directory
xmessage: problems reading message file
Traceback (most recent call last):
  File "/usr/bin/X11/btdownloadgui.bittorrent", line 27, in <module>
    sys.exit(-1)
NameError: name 'sys' is not defined

Albin Tonnerre (lutin) on 2007-04-11
Changed in bittorrent:
assignee: nobody → lutin
Albin Tonnerre (lutin) on 2007-04-17
Changed in bittorrent:
status: Confirmed → In Progress
Albin Tonnerre (lutin) on 2007-10-02
Changed in bittorrent:
assignee: lutin → nobody
status: In Progress → Triaged
Cory Albrecht (bytor) wrote :

This error is still happening in 7.10-desktop-amd6. Even installing python-wxgtk2.4 does not solve the problem. How is this still not fixed over a year after being first reported?

[cory@snowdog] 18:45:54 [3]~> /usr/bin/btdownloadgui.bittorrent
Could not load wxPython. In order to use this script,
you must have wxPython installed. It is available in
the package libwxgtk2.4-python.

I am now going to attempt to run xmessage to alert
GUI users.
/usr/share/bittorrent/nowxmsg: No such file or directory
xmessage: problems reading message file
Traceback (most recent call last):
  File "/usr/bin/btdownloadgui.bittorrent", line 27, in <module>
    sys.exit(-1)
NameError: name 'sys' is not defined

Cameron Dale (camrdale) wrote :

The debian package works fine in ubuntu gutsy, and they are using python-wxgtk2.6. The only thing stopping this package from working was the ubuntu change that used wxversion to try and select python-wxgtk2.4. I created a new package for ubuntu that removes this change and uploaded it to REVU. You can find it here:

http://revu.tauware.de/details.py?upid=393

Attached is the debdiff for bittorrent_3.4.2-11ubuntu2 to bittorrent_3.4.2-11ubuntu3 to fix this bug.

Andrea Veri (av) wrote :

Cameron, I think we should request an SRU for this as far as it's not usable in gutsy. So it would be nice to have a debdiff with gutsy-proposed release, and the SRU need to be documented inside your changelog's entry, maybe writing the bug number for a faster review of archive-admins. Anyway I've already pinged Alexander (asac) for this and it will be processed tomorrow.

Plus I'm linking this bug to another duplicate, which is Bug #155583 that reports the same issue as here.

Changed in bittorrent:
importance: Undecided → Medium
status: Triaged → Confirmed
Cameron Dale (camrdale) wrote :

I updated the debdiff to use gutsy-proposed as the release, and removed the duplicate bug number from the changelog entry.

Alexander Sack (asac) on 2007-10-24
Changed in bittorrent:
importance: Medium → High
Alexander Sack (asac) on 2007-10-24
Changed in bittorrent:
importance: Undecided → High
status: New → Confirmed
Alexander Sack (asac) wrote :
Changed in bittorrent:
status: Confirmed → Fix Committed
Alexander Sack (asac) wrote :
Cameron Dale (camrdale) wrote :

bittorrent (3.4.2-11ubuntu3) hardy; urgency=low

  * Revert the change that used wxversion to select the python-wxgtk
    version to use. (LP: #66795)

 -- Cameron Dale <email address hidden> Sun, 21 Oct 2007 17:28:45 -0700

Changed in bittorrent:
status: Fix Committed → Fix Released
Alexander Sack (asac) wrote :

Cameron or Andrea, could you please add a comprehensive summary to this bug (edit summary for that) so the sru team can review it easily?

You can find the points needed at https://wiki.ubuntu.com/StableReleaseUpdates (1. proposed)

Thanks,

 - Alexander

Andrea Veri (av) wrote :

Bug description updated matching the SRU request upload to -proposed. Thanks.

description: updated
Alexander Sack (asac) wrote :

thanks ... i tested that now the gui starts and uploaded to gutsy-proposed.

Martin Pitt (pitti) wrote :

Accepted into gutsy-proposed. Please test.

Changed in bittorrent:
status: Confirmed → Fix Committed

I've tested the package and the bug seems to be fixed now! Thanks

Daniel Hahler (blueyed) wrote :

I can confirm that the bug is fixed with the new package from gutsy-proposed, too.

Martin Pitt (pitti) wrote :

Copied to gutsy-updates.

Changed in bittorrent:
status: Fix Committed → Fix Released
anyos (anyos-abv) on 2011-01-10
Changed in bittorrent (Ubuntu):
assignee: nobody → anyos (anyos-abv)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers