[SRU] biosdevname returns identical names for two different devices.

Bug #1324558 reported by Jorge Niedbalski on 2014-05-29
118
This bug affects 47 people
Affects Status Importance Assigned to Milestone
biosdevname (Ubuntu)
Undecided
Unassigned
Saucy
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

SRU justification :

The 'addslot' function can return the same value for two or more interfaces (same dev->index_in_slot), causing the interfaces on a given PCI slot get same port number. This could trigger a rename to a different name space (such as rename*) presented on LP: #1284043.

Example problematic behavior:

# biosdevname -i em1
em1
# biosdevname -i em2
em3
# biosdevname -i em3
em4
# biosdevname -i rename3
em2

Another user points:

On first reboot the names are different. eth0 renamed to p4p1 and eth1 renamed to p4p2
then on next reboot eth0 renamed to p4p1 and eth1 renamed to rename3

Impact :

Without this SRU users will experience erroneous output from biosdevname ( renamed interfaces) as noticed on LP: #1293633 and LP: #1284043

Fix :

Apply fix from upstream project.

Origin: upstream, http://linux.dell.com/cgi-bin/gitweb/gitweb.cgi?p=biosdevname.git;a=commit;h=0bc6ce6d8da61153e7bfd1c3444ab06c0c83d0af
Bug: https://bugzilla.redhat.com/show_bug.cgi?id=782145

Test Case :

1) Have one or more PCI ethernet cards attached
2) Have one or more onboard ethernet cards available.
3) Run biosdevname -d and notice the renamed interfaces.

If you get some rename* interfaces this bug isn't fixed, if you can see the correct bios hardware names associated with the interface, it's fixed.

Regression :

None expected

Description of the problem :

See justification

description: updated
description: updated
description: updated
Changed in biosdevname (Ubuntu):
status: New → In Progress
Changed in biosdevname (Ubuntu Saucy):
status: New → In Progress
Changed in biosdevname (Ubuntu Trusty):
status: New → In Progress
summary: - SRU for biosdevname returns identical names for two different devices.
+ [SRU] biosdevname returns identical names for two different devices.
description: updated
description: updated
Chris J Arges (arges) wrote :

Can you make the patch look more like the upstream patch:
http://linux.dell.com/cgi-bin/gitweb/gitweb.cgi?p=biosdevname.git;a=patch;h=0bc6ce6d8da61153e7bfd1c3444ab06c0c83d0af;hp=11d0ae50aadeb2917dffc809f8bd2f4a78089675

There is a difference from the patch you provided and this.
In addition when you re-submit please add proper headers to the patch:
http://dep.debian.net/deps/dep3/

Thanks

Jorge Niedbalski (niedbalski) wrote :
description: updated
Jorge Niedbalski (niedbalski) wrote :

Hello arges,

I updated the patch pointing to the right upstream commit, also i added the required dep3 headers
on the patch.

Could you please re sponsor-patch this one?

Colin Watson (cjwatson) wrote :

Thanks. There are a few formatting details to fix up, but I'll take care of those.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package biosdevname - 0.4.1-0ubuntu7

---------------
biosdevname (0.4.1-0ubuntu7) utopic; urgency=high

  * Backport upstream patch to fix regression introduced by the addslot
    function, which caused biosdevname to return identical names for two
    different devices (LP: #1324558).
 -- Jorge Niedbalski <email address hidden> Wed, 04 Jun 2014 14:58:23 +0100

Changed in biosdevname (Ubuntu):
status: In Progress → Fix Released

Hello Jorge, or anyone else affected,

Accepted biosdevname into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/biosdevname/0.4.1-0ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in biosdevname (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done-trusty verification-needed-saucy
removed: verification-needed
James Page (james-page) wrote :

Un-subscribing ubuntu-sponsors - all sponsor work done.

Breen Hagan (breenh) wrote :

I saw this in 12.04 for the first time today after updating the system (not sure if that's relevant or just a coincidence). Any chance this fix can be added to 12.04?

Shang Wu (shangwu) wrote :

Hi Breen,

As stated in comment #11, Can you enable to propose repo and update this package and see if this fixes your issue?

Shang Wu (shangwu) wrote :

Assuming this is the same patch from:
https://bugs.launchpad.net/ubuntu/+source/biosdevname/+bug/1284043/comments/26

That package works for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package biosdevname - 0.4.1-0ubuntu6.1

---------------
biosdevname (0.4.1-0ubuntu6.1) trusty; urgency=high

  * Backport upstream patch to fix regression introduced by the addslot
    function, which caused biosdevname to return identical names for two
    different devices (LP: #1324558).
 -- Jorge Niedbalski <email address hidden> Wed, 04 Jun 2014 14:58:23 +0100

Changed in biosdevname (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for biosdevname has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Hello Jorge, or anyone else affected,

Accepted biosdevname into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/biosdevname/0.4.1-0ubuntu5.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in biosdevname (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
Justin Shepherd (jshepher) wrote :

I don't believe this bug has been fixed. I am running on 14.04.1 with the latest biosdevname package and am still seeing the issue:

# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.1 LTS"

# dpkg -l | grep biosdevname
ii biosdevname 0.4.1-0ubuntu6.1 amd64 apply BIOS-given names to network devices

# lshw -businfo -C network
Bus info Device Class Description
=======================================================
pci@0000:03:00.0 p1p1 network 82599ES 10-Gigabit SFI/SFP+ Network Connection
pci@0000:03:00.1 p1p2 network 82599ES 10-Gigabit SFI/SFP+ Network Connection
pci@0000:08:00.0 rename9 network MT27500 Family [ConnectX-3]

# ifconfig -a | grep HWaddr
p1p1 Link encap:Ethernet HWaddr 90:e2:ba:2f:7c:68
p1p2 Link encap:Ethernet HWaddr 90:e2:ba:2f:7c:69
p9p1 Link encap:Ethernet HWaddr 00:02:c9:d3:3b:5e
rename9 Link encap:Ethernet HWaddr 00:02:c9:d3:3b:5f

# biosdevname -i p9p1
# biosdevname -i rename9
p9p1

David Medberry (med) wrote :

This issue still exists. At each boot it does an interface rename (dl380p Gen8 with two 10G nics)

Jorge Niedbalski (niedbalski) wrote :

Interesting, this has been working perfect for a while using this patch , i noticed that this is happening again after upgrade to kernel 3.13.0-30 , https://bugs.launchpad.net/bugs/1284043

We need to review what change reactivated this misbehavior.

tags: added: cts
tags: removed: verification-needed
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in biosdevname (Ubuntu Saucy):
status: Fix Committed → Won't Fix
Andrey Petrov (mohsen47) wrote :

How can I apply the fix.
This url http://linux.dell.com/cgi-bin/gitweb/gitweb.cgi?p=biosdevname.git;a=commit;h=0bc6ce6d8da61153e7bfd1c3444ab06c0c83d0af gives me Server not found error.

I am using Ubuntu Server 14.04 trusty release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers