Ubuntu

Please sync bioperl 1.6.0-1 (universe) from Debian experimental (main).

Reported by David Paleino on 2009-02-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bioperl (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/bioperl
 status new
 importance wishlist
 subscribe ubuntu-universe-sponsors

Please sync bioperl 1.6.0-1 (universe) from Debian experimental (main).

Changelog since current jaunty version 1.5.2.102-3:

bioperl (1.6.0-1) experimental; urgency=low

  [ Charles Plessy ]
  * debian/control
    - Updated dependancies according to the new upstream release.
    - Added the CPAN dependancies of BioPerl to Build-Depends-Indep in order to
      run the tests at build time.
    - Added bioperl-run to the recommended packages.
    - Updated my email address.
    - Uses Debhelper 7 (debian/compat modified accordingly).
  * debian/patches: removed as not needed (no downloads by default).
  * debian/rules:
    - Uses Build.PL instead of Makefile.PL.
    - Tests disabled for the experimental upload: not all dependancies are available yet.
  * debian/README.{Debian,source}: removed as not needed anymore
  * debian/watch: BioPerl is now mixed case.

  [ David Paleino ]
  * New upstream stable release:
    - fixes Bio::AlignIO::next_aln bug (Closes: #266921).
    - New modules, deprecated modules,… please consult Upsteam documents in
      /usr/share/doc/bioperl.
  * debian/control:
    - fields values rewrapped to easily spot diffs in commit mails
    - dropped B-D-I versioning on perl, since Etch already has a greater
      version
    - Standards-Version bumped to 3.8.0 (no changes needed).

 -- Charles Plessy <email address hidden> Mon, 26 Jan 2009 12:58:28 +0900

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)

iEYEARECAAYFAkmF22EACgkQ5qqQFxOSsXRyfQCgoBfmCGWgjm8901WDpwx4TPs8
WqQAn3tJxa32pDDrWLVG8E0CtdbDODZC
=YL2R
-----END PGP SIGNATURE-----

Iulian Udrea (iulian) wrote :

It FTBFS on i686.

Installing /tmp/buildd/bioperl-1.6.0/debian/bioperl/usr/bin/bp_taxonomy2tree.pl
Writing /tmp/buildd/bioperl-1.6.0/debian/bioperl/usr/lib/perl5/i486-linux-gnu-thread-multi/auto/Bio/.packlist
/usr/bin/perl maintenance/symlink_script.pl
Will try to install symlinks to /usr/local/bin
find debian/bioperl -type f -name .packlist | xargs rm
rmdir /tmp/buildd/bioperl-1.6.0/debian/bioperl/usr/lib/perl5/powerpc-linux-gnu-thread-multi/auto/Bio/
rmdir: failed to remove `/tmp/buildd/bioperl-1.6.0/debian/bioperl/usr/lib/perl5/powerpc-linux-gnu-thread-multi/auto/Bio/': No such file or directory
make: *** [install-stamp] Error 1
dpkg-buildpackage: failure: fakeroot debian/rules binary gave error exit status 2
pbuilder: Failed autobuilding of package
 -> Aborting with an error
 -> unmounting dev/pts filesystem
 -> unmounting proc filesystem
 -> cleaning the build env
    -> removing directory /var/cache/pbuilder/build//6118 and its subdirectories

Changed in bioperl:
status: New → Incomplete
Charles Plessy (plessy) wrote :

Hi all,

I apologise for the stupid hardcoding :)

Next upload will have the following change:

- rmdir $(CURDIR)/debian/bioperl/usr/lib/perl5/powerpc-linux-gnu-thread-multi/auto/Bio/
+ find $(CURDIR)/debian/bioperl -type d -empty -delete

If Lenny is released next weekend, I will upload bioperl_1.6.0-2 to Unstable shortly after with this fix (and others) and a changelog entry closing this Lauchpad bug. Otherwise, I will upload to Experimental again.

Have a nice day,

--
Charles Plessy
Debian Med packaging team
http://www.debian.org/devel/debian-med
Tsurumi, Kanagawa, Japan

Charles Plessy (plessy) wrote :

Hi all,

it is uploaded:

 bioperl (1.6.0-2) unstable; urgency=low
 .
   * Removed patch system (not used):
     - removed instuctions in debian/rules;
     - removed quilt from Build-Depends in debian/control.
   * Re-enabled tests:
     - uncommented test command in debian/rules;
     - uncommented previously missing build-dependencies in debian/control.
     - Re-enabled tests and uncommented build-dependencies accordingly.
   * Removed libmodule-build-perl and libtest-harness-perl from
     Build-Depends-Indep (provided by perl-modules).
   * Better cleaning of empty directories using find -type d -empty -delete
     instead of rmdir in debian/rules (LP: #324001).

Have a nice day

--
Charles

Morten Kjeldgaard (mok0) on 2009-03-30
Changed in bioperl (Ubuntu):
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bioperl - 1.6.0-2

---------------
bioperl (1.6.0-2) unstable; urgency=low

  * Removed patch system (not used):
    - removed instuctions in debian/rules;
    - removed quilt from Build-Depends in debian/control.
  * Re-enabled tests:
    - uncommented test command in debian/rules;
    - uncommented previously missing build-dependencies in debian/control.
    - Re-enabled tests and uncommented build-dependencies accordingly.
  * Removed libmodule-build-perl and libtest-harness-perl from
    Build-Depends-Indep (provided by perl-modules).
  * Better cleaning of empty directories using find -type d -empty -delete
    instead of rmdir in debian/rules (LP: #324001).

bioperl (1.6.0-1) experimental; urgency=low

  [ Charles Plessy ]
  * debian/control
    - Updated dependencies according to the new upstream release.
    - Added the CPAN dependancies of BioPerl to Build-Depends-Indep in order to
      run the tests at build time.
    - Added bioperl-run to the recommended packages.
    - Updated my email address.
    - Uses Debhelper 7 (debian/compat modified accordingly).
  * debian/patches: removed as not needed (no downloads by default).
  * debian/rules:
    - Uses Build.PL instead of Makefile.PL.
    - Tests disabled for the experimental upload: not all dependencies are
      available yet.
  * debian/README.{Debian,source}: removed as not needed anymore
  * debian/watch: BioPerl is now mixed case.

  [ David Paleino ]
  * New upstream stable release:
    - fixes Bio::AlignIO::next_aln bug (Closes: #266921).
    - New modules, deprecated modules,… please consult Upsteam documents in
      /usr/share/doc/bioperl.
  * debian/control:
    - fields values rewrapped to easily spot diffs in commit mails
    - dropped B-D-I versioning on perl, since Etch already has a greater
      version
    - Standards-Version bumped to 3.8.0 (no changes needed).

 -- Ubuntu Archive Auto-Sync <email address hidden> Tue, 28 Apr 2009 22:59:17 +0100

Changed in bioperl (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers