binutils 2.24-5ubuntu14.2 source package in Ubuntu

Changelog

binutils (2.24-5ubuntu14.2) trusty; urgency=medium

  * 002-dont-segv-on-initial-instructions-overflow.patch:
    Fix ld crash on arm64 (LP: #1644363)

 -- Julian Andres Klode <email address hidden>  Tue, 25 Apr 2017 17:02:10 +0200

Upload details

Uploaded by:
Julian Andres Klode on 2017-04-25
Sponsored by:
Adam Conrad
Uploaded to:
Trusty
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Trusty updates on 2017-05-08 main devel
Trusty security on 2017-05-08 main devel

Downloads

File Size SHA-256 Checksum
binutils_2.24.orig.tar.gz 29.4 MiB 4930b2886309112c00a279483eaef2f0f8e1b1b62010e0239c16b22af7c346d4
binutils_2.24-5ubuntu14.2.diff.gz 301.9 KiB 5081f5353b3448ea1c62cb935d8645cf77111463d8acbaf4954ddf1e14029ff3
binutils_2.24-5ubuntu14.2.dsc 2.4 KiB 0e353b3e90d4fe8f0343e89f96a68dd731799a4a00bcddddf67574a6ce4472ae

View changes file

Binary packages built by this source

binutils: GNU assembler, linker and binary utilities

 The programs in this package are used to assemble, link and manipulate
 binary and object files. They may be used in conjunction with a compiler
 and various libraries to build programs.

binutils-dev: GNU binary utilities (BFD development files)

 This package includes header files and static libraries necessary to build
 programs which use the GNU BFD library, which is part of binutils. Note
 that building Debian packages which depend on the shared libbfd is Not
 Allowed.

binutils-doc: Documentation for the GNU assembler, linker and binary utilities

 This package consists of the documentation for the GNU assembler,
 linker and binary utilities in info format.

binutils-multiarch: Binary utilities that support multi-arch targets

 The programs in this package are used to manipulate binary and object
 files that may have been created on other architectures. This package
 is primarily for multi-architecture developers and cross-compilers and
 is not needed by normal users or developers. Note that a cross-assembling
 version of gas is not included in this package, just the binary utilities.
 .
 NORMAL USERS SHOULD NOT INSTALL THIS PACKAGE. It's meant only for those
 requiring support for reading info from binaries from other architectures.

binutils-multiarch-dev: GNU binary utilities that support multi-arch targets (BFD development files)

 This package includes header files, static and shared libraries necessary
 to build programs which use the GNU BFD library for multi-arch targets,
 which is part of binutils. Note that building Debian packages which depend
 on the shared libbfd is Not Allowed.
 .
 NORMAL USERS SHOULD NOT INSTALL THIS PACKAGE. It's meant only for those
 requiring support for reading info from binaries from other architectures.

binutils-source: GNU assembler, linker and binary utilities (source)

 This package contains the sources and patches which are needed to
 build binutils.

binutils-static: statically linked binutils tools

 This package contains statically linked binutils tools used
 for linking kernel modules needed to mount /usr or /. At the moment,
 it only contains ld.

binutils-static-udeb: statically linked binutils tools for for the Debian installer

 This package contains statically linked binutils tools used
 for linking kernel modules needed to mount /usr or /. At the moment,
 it only contains ld.