binutils: debian/changelog formatting issue

Bug #1827044 reported by Paul Wise (Debian) on 2019-04-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
binutils (Ubuntu)
Low
Unassigned

Bug Description

The Debian python modules emits warnings when parsing
the debian/changelog file from binutils 2.32-8ubuntu1:

   $ python3 -c 'from debian import changelog as c; f = open("debian/changelog"); c.Changelog(f)'
   /usr/lib/python3/dist-packages/debian/changelog.py:484: UserWarning: Unexpected line while looking for next heading of EOF: *
     warnings.warn(message)
   /usr/lib/python3/dist-packages/debian/changelog.py:484: UserWarning: Unexpected line while looking for next heading of EOF: -- Matthias Klose <doko@x1> Wed, 13 Dec 2017 10:50:43 +0000
     warnings.warn(message)

It is caused by this changelog entry:

   binutils (2.29-8ubuntu1) artful; urgency=medium

     * Merge with Debian; remaining changes:
       - Build from upstream sources.

    -- Matthias Klose <email address hidden> Wed, 30 Aug 2017 08:13:33 +0200
     *

    -- Matthias Klose <doko@x1> Wed, 13 Dec 2017 10:50:43 +0000

This doesn't appear to be present in the equivalent Debian version.

 affects ubuntu/binutils

--
bye,
pabs

https://wiki.debian.org/PaulWise

Changed in binutils (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package binutils - 2.32.51.20190614-0ubuntu1

---------------
binutils (2.32.51.20190614-0ubuntu1) eoan; urgency=medium

  * Snapshot, taken from the trunk (20190614).

binutils (2.32.51.20190611-1ubuntu1) eoan; urgency=medium

  * Snapshot, taken from the trunk (20190611).
  * Fix prehistoric changelog garbage. LP: #1827044.

binutils (2.32.51.20190611-1) experimental; urgency=medium

  * Snapshot, taken from the trunk (20190611).
  * Simplify setting the soname for the various builds.

 -- Matthias Klose <email address hidden> Fri, 14 Jun 2019 10:47:26 +0200

Changed in binutils (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers