ld: Relocation truncated to fit: R_ARM_THM_JUMP24 for relocation to PLT entry

Bug #1696686 reported by Diana Picus on 2017-06-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
binutils
Fix Released
Medium
binutils (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

SRU acceptance criteria:
 - the package builds
 - the newly added tests pass, no regressions to previous builds
 - needs only testing on armhf, no other changes.

Original bug report:

When linking large applications, we sometimes see this error. This is affecting the LLVM ARM buildbots.

The issue was fixed upstream:
https://sourceware.org/bugzilla/show_bug.cgi?id=20608

Could you please backport it to Xenial?

I have applied the patch on top of binutils_2.26.1.orig.tar.gz + binutils_2.26.1-1ubuntu1~16.04.3.diff.gz as found here:
https://packages.ubuntu.com/xenial-updates/binutils-arm-linux-gnueabihf

It applies cleanly (except the ChangeLog) and passes make check.

Changed in binutils:
importance: Unknown → Medium
status: Unknown → Fix Released
Matthias Klose (doko) wrote :

fixed in 16.10 and later releases

description: updated
Changed in binutils (Ubuntu Xenial):
status: New → In Progress
Changed in binutils (Ubuntu):
status: New → Fix Released

Hello Diana, or anyone else affected,

Accepted binutils into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/binutils/2.26.1-1ubuntu1~16.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in binutils (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Diana Picus (rovka) wrote :

Hi,

I tested this on our reproducer and I can confirm it fixes the bug for us. Thanks!
I used
http://ports.ubuntu.com/ubuntu-ports xenial-proposed/main armhf binutils armhf 2.26.1-1ubuntu1~16.04.5.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hey Matthias! I see the xenial upload has a bunch of autopkgtests failing against -proposed. Could you take a look if any of those are related?

Matthias Klose (doko) wrote :

the binutils change is limited to arm32 only. so you have to look for other things causing these "regressions".

the linux/armhf failure seems to be unrelated, packaging error?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package binutils - 2.26.1-1ubuntu1~16.04.5

---------------
binutils (2.26.1-1ubuntu1~16.04.5) xenial-proposed; urgency=medium

  * SRU: LP: #1696686.
  * Fix PR ld/20608: Relocation truncated to fit: R_ARM_THM_JUMP24 for
    relocation to PLT entry.

 -- Matthias Klose <email address hidden> Mon, 21 Aug 2017 16:24:14 +0200

Changed in binutils (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for binutils has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.