Upgrade failed, x86_64-linux-gnu/crti.o: unrecognized relocation (0x2a) in section `.init'

Bug #1575109 reported by Víctor R. Ruiz on 2016-04-26
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
binutils
New
Undecided
Unassigned
binutils (Debian)
Fix Released
Unknown
binutils (Ubuntu)
High
Unassigned
ubuntu-release-upgrader (Ubuntu)
High
Unassigned

Bug Description

Running sa-compile (may take a long time)
/usr/bin/ld: /usr/lib/gcc/x86_64-linux-gnu/5/../../../x86_64-linux-gnu/crti.o: unrecognized relocation (0x2a) in section `.init'
/usr/bin/ld: final link failed: Bad value
collect2: error: ld returned 1 exit status
make: *** [blib/arch/auto/Mail/SpamAssassin/CompiledRegexps/body_0/body_0.so] Error 1
command 'make >>/tmp/.spamassassin6654c6JaRRtmp/log' failed: exit 2
dpkg: error processing package sa-compile (--configure):
 subprocess installed post-installation script returned error exit status 25
Errors were encountered while processing:
 libgmp-dev:amd64
 systemd
 sa-compile

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:15.10.14.4
ProcVersionSignature: Ubuntu 4.2.0-35.40-generic 4.2.8-ckt5
Uname: Linux 4.2.0-35-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Tue Apr 26 11:38:01 2016
InstallationDate: Installed on 2012-02-04 (1542 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to xenial on 2016-04-26 (0 days ago)
VarLogDistupgradeAptclonesystemstate.tar.gz: Error: command ['pkexec', 'cat', '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'] failed with exit code 127: pkexec must be setuid root

Víctor R. Ruiz (vrruiz) wrote :
Víctor R. Ruiz (vrruiz) wrote :
Víctor R. Ruiz (vrruiz) wrote :
Víctor R. Ruiz (vrruiz) wrote :
Víctor R. Ruiz (vrruiz) wrote :
no longer affects: ubuntu-release-upgrader (Debian)
summary: - Upgrade failed, x86_64-linux-gnu/crti.o: unrecognized relocation
+ Upgrade failed, x86_64-linux-gnu/crti.o: unrecognized relocation (0x2a)
+ in section `.init'
no longer affects: libc6-i386 (Debian)
Changed in binutils (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in binutils (Ubuntu):
status: New → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Changed in binutils (Ubuntu):
importance: Undecided → High
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
tags: added: wily2xenial
nilandenterprise (nilands55s) wrote :

since the update my gcc-4.8 will not compile (Make) Ubuntu 140.4.5 (Linux-...generic-..131.)
So far I have had to r-sync a backup on my system because of updates, 4 times the last 2 months due to upstates. I am confused, frustrated and dismayed recently with Ubuntu. This bug is no allowing me to compile the driver from http://foo2hbpl.rkkda.com for my printer. Now not working either!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.