package binutils-avr 2.18-3 failed to install/upgrade: trying to create hardlink, but /usr/lib is on another partition (the original file was not specified).

Bug #369130 reported by Mikkel Jakobsen
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
binutils-avr (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Binary package hint: binutils-avr

Dist upgrading to 9.04 (32bit version)

Special system configuration: (soft link)
/usr/lib -> /data/usr/lib

fstab info:
/dev/sda2 on / type ext3 (rw,errors=remount-ro)
/dev/sdb1 on /data type ext3 (rw)

The softlink was created due to space limitations on /dev/sda2 and /dev/sdb1 already existed as a full disk partition.

Error from package system:
E: /var/cache/apt/archives/binutils-avr_2.18-4ubuntu1_i386.deb: error creating hard link `./usr/lib/avr/bin/nm'

Preparing to replace binutils-avr 2.18-3 (using .../binutils-avr_2.18-4ubuntu1_i386.deb) ...
Unpacking replacement binutils-avr ...
dpkg: error processing /var/cache/apt/archives/binutils-avr_2.18-4ubuntu1_i386.deb (--unpack):
 error creating hard link `./usr/lib/avr/bin/nm': Invalid cross-device link
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/binutils-avr_2.18-4ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:

(continuing with dependency problems due to failed installation...)

ProblemType: Package
Architecture: i386
Dependencies:
 libgcc1 1:4.3.3-5ubuntu4
 gcc-4.3-base 4.3.3-5ubuntu4
 findutils 4.4.0-2ubuntu4
 libc6 2.9-4ubuntu6
DistroRelease: Ubuntu 9.04
ErrorMessage:
 ErrorMessage: package binutils-avr is already installed and configured
Package: binutils-avr 2.18-3
SourcePackage: binutils-avr
Title: package binutils-avr 2.18-3 failed to install/upgrade:
Uname: Linux 2.6.27-11-generic i686

Revision history for this message
Mikkel Jakobsen (mikkelkj) wrote :
Revision history for this message
Alessio Igor Bogani (abogani) wrote :

Could you test with binutils-avr 2.20-2 available in Lucid Lynx, please?

Thanks!

Changed in binutils-avr (Ubuntu):
status: New → Incomplete
Revision history for this message
Alessio Igor Bogani (abogani) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in binutils-avr (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Chris (christian-fontana) wrote :

I'm trying to install this package on kubuntu 10.04 and the error is the same. The version I'm installing is binutils-avr_2.20-2_i386.deb
This is my partition schema:

mount
/dev/sda3 on / type ext3 (rw,relatime,errors=remount-ro)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sda6 on /home type ext3 (rw,relatime)
/dev/sda7 on /root type ext3 (rw,relatime)
/dev/sda8 on /usr type ext3 (rw,relatime)
/dev/sda12 on /usr/lib type ext3 (rw,relatime)
/dev/sda11 on /usr/share type ext3 (rw,relatime)
/dev/sda9 on /var type ext3 (rw,relatime)
/dev/sda10 on /var/cache type ext3 (rw,relatime)
/dev/sda13 on /home/chris/Project type ext4 (rw,relatime)
none on /proc/fs/vmblock/mountPoint type vmblock (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)

This is blocking for me as I didn't succeeded in install the gcc-avr from packages

thanks
christian

Changed in binutils-avr (Ubuntu):
status: Invalid → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in binutils-avr (Ubuntu):
status: New → Confirmed
Revision history for this message
talas (talas777) wrote :

Tested and didnt work in Ubuntu 12.04 LTS.

It still tries to create a hard link, which fails if /usr/lib is on a different partition.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers