Firefox address and search bar not working after update to FF 11 on Lucid

Bug #957010 reported by Mirza Ibrahim
72
This bug affects 11 people
Affects Status Importance Assigned to Milestone
bindwood (Ubuntu)
Invalid
Undecided
Unassigned
Lucid
Fix Released
Critical
Unassigned
Maverick
Fix Released
Critical
Unassigned
Natty
Fix Released
Critical
Unassigned
Oneiric
Fix Released
Critical
Unassigned

Bug Description

The address bar and search bar in Firefox stopped working after I upgraded from FF 10 to 11 in ubuntu 10.04. Typing in URLs or search phrases is not followed by any FF activity. I can open URLs from bookmarks though.

Also, I cannot access "Manage search engines", the Add-ons-manager won't load.
At first, the bookmarks menu remained blank, too. That changed when I brought up the classic Menu bar instead of the Firefox menu.

I have reinstalled Firefox both from the mozillateam and the ubuntu main ppa's, to no avail.

same problem reported by others on ubuntu forums.
http://ubuntuforums.org/showthread.php?t=1941792

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: firefox 11.0+build1-0ubuntu0.10.04.2
ProcVersionSignature: Ubuntu 2.6.32-39.86-generic 2.6.32.56+drm33.22
Uname: Linux 2.6.32-39-generic i686
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ibrahim 1441 F.... pulseaudio
BuildID: 20120310193829
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x90200000 irq 22'
   Mixer name : 'SigmaTel STAC9227'
   Components : 'HDA:83847618,8086a201,00100201'
   Controls : 37
   Simple ctrls : 24
Channel: release
Date: Fri Mar 16 19:45:43 2012
EtcFirefoxSyspref: Cannot parse /etc/firefox/syspref.js - [Errno 2] No such file or directory: '/etc/firefox/syspref.js'
ForcedLayersAccel: False
IncompatibleExtensions:
 Bindwood - <email address hidden>, Version=1.0.4, minVersion=3.5, maxVersion=9.0.*, Location=app-system-share, Type=extension, Active=Yes
 Ubuntu Firefox Modifications - <email address hidden>, Version=0.9.4, minVersion=4.0b6, maxVersion=10.*, Location=app-system-share, Type=extension, Active=Yes
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
IpRoute:
 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.2 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
 default via 192.168.1.1 dev eth0 proto static
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 vboxnet0 no wireless extensions.
ProcEnviron:
 PATH=(custom, user)
 LANG=en_IN
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=11.0/20120310193829 (Running)
RfKill:

RunningIncompatibleAddons: True
SourcePackage: firefox
dmi.bios.date: 11/07/2007
dmi.bios.vendor: Intel Corp.
dmi.bios.version: TS94610J.86A.0087.2007.1107.1049
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: D946GZIS
dmi.board.vendor: Intel Corporation
dmi.board.version: AAD66165-302
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrTS94610J.86A.0087.2007.1107.1049:bd11/07/2007:svn:pn:pvr:rvnIntelCorporation:rnD946GZIS:rvrAAD66165-302:cvn:ct2:cvr:

Revision history for this message
Mirza Ibrahim (mirzasaeed07) wrote :
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

This is caused by the incompatible version of bindwood that you're running, which is unmaintained

affects: firefox (Ubuntu) → bindwood (Ubuntu)
Changed in bindwood (Ubuntu):
status: New → Invalid
Changed in bindwood (Ubuntu Lucid):
importance: Undecided → Critical
Changed in bindwood (Ubuntu Natty):
importance: Undecided → Critical
Changed in bindwood (Ubuntu Oneiric):
importance: Undecided → Critical
Changed in bindwood (Ubuntu Maverick):
importance: Undecided → Critical
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

We'll push out on empty bindwood package to force it's removal. It's pretty useless now anyway (http://voices.canonical.com/ubuntuone/2011/10/17/putting-bookmark-sync-to-bed/)

Changed in bindwood (Ubuntu Lucid):
status: New → Triaged
Changed in bindwood (Ubuntu Maverick):
status: New → Triaged
Changed in bindwood (Ubuntu Natty):
status: New → Triaged
Changed in bindwood (Ubuntu Oneiric):
status: New → Triaged
Revision history for this message
Mirza Ibrahim (mirzasaeed07) wrote :

Yes, thats right, After removing that package, firefox working now. Thank You.

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Did you manually edit /usr/share/xul-ext/bindwood/install.rdf btw? If not, where did you install it from? The compatibility information attached to your bug report doesn't match what we have in the archive

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bindwood - 1.99.0-0ubuntu3.1

---------------
bindwood (1.99.0-0ubuntu3.1) oneiric-security; urgency=low

  * This extension is incompatible with Firefox 11, and is causing the
    browser to fail. Since the bookmarks sync feature is no longer
    available in Ubuntu One, make this package empty until someone fixes
    it. (LP: #957010)
 -- Marc Deslauriers <email address hidden> Fri, 16 Mar 2012 10:51:52 -0400

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bindwood - 1.99.0-0ubuntu1.3

---------------
bindwood (1.99.0-0ubuntu1.3) natty-security; urgency=low

  * This extension is incompatible with Firefox 11, and is causing the
    browser to fail. Since the bookmarks sync feature is no longer
    available in Ubuntu One, make this package empty until someone fixes
    it. (LP: #957010)
 -- Marc Deslauriers <email address hidden> Fri, 16 Mar 2012 11:01:21 -0400

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bindwood - 1.0.4-0ubuntu2.1

---------------
bindwood (1.0.4-0ubuntu2.1) maverick-security; urgency=low

  * This extension is incompatible with Firefox 11, and is causing the
    browser to fail. Since the bookmarks sync feature is no longer
    available in Ubuntu One, make this package empty until someone fixes
    it. (LP: #957010)
 -- Marc Deslauriers <email address hidden> Fri, 16 Mar 2012 11:03:44 -0400

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bindwood - 1.0.4-0ubuntu1.1

---------------
bindwood (1.0.4-0ubuntu1.1) lucid-security; urgency=low

  * This extension is incompatible with Firefox 11, and is causing the
    browser to fail. Since the bookmarks sync feature is no longer
    available in Ubuntu One, make this package empty until someone fixes
    it. (LP: #957010)
 -- Marc Deslauriers <email address hidden> Fri, 16 Mar 2012 11:05:42 -0400

Changed in bindwood (Ubuntu Lucid):
status: Triaged → Fix Released
Changed in bindwood (Ubuntu Maverick):
status: Triaged → Fix Released
Changed in bindwood (Ubuntu Natty):
status: Triaged → Fix Released
Changed in bindwood (Ubuntu Oneiric):
status: Triaged → Fix Released
Revision history for this message
Mirza Ibrahim (mirzasaeed07) wrote :

@chris.. No, I had not edited any file, just installed that package from repositories long back, but never used that.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers