Bindwood migrates for infinity

Bug #560583 reported by AJenbo
138
This bug affects 35 people
Affects Status Importance Assigned to Milestone
Bindwood
Fix Released
Undecided
Zachery Bir
bindwood (Ubuntu)
Fix Released
Low
Zachery Bir

Bug Description

Binary package hint: bindwood

Bindwood

Welcome back to Bindwood. Bindwood now can preserve all your bookmarks, folders, and feeds, but we need to tidy up the records in the database before we can proceed. Please don't be alarmed if you notice a lag while Bindwood is migrating your bookmarks.
...................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

:(

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: firefox 3.6.3+nobinonly-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
Architecture: i386
Date: Sun Apr 11 11:44:23 2010
FirefoxPackages:
 firefox 3.6.3+nobinonly-0ubuntu2
 firefox-gnome-support 3.6.3+nobinonly-0ubuntu2
 firefox-branding 3.6.3+nobinonly-0ubuntu2
 abroswer N/A
 abrowser-branding N/A
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100327)
ProcEnviron:
 LANG=da_DK.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox

Related branches

Revision history for this message
AJenbo (ajenbo) wrote :
Revision history for this message
Martin Albisetti (beuno) wrote :

I have the same problem. Infinite dots!
I don't believe I had ever installed bindwood before, so I'm not sure what it's migrating.

Revision history for this message
AJenbo (ajenbo) wrote :

I had bindwood installed in karmic but removed it as it worked horible back then.

Revision history for this message
Sense Egbert Hofstede (sense) wrote :

Thank you for helping with making Ubuntu and Bindwood better by reporting this bug. I can confirm this issue myself on an up-to-date version of Ubuntu Lucid.
I'm setting the status to Triaged and opening an upstream task so the developers can take a look at this issue.

Changed in bindwood (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Revision history for this message
Zachery Bir (urbanape) wrote :

Hey, all. Thanks for reporting this. The only time you *should* be getting the migration status is if you've got some records in your local desktop couch and some preferences set in Firefox (triggered from an earlier Bindwood run).

Can you please enable a boolean Firefox pref called bindwood.debug and set it to True, when running in debug mode, the Javascript console will output a lot of info, and there's likely one little crash point. If you can include that as an attachment here, it might help diagnose.

Changed in bindwood:
assignee: nobody → Zachery Bir (urbanape)
Changed in bindwood (Ubuntu):
assignee: nobody → Zachery Bir (urbanape)
Revision history for this message
Matthew Gregg (mcg) wrote :

Setting bindwood.debug=true, after sync runs for a bit, I get the following.

Bindwood: Couldn't find a UUID for itemId: 2824 message: 'Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIAnnotationService.getItemAnnotation]', reason: 'undefined', description: 'undefined', error: 'undefined', raw error: '{}'

Bindwood: UUID We came up with: {eaeb55c4-f3c2-4c98-a77d-de642bc0fb9d}

Bindwood: Annotating the item now.

Bindwood: Something wrong with the process, exiting. message: 'Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIAnnotationService.setItemAnnotation]', reason: 'undefined', description: 'undefined', error: 'undefined', raw error: '{}'

Revision history for this message
Martin Albisetti (beuno) wrote :

Same here. The couch source for those IDs is:

{
   "_id": "{91ec63fa-c8c7-42c7-be81-67998960e495}",
   "_rev": "1-3af30b174864e7ca1b070d18047fb3e5",
   "record_type_version": 1,
   "application_annotations": {
       "Firefox": {
           "profile": "default",
           "last_modified": 1270865994453602
       }
   },
   "title": "Desktop Couch Scratch",
   "record_type": "http://www.freedesktop.org/wiki/Specifications/desktopcouch/folder",
   "children": [
   ]
}

{
   "_id": "{0062b0de-9f4e-4471-be7b-ae81c6db7e5d}",
   "_rev": "1-3ecaa6e8e343d24aae978086a8d222f6",
   "record_type_version": 1,
   "application_annotations": {
       "Firefox": {
           "profile": "default",
           "last_modified": 1270865991436465
       }
   },
   "title": "Aza’s Thoughts » Firefox 3.1 New Tab Specification",
   "record_type": "http://www.freedesktop.org/wiki/Specifications/desktopcouch/bookmark",
   "uri": "http://www.azarask.in/blog/post/firefox-31-new-tab-spec/"
}

Revision history for this message
teJECSke (attila-jecs) wrote :

how can i set bindwood.debug=true ?
i cannot find bindwood.debug in "about:config"

Revision history for this message
teJECSke (attila-jecs) wrote :

ok, i added a new boolean

Revision history for this message
teJECSke (attila-jecs) wrote :

Bindwood: Item #30: ItemId: 380
Bindwood: Annotation on 380: {b5142add-3171-46e5-a983-c9b851f43481}
Bindwood: XXX: Still haven't found the right itemId!
Bindwood: Found its local itemID from the map: undefined
Bindwood: UUID We came up with: {0398a489-1d6e-4afa-8f11-6626c4effbd4}
Bindwood: Annotating the item now.
Bindwood: Something wrong with the process, exiting. message: 'Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIAnnotationService.setItemAnnotation]', reason: 'undefined', description: 'undefined', error: 'undefined', raw error: '{}'

Zachery Bir (urbanape)
Changed in bindwood:
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bindwood - 1.0.4-0ubuntu1

---------------
bindwood (1.0.4-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Removed status windows
    - Merged in fixing-broken-migration (LP: #560583)
 -- Chris Coulson <email address hidden> Wed, 14 Apr 2010 21:39:02 +0100

Changed in bindwood (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Zachery Bir (urbanape) wrote :

Hi, all. 1.0.4 was released yesterday afternoon. In addition to removing the pop-up, it also should fix the error that was causing the migration to seem to go on forever. Please try it out and see if this issue is resolved.

Changed in bindwood:
status: Fix Committed → Fix Released
Revision history for this message
teJECSke (attila-jecs) wrote : Re: [Bug 560583] Re: Bindwood migrates for infinity

where can i download it?
main update server still has 1.0.3

2010. 04. 15, csütörtök keltezéssel 13.46-kor Zachery Bir ezt írta:
> Hi, all. 1.0.4 was released yesterday afternoon. In addition to removing
> the pop-up, it also should fix the error that was causing the migration
> to seem to go on forever. Please try it out and see if this issue is
> resolved.
>
> ** Changed in: bindwood
> Status: Fix Committed => Fix Released
>

--
Jecs Attila <email address hidden>
StarGate Command

Revision history for this message
Zachery Bir (urbanape) wrote :

On Thu, Apr 15, 2010 at 2:34 PM, teJECSke <email address hidden> wrote:

> where can i download it?
> main update server still has 1.0.3

Perhaps it'll take a while? I got it this morning from my update manager

Zac

Revision history for this message
Zachery Bir (urbanape) wrote :

Sorry, I spoke too soon. The package for 1.0.4 has been uploaded to our
build servers and is currently in queue. In the meanwhile, you can add my
experimental bindwood PPA to your software sources and get a PPA build of
1.0.4:

  ppa:urbanape/bindwood-exp

Thanks,

Zac

Revision history for this message
Zachery Bir (urbanape) wrote :

On Thu, Apr 15, 2010 at 4:31 PM, Zachery Bir <email address hidden>wrote:

> Sorry, I spoke too soon. The package for 1.0.4 has been uploaded to our
> build servers and is currently in queue. In the meanwhile, you can add my
> experimental bindwood PPA to your software sources and get a PPA build of
> 1.0.4:
>
> ppa:urbanape/bindwood-exp
>
> Hrm, only maybe that won't work, because the upstream package has some
different rules for post-processing the shell script included. Grr. yeah,
ignore this PPA build. By the time I'd get a new one up there, the real one
should be available. Sorry, your continued patience is appreciated.

Zac

Revision history for this message
teJECSke (attila-jecs) wrote :

2010. 04. 15, csütörtök keltezéssel 20.33-kor Zachery Bir ezt írta:
> On Thu, Apr 15, 2010 at 4:31 PM, Zachery Bir
> <email address hidden>wrote:
>
> > Sorry, I spoke too soon. The package for 1.0.4 has been uploaded to our
> > build servers and is currently in queue. In the meanwhile, you can add my
> > experimental bindwood PPA to your software sources and get a PPA build of
> > 1.0.4:
> >
> > ppa:urbanape/bindwood-exp
> >
> > Hrm, only maybe that won't work, because the upstream package has some
> different rules for post-processing the shell script included. Grr. yeah,
> ignore this PPA build. By the time I'd get a new one up there, the real one
> should be available. Sorry, your continued patience is appreciated.
>
> Zac

it arrived and seems working, thanks

--
Jecs Attila <email address hidden>
StarGate Command

Revision history for this message
Matthew Gregg (mcg) wrote :

Updated to 1.0.4 and no longer get the dialog/popup but the same errors are in the error console.

Bindwood: Couldn't find a UUID for itemId: 2824 message: 'Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIAnnotationService.getItemAnnotation]', reason: 'undefined', description: 'undefined', error: 'undefined', raw error: '{}'

Bindwood: UUID We came up with: {99cff5ae-88d5-4c05-9122-cd8f39ec0f96}

Bindwood: Something wrong with the process, exiting. message: 'Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIAnnotationService.setItemAnnotation]', reason: 'undefined', description: 'undefined', error: 'undefined', raw error: '{}'

Revision history for this message
Zachery Bir (urbanape) wrote :
Download full text (3.8 KiB)

On Fri, Apr 16, 2010 at 9:02 AM, Matthew Gregg <email address hidden> wrote:

> Updated to 1.0.4 and no longer get the dialog/popup but the same errors
> are in the error console.

Hey, Matthew,

Can you try running this attached script and paste the resulting output?

Run it like so:

  $ python ./verify_bindwood_consistency.py -d
/path/to/the/default/firefox/profile

(Mine, for example, is /home/zbir/.mozilla/firefox/6yz8p1ca.default)

If you've gone through a successful migration, you'd see something like the
following:

Checking record (root_default) for local counterpart
No counterpart
Checking record ({0bc903bc-e61d-46b0-ba23-4670b3ecfed2}) for local
counterpart
Counterpart itemId: 181
Checking record ({0cd2dad6-41bf-4997-9ee2-6cfa1066afa3}) for local
counterpart
Counterpart itemId: 155
Checking record ({12b81a5b-4dfd-4d09-8f0e-3e48b7c6ed8a}) for local
counterpart
Counterpart itemId: 9
Checking record ({140e0166-1ae5-4f32-8eba-5db54b6b80b7}) for local
counterpart
Counterpart itemId: 186
Checking record ({1b1e369b-796e-4689-94c5-ea3924fec9f3}) for local
counterpart
Counterpart itemId: 5
Checking record ({1cb2f4c3-e8be-4450-add0-4bd3449cfa06}) for local
counterpart
Counterpart itemId: 178
Checking record ({1e0eed5b-46d2-4fed-908d-a7d5b4461e88}) for local
counterpart
Counterpart itemId: 156
Checking record ({38b7893a-f6cd-40e2-9973-936850fd9d1b}) for local
counterpart
Counterpart itemId: 14
Checking record ({39742652-4371-4f51-a95b-c38348af8b09}) for local
counterpart
Counterpart itemId: 184
Checking record ({44f77d38-da46-4f70-8b4f-d9cd6deeec0a}) for local
counterpart
Counterpart itemId: 74
Checking record ({4a976c0e-2fc0-4a31-8696-74d79b5814d3}) for local
counterpart
Counterpart itemId: 152
Checking record ({75925be7-6857-4f91-a197-1104152a5f86}) for local
counterpart
Counterpart itemId: 2
Checking record ({7c04024c-a66c-413a-b00b-c701c5f0db7e}) for local
counterpart
Counterpart itemId: 75
Checking record ({822f04e5-4338-4341-8ec7-c548f5cbab91}) for local
counterpart
Counterpart itemId: 19
Checking record ({897bb36b-0ac1-417a-81bc-9e7ade568b3f}) for local
counterpart
Counterpart itemId: 183
Checking record ({95481fbb-77d9-4267-a7a8-cf1822814d1c}) for local
counterpart
Counterpart itemId: 180
Checking record ({ac1b792f-589e-4d57-ab0e-8f857927dfdb}) for local
counterpart
Counterpart itemId: 106
Checking record ({b1cb72e3-74cf-4d9c-9293-f9c5d515e54f}) for local
counterpart
Counterpart itemId: 185
Checking record ({b7b07a40-fc1e-4140-90ba-4bb273bd761e}) for local
counterpart
Counterpart itemId: 187
Checking record ({b82cfa3e-b239-4888-8051-98e4a1717591}) for local
counterpart
Counterpart itemId: 76
Checking record ({bc629793-34ec-420c-a704-a76d0bc60279}) for local
counterpart
Counterpart itemId: 82
Checking record ({c54665ce-fe87-47d5-9060-f5a75c9902ea}) for local
counterpart
Counterpart itemId: 7
Checking record ({c58e1df9-eae3-4957-9f4a-edb720a76e9f}) for local
counterpart
Counterpart itemId: 188
Checking record ({da8eedf6-8b1c-45df-aacc-8886846f3dc8}) for local
counterpart
Counterpart itemId: 81
Checking record ({db11d360-6a2d-4370-bdaf-6bf43d76e663}) for local
counterpart
Counterpart itemId: 157
Checking record ({dc5e4b79-fd73-4143-a73c-81...

Read more...

Revision history for this message
Matthew Gregg (mcg) wrote :

 I don't get any output from the script. However it gave me an idea, so I vacuumed Firefox's sqlite db's. Next start of firefox and Bindwood looks to have sync'd correctly or at least made it a lot farther. I restarted FF after it seem to have completed and now get a few of these:
Bindwood: Item #1578: ItemId: 11281
Bindwood: Annotation on 11281: 93e8654272ba657dc1ec448ac38abc45

then:
Bindwood: XXX: Still haven't found the right itemId!

Bindwood: Found its local itemID from the map: undefined

Bindwood: UUID We came up with: 0210882007b5e6240b4f506033a494b7

Bindwood: Annotating the item now.

Bindwood: Something wrong with the process, exiting. message: 'Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIAnnotationService.setItemAnnotation]', reason: 'undefined', description: 'undefined', error: 'undefined', raw error: '{}'

The script still doesn't produce any output.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers