Can't install bindfs package - it have dependency on non-exist package fuse

Bug #851600 reported by Murz on 2011-09-16
134
This bug affects 28 people
Affects Status Importance Assigned to Milestone
bindfs (Ubuntu)
Undecided
Unassigned

Bug Description

On natty I have successfully installed bindfs package. But on oneric I can't install it, becuase it have dependency on fuse package, that don't exist in oneric:
Depends: libc6 (>= 2.7), libfuse2 (>= 2.8.1), fuse

I have successfully install on my system package from natty, but can't upgrade or install from oneric.

# aptitude show fuse
No current or candidate version found for fuse
Package: fuse
State: not a real package

Murz (murznn) on 2011-09-16
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bindfs (Ubuntu):
status: New → Confirmed
yota (yota-opensystems) wrote :

To circumvent the problem I repackaged the deb without the fuse dependency: now it installs and runs fine on my system.

It's attached in the case that can come handy to someone else waiting for an official fix.

By looking at list of dependencies from the previous bindfs packages, they seem to depend on fuse-util but not fuse. My guess is that fuse is not the correct name of the package in the first place.

Joshua Kite (joshuamkite-gmail) wrote :

I have 2 machines running ubuntu and have upgraded one to 11.10. I rely on bindfs and this dependency bug has broken my installation on one and is preventing me upgrading on the other. This should be very simple to sort out: Package 'Fuse' is not available in 11.10, so it should not be a dependency for any other package. Can we perhaps have the dependency switched to 'fuse-utils' as Abhabongse Janthong suggests so that we can continue using our devices?

Hiro Protagonist (surfer) wrote :

same problem here.

@yota: your workaround works. thanks a lot! i hope your package is free from nasty stuff... q8)

Kuzma Shapran (kuzma-shapran) wrote :

the same problem. I've 32bit computer, so yota's workaround won't work :-(

The attached file is repackaged with dependencies changed from fuse to fuse-utils. This is my first time doing things like this. At least it works on my machine. It's for 32-bit.

Make sure when you update the packages from repository, don't get the installed one replaced by the buggy ones in the repo, until you know it has been fixed. In most case, this won't happen.

Kuzma Shapran (kuzma-shapran) wrote :

to Abhabongse Janthong: Awesome! Thanks! That one works!

Kris (k-kristoferb) wrote :

Any chances of getting this fixed in the repo?

Fix is clear and easy, yet it's still not fixed in the repo... What's the delay?

Ben M. (bmhm) wrote :

While the bindfs-dependency is obviously wrong, you could also repackage fuse-utils to include "Provides: fuse" in DEBIAN/control.

lunomad (damon-metapaso) wrote :

Ran into the same problem today.

bindfs has been showing up as "not upgradeable" ever since the upgrade to oneiric, but i was just ignoring it. Today I uninstalled the natty version (1.8 something) and tried to re-install the version in the repos...no luck.

yota's attachment installs fine for me on 64-bit oneiric.

Thanks, yota!

Ben M. (bmhm) wrote :

Hi,

Yota's solution is working, but you won't receive upgrades. Luckily there is another way, which will not interfere with any other packages. A quick and clean solution is to install a virtual package "fuse", which depends on fuse-utils.

Check my blog on how to create such a package:
http://blog.bmarwell.de/2012/01/10/ubuntu-bindfs-mit-abhangigkeit-von-fuse-installieren/
(the first grey box contains the control file content)

Hope that helps.

d❤vid (kwill) wrote :

This issue appears to be fixed in 12.04 LTS Beta 1. I selected the package bindfs and it installed without error.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers