Apport hook for bind9

Bug #533601 reported by Andres Rodriguez on 2010-03-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bind9 (Ubuntu)
Wishlist
LaMont Jones

Related branches

Changed in bind9 (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Andres Rodriguez (andreserl)
Changed in bind9 (Ubuntu):
status: In Progress → Confirmed
importance: Low → Wishlist
summary: - Apport hook for bind9
+ [FFe] Apport hook for bind9
description: updated

This package builds, installs, and upgrades correctly.

For build logs please see the Bug description.

I'm attaching install/upgrade logs.

Andres Rodriguez (andreserl) wrote :
Changed in bind9 (Ubuntu):
assignee: Andres Rodriguez (andreserl) → nobody
status: Confirmed → New
Martin Pitt (pitti) wrote :

Apport hooks do not really need a feature freeze exception, they help us for debugging the system.

Changed in bind9 (Ubuntu):
status: New → Triaged
summary: - [FFe] Apport hook for bind9
+ Apport hook for bind9
LaMont Jones (lamont) wrote :

I'm inclined to have hook give the option about named.conf, but report the other information unconditionally. I'll add this during maverick.

Changed in bind9 (Ubuntu):
assignee: nobody → LaMont Jones (lamont)
status: Triaged → In Progress
Mathias Gug (mathiaz) wrote :

Given that Lamont is planning to integrate that work via Debian, I'm unsubscribing the ubuntu-sponsor team for now.

UndiFineD (k.dejong) wrote :

well it's implemented
I had heaps of trouble getting munin stats on bind
finally I found the apparmor.d profile for named and had to edit it to make bind / munin work

Martin Pitt (pitti) wrote :

I'll modify the patch a bit so that it can be applied in Debian. I. e. not use dh-apport, but install it manually, and conditional to "dpkg-vendor --is ubuntu".

Martin Pitt (pitti) wrote :

Also, there is no need to use root_command_output -- "/usr/sbin/named -v" works fine as user. Also, it's redundant, since we already have the package version in Apport reports. Also, the related package info and syslog stuff are currently covered in the "else" branch, but should be unconditional.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bind9 - 1:9.7.2.dfsg.P2-2ubuntu1

---------------
bind9 (1:9.7.2.dfsg.P2-2ubuntu1) natty; urgency=low

  [ Andres Rodriguez ]
  * Add apport hook (LP: #533601):
    - debian/bind9.apport: Added.

  [ Martin Pitt ]
  * debian/rules: Install Apport hook when building on Ubuntu.
 -- Martin Pitt <email address hidden> Fri, 26 Nov 2010 10:50:17 +0100

Changed in bind9 (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

This is the debdiff I sponsored to Natty now, minus the Maintainer: change. Thanks Andres Rodriguez!

Lamont, do you want to apply this as it is (should be fine for Debian now). Do you want me to create a Debian bug report for this, or is this fine?

Martin

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches