Invalid multi values domain string generated by network manager

Bug #291161 reported by João Pinto on 2008-10-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NetworkManager
Unknown
Medium
bind9 (Ubuntu)
Undecided
Unassigned
network-manager (Ubuntu)
Undecided
Unassigned
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

I am getting the following error using nslookup:
nslookup: parse of /etc/resolv.conf failed
The file was not edited manually, it was generated by NM and the AT&T VPN Client.
I have changed the IPs/Domains for privacy reasons, /etc/resolv.conf:
#@NETVPN_GENERATED@ -- this file is generated by NetVPN
# and will be overwritten by NetVPN
# as long as the above mark is intact
nameserver 127.0.0.1
nameserver 127.0.0.1
# Generated by NetworkManager
domain local.domain.com br.somewhere.com somewhere.com
search local.domain.com
nameserver 127.0.0.1
nameserver 127.0.0.1
nameserver 127.0.0.1

João Pinto (joaopinto) wrote :

dnsutils:
  Installed: 1:9.5.0.dfsg.P2-1ubuntu2

description: updated
João Pinto (joaopinto) wrote :

nslookup error message is related to the "domain local.domain.com br.somewhere.com somewhere.com", which is invalid.
The bug us with NetworkManager which is building an invalid multiple domain script.

Changed in bind9:
status: New → Invalid
João Pinto (joaopinto) wrote :

This turned to be an AT&T VPN client problem.
Setting NETVPN_DEF_DOMAIN to "" on /etc/agnclient/agnclient.conf fixed it.

Changed in network-manager-applet:
status: New → Invalid
gwendo (mikael-lonneberg) wrote :

This is actually not an issue with the Agnclient, it is the Comment line # Generated by NetworkManager in the middle of the file that is the problem. Remove that and it works like a charm.

João Pinto wrote:
> nslookup error message is related to the "domain local.domain.com br.somewhere.com somewhere.com", which is invalid.
> The bug us with NetworkManager which is building an invalid multiple domain script.
>
> ** Also affects: network-manager-applet (Ubuntu)
> Importance: Undecided
> Status: New
>
>
 affects ubuntu/network-manager-applet
 status invalid

this is a bug in NM

 affects ubuntu/network-manager
 status triaged

Can you please open a bug in bugzilla.gnome.org for that?

 affects network-manager
 status incomplete

thanks!

Forwarded upstream

Changed in network-manager:
importance: Undecided → Unknown
status: Incomplete → Unknown
Changed in network-manager:
status: Unknown → New
Changed in network-manager:
status: New → Invalid

Upstream considers this not being a bug in network-manager, but in the AT&T VPN Client. Don't know which package is the right one for that.

Changed in network-manager:
status: Triaged → Invalid
Changed in network-manager:
importance: Unknown → Medium
status: Invalid → Unknown
Matt Keys (mk6032) wrote :

I ran into this error on a different (CentOS 6 x86_64) system. Simply executing "nslookup" would return the error "nslookup: parse of /etc/resolv.conf failed". Upon close inspection of the contents nothing was out of order. Permissions and ownership also looked good and I was executing nslookup as root. It was then I noticed lsattr /etc/resolv.conf was showing the "e" flag set.

The customer had copied resolv.conf over from a different server (also ext4 formatted). I believe it may be that this attribute was set on the previous filesystem, and when moved to the new ext4 file system the extent mappings were incorrect, which caused the read/parse problem. Since you can't remove the attribute with chattr I was able to resolve the issue by simply copying the contents, deleting the old /etc/resolv.conf, creating a new /etc/resolv.conf, then pasting in the contents from clipboard and saving.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.