BIND 9.11.3 dropping queries when dhcp lease is renewed

Bug #1862327 reported by Radu Pantiru
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bind9 (Ubuntu)
Expired
Undecided
Unassigned

Bug Description

1. OS Version: Ubuntu 18.04.4 LTS

2. Package: bind9-9.11.3+dfsg-1ubuntu1.11

3. Expected behaviour: DNS query response.

4. Observed behaviour:

At random times when the dhcp lease gets renewed named does not reply with a response and the query will eventually time out.

System log:

DATE HH:MM:41 hosname.localdomain systemd-networkd[26198]: ens3: DHCP lease lost
DATE HH:MM:41 hosname.localdomain dbus-daemon[662]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.508' (uid=100 pid=26198 comm="/lib/systemd/systemd-networkd " label="unconfined")
DATE HH:MM:41 hosname.localdomain systemd[1]: Starting Hostname Service...
DATE HH:MM:41 hosname.localdomain systemd-networkd[26198]: ens3: DHCPv4 address <<IP_ADDRESS/SUBNET>> via <<GATEWAY>>>

named.log:

DATE HH:MM:41.646 network: error: binding TCP socket: address in use

Thank you for your help!

description: updated
Paride Legovini (paride)
tags: added: server-triage-discuss
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Hi Radu,
at the current level of information this isn't something that is actionable to fix.
The common paths from here are either:
a) try newer versions e.g. up to 1:9.16.0-1ubuntu1 in Ubuntu 20.04, if working there try the versions in between and then we can look together in changelogs if there is an already existing fix that can be backported.
b) report the issue upstream and ping back here with the bug ID. We can then track the discussion there and once a fix exists backport that as applicable.

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

This sounds like an upstream bug to me.
If the newer versions in Ubuntu aren't enough for your test please consider verifying this by building directly from the latest upstream source? If this can be confirmed as an upstream bug, the best route to getting it fixed in Ubuntu in this case would be to file an upstream bug if you're able to do that. Otherwise, I'm not sure what we can do directly in Ubuntu to fix the problem.

If you do end up filing an upstream bug, please link to it from here. Thanks!

Changed in bind9 (Ubuntu):
status: New → Incomplete
Revision history for this message
Radu Pantiru (radupantiru) wrote :

Thank you for your reply. I will see what it can be done to use a newer version of Ubuntu.

tags: removed: server-triage-discuss
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for bind9 (Ubuntu) because there has been no activity for 60 days.]

Changed in bind9 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers