L.ROOT-SERVERS.NET record needs an update

Bug #160176 reported by Karoly Molnar on 2007-11-05
12
Affects Status Importance Assigned to Milestone
bind9 (Debian)
Fix Released
Unknown
bind9 (Ubuntu)
Low
LaMont Jones
Dapper
Undecided
Unassigned
Feisty
Undecided
Unassigned
Gutsy
Undecided
Unassigned
Hardy
Low
LaMont Jones

Bug Description

Binary package hint: bind9

Hello,

One of the DNS root servers address has changed. Here is the original announcement:
http://www.ripe.net/ripe/maillists/archives/dns-wg/2007/msg00171.html

This is advance notice that there is a scheduled change to the IP
address for one of the authorities listed for the DNS root zone. The
change is to L.ROOT-SERVERS.NET, which is administered by ICANN.

The new IPv4 address for this authority is:

    199.7.83.42

This change is anticipated to be implemented in the root zone on 1
November 2007, however the new address is operational now. It will
replace the previous IP address of 198.32.64.12.

We encourage operators of DNS infrastructure to update any references to
the old IP address, and replace it with the new address. In particular,
many DNS resolvers have a DNS root "hints" file. This should be updated
with the new IP address.

...

It is expected that the old address will continue to work for at least
six months after the transition, but will ultimately be retired from
service.

----------------------------
This could be solved by updating the db.root file I guess:
-L.ROOT-SERVERS.NET. 3600000 IN A 198.32.64.12
+L.ROOT-SERVERS.NET. 3600000 IN A 199.7.83.42

Changed in bind9:
assignee: nobody → nxvl
status: New → Confirmed
Nicolas Valcarcel (nvalcarcel) wrote :

Fixed, attaching the debdiff.

Changed in bind9:
assignee: nxvl → nobody
Luke Yelavich (themuso) wrote :

First of all, this package is in main, so you want to subscribe ubuntu-main-sponsors instead of ubuntu-universe-sponsors.

Secondly, this is a fix that should be submmitted through the stable release updates process. https://wiki.ubuntu.com/StableReleaseUpdates is where you will find more information.

Changed in bind9:
status: Confirmed → Incomplete
Changed in bind9:
status: Unknown → Fix Committed
LaMont Jones (lamont) wrote :

And thirdly, we really really need to fix this sometime within the next 2 years.... </sarcasm>

It will be fixed in 1:9.4.1-P1-4, which will hit debian shortly. No need to do a hardy upload in the meantime.

Changed in bind9:
assignee: nobody → lamont
importance: Undecided → Low
milestone: none → ubuntu-8.04
status: Incomplete → Fix Committed
Changed in bind9:
status: Fix Committed → Fix Released
Daniel Holbach (dholbach) wrote :

Hum, if this is going through SRU, there will be an upload necessary. As Luke pointed out, please follow https://wiki.ubuntu.com/StableReleaseUpdates

Mathias Gug (mathiaz) wrote :

We may wanna issue a SRU for dapper as bind9 will be supported until 2011. Nominating for dapper.

Mathias Gug (mathiaz) wrote :

Marking Fix Released since the version in Hardy is 1:9.4.2-1.

Changed in bind9:
status: Fix Committed → Fix Released
Daniel Holbach (dholbach) wrote :

What's the status of the SRUs?

Soren Hansen (soren) wrote :
Soren Hansen (soren) wrote :
Soren Hansen (soren) wrote :
Soren Hansen (soren) wrote :
Soren Hansen (soren) wrote :

Updates have been uploaded to {dapper,edgy,feisty,gutsy}-proposed.

Martin Pitt (pitti) wrote :

Accepted into *-proposed. Please test.

Changed in bind9:
status: New → Fix Committed
status: New → Fix Committed
status: New → Fix Committed
Martin Pitt (pitti) wrote :

The dapper update has been tested by Soren, moved to -updates.

Changed in bind9:
status: Fix Committed → Fix Released
Pedro Villavicencio (pedro) wrote :

Verification done.

- Tested with Edgy, Feisty and Gutsy, after install the bind9 package the db.root file is listing the IP address of the L.ROOT-SERVERS.NET as 198.32.64.12.
- Test with Edgy, Feisty and Gutsy, after install the bind9 proposed package the db.root file update the IP address of the L.ROOT-SERVERS.NET now is 199.7.83.42, bug is fixed, thanks.

Martin Pitt (pitti) wrote :

Copied to -updates.

Changed in bind9:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.