E: /var/cache/apt/archives/bind9_1%3a9.10.3.dfsg.P4-1ubuntu2_amd64.deb: trying to overwrite '/usr/sbin/named-checkzone', which is also in package bind9utils 1:9.10.3.dfsg.P4-1ubuntu2

Bug #1559090 reported by dino99 on 2016-03-18
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
bind9 (Ubuntu)
Undecided
Unassigned

Bug Description

Got that error while upgrading it:

Setting up bind9 (1:9.10.3.dfsg.P4-1ubuntu1) ...
/usr/bin/deb-systemd-helper: error: unable to read bind9.service
Failed to open '/usr/lib/tmpfiles.d/bind9.conf', ignoring: No such file or directory

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: bind9 1:9.10.3.dfsg.P4-1ubuntu1
Uname: Linux 4.5.0-040500-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Mar 18 14:03:02 2016
RelatedPackageVersions:
 bind9utils 1:9.10.3.dfsg.P4-1ubuntu1
 apparmor 2.10-3ubuntu2
SourcePackage: bind9
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
dino99 (9d9) wrote :

Even worst with the latest:

Preparing to unpack .../bind9_1%3a9.10.3.dfsg.P4-1ubuntu2_amd64.deb ...
Unpacking bind9 (1:9.10.3.dfsg.P4-1ubuntu2) over (1:9.10.3.dfsg.P4-1ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/bind9_1%3a9.10.3.dfsg.P4-1ubuntu2_amd64.deb (--unpack):
 trying to overwrite '/usr/sbin/named-checkzone', which is also in package bind9utils 1:9.10.3.dfsg.P4-1ubuntu1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
/usr/bin/deb-systemd-helper: error: unable to read bind9.service
Failed to open '/usr/lib/tmpfiles.d/bind9.conf', ignoring: No such file or directory

dino99 (9d9) wrote :

Tested a downgrade, then re-upgrade, but still get the error:

E: /var/cache/apt/archives/bind9_1%3a9.10.3.dfsg.P4-1ubuntu2_amd64.deb: trying to overwrite '/usr/sbin/named-checkzone', which is also in package bind9utils 1:9.10.3.dfsg.P4-1ubuntu2

(1- disable 'proposed'
 2- empty the cache
 3- update
 4- purge bind9
 5- downgrade the bind* packages
 6- install bind9
 7- activate 'proposed'
 8- update/upgrade

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bind9 (Ubuntu):
status: New → Confirmed
dino99 (9d9) on 2016-03-18
summary: - Setting up bind9 (1:9.10.3.dfsg.P4-1ubuntu1) ... /usr/bin/deb-systemd-
- helper: error: unable to read bind9.service Failed to open
- '/usr/lib/tmpfiles.d/bind9.conf', ignoring: No such file or directory
+ E: /var/cache/apt/archives/bind9_1%3a9.10.3.dfsg.P4-1ubuntu2_amd64.deb:
+ trying to overwrite '/usr/sbin/named-checkzone', which is also in
+ package bind9utils 1:9.10.3.dfsg.P4-1ubuntu2
dino99 (9d9) wrote :

Problem resolved by bind9 (1:9.10.3.dfsg.P4-3) upgrade

Changed in bind9 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers