named crashed with SIGABRT in isc_assertion_failed()

Bug #1553460 reported by dino99 on 2016-03-05
96
This bug affects 19 people
Affects Status Importance Assigned to Milestone
bind9 (Ubuntu)
High
Unassigned

Bug Description

Got that crash on shutdown, and found it after a cold boot

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: bind9 1:9.10.3.dfsg.P2-5
ProcVersionSignature: Ubuntu 4.4.0-10.25-generic 4.4.3
Uname: Linux 4.4.0-10-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
Date: Sat Mar 5 07:22:29 2016
ExecutablePath: /usr/sbin/named
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-10-generic root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
ProcEnviron:
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
RelatedPackageVersions:
 bind9utils 1:9.10.3.dfsg.P2-5
 apparmor 2.10-3ubuntu2
Signal: 6
SourcePackage: bind9
StacktraceTop:
 ?? ()
 isc_assertion_failed () from /usr/lib/x86_64-linux-gnu/libisc.so.160
 isc.mem_destroy () from /usr/lib/x86_64-linux-gnu/libisc.so.160
 isc_mem_destroy () from /usr/lib/x86_64-linux-gnu/libisc.so.160
 ?? ()
Title: named crashed with SIGABRT in isc_assertion_failed()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dino99 (9d9) wrote :
information type: Private → Public

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1552801, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-amd64-retrace
dino99 (9d9) wrote :

Sadly #1552801 is a 'private' report; so it cant be followed and should not grab dupes

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bind9 (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

Still continue crashing (in a random way)

dino99 (9d9) on 2016-04-02
description: updated
Changed in bind9 (Ubuntu):
importance: Undecided → High
dino99 (9d9) wrote :

It could be a gcc 4.9 compiler code optimization (if the ubuntu package have used it).

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=762755
Look message #82

Joe Carey (joecarey) wrote :

Happens with each and every boot.

Lisio (lisio) wrote :

Crashes during every system start

Hello dino99, or anyone else affected,

Accepted bind9 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bind9/1:9.10.3.dfsg.P4-8ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bind9 - 1:9.10.3.dfsg.P4-9

---------------
bind9 (1:9.10.3.dfsg.P4-9) unstable; urgency=medium

  * Fix bad patch from when we switched to quilt. Closes: #820847 LP:
    #1552801, #1549788, #1553460
  * freshen patch to remove fuzz.

 -- LaMont Jones <email address hidden> Tue, 26 Apr 2016 15:17:58 -0600

Changed in bind9 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.