Package failed to install and crashed...

Bug #370978 reported by Bobby on 2009-05-02
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bibledit (Ubuntu)
Undecided
Jonathan Marsden

Bug Description

Binary package hint: bibledit

I'm new to Ubuntu, but when I tried to install this program, it failed to finish the install and crashed my system...

ProblemType: Package
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 8.10
ErrorMessage: trying to overwrite `/usr/share/bibledit/bibledit.xpm', which is also in package bibledit-data
NonfreeKernelModules: nvidia
Package: bibledit None [modified: /var/lib/dpkg/info/bibledit.list]
SourcePackage: bibledit
Title: package bibledit None [modified: /var/lib/dpkg/info/bibledit.list] failed to install/upgrade: trying to overwrite `/usr/share/bibledit/bibledit.xpm', which is also in package bibledit-data
Uname: Linux 2.6.27-11-generic i686

Bobby (bobbyposs) wrote :
Jonathan Marsden (jmarsden) wrote :

Thanks for reporting this and so helping to improve Ubuntu.

I am not seeing this behaviour in Intrepid. How exactly are you trying to install bibledit?

Even if this install issue were happening to everyone, it still should not "crash your system" -- please provide more details about exactly what you mean by this. Thanks.

Meanwhile there is a Ubuntu package of Bibledit 3.7 in my PPA, which is much more up to date that the 2.2.* packages in Intrepid.

You might want to take a look at https://edge.launchpad.net/~jmarsden/+archive/ppa and see if using the bibledit and bibledit-data packages in there works for you. Incidentally, we expect Bibledit 3.7 will be in the next release of Ubuntu, 9.10 Karmic Koala. It is already in Debian unstable.

Jonathan

Changed in bibledit (Ubuntu):
status: New → Incomplete
Derrick Hudson (dman) wrote :

I just ran into this error.

The solution is to add
    Conflicts: bibledit (<<3.7)
to the bibledit-data control file.

I installed the bibledit (2.2-2.1) package from the 9.04 repository. Since it is old (and crashed), I then downloaded the source package from 9.10 and compiled it. That one crashed because it could not load the stylesheet config file. To resolve that simply, I tried to install the bibledit-data package from 9.10 on my 9.04 system. However, I still had the old bibledit package installed. Removing it resolved this conflict.

Jonathan Marsden (jmarsden) wrote :

Derrick:

Thanks for the report. Your steps to reproduce the issue seem somewhat roundabout to me. Bear in mind that any time you have to build packages from source in order to reproduce a bug, there is probably a better (simpler) way to do things! Nevertheless, I tried to follow your approach.

Here is what I tried to reproduce this issue:

(1) Create a new virtual machine, and install Ubuntu Desktop 9.04 i386 on it.

(2) In a terminal window in that newly created Ubuntu 9.04 machine, do:

  # Install older Jaunty version of bibledit
  sudo apt-get -y install bibledit

(3) Now to try to reproduce your approach and this issue. In a terminal window, do:

  # Install basic development tools
  sudo apt-get -y install build-essential devscripts
  # Grab the latest bibledit source package 3.7-1 from Ubuntu archives
  mkdir -p ~/packages/bibledit
  cd ~/packages/bibledit
  dget ftp://archive.ubuntu.com/ubuntu/pool/universe/b/bibledit/bibledit_3.7-1.dsc
  dpkg-source -x *.dsc
  # Install build dependencies
  sudo apt-get -y build-dep bibledit
  # Install more build dependenceis for the newer package
  sudo apt-get -y install rcs libenchant-dev libgtkhtml3.14-dev git-core
  sudo apt-get -y install libcurl4-gnutls-dev libgtksourceview2.0-dev
  # Build new version of bibledit from source
  cd bibledit-3.7
  debuild -us -uc
  # Install it
  sudo dpkg -i ../*.deb

This works fine, and bibledit (version 3.7) now runs normally on this system.

HOWEVER, after more experimenting, I did find a way to reproduce the issue -- it seems to require that you install bibledit-data before installing/updating bibledit itself.

NOTE: The simpler way by far to get to this point in Jaunty at the moment would be to use the CrossWire Packaging Team PPA and so avoid needing to build anything from scratch, by replacing (3) above with:

  wget https://launchpad.net/~pkgcrosswire/+archive/ppa/+files/crosswire-ppa_1.6~09.04_all.deb
  sudo dpkg -i crosswire*.deb
  sudo apt-get update
  sudo apt-get -y install bibledit

Job done -- this approach also works fine, needs no development tools, and is a *lot* quicker :) Oh, and you'll get updates as we release them into the PPA, too!

Once Karmic is released, we expect to be able to get a backported version of bibledit 3.7 into the jaunty-backports repository, so people can enable that and install from there, rather that needing to use a (less trusted) PPA.

I'll package Bibledit 3.7.42 (the latest source tarball release of Bibledit) and correct this issue.

Thanks,

Jonathan

Changed in bibledit (Ubuntu):
assignee: nobody → Jonathan Marsden (jmarsden)
status: Incomplete → In Progress
Derrick Hudson (dman) wrote :

You're right -- my situation is not a particularly good way to reproduce the issue. It was simply what I was doing when I discovered the issue, and I found this existing report.

As you discovered, the simplest steps are:
    1) install bibledit 2.2-2.1
    2) install bibledit-data 3.7
        (without updating bibledit)

The background for my situation is that I wanted to install 3.7 and not bother debugging the crash in 2.2. I did not want to risk updating libstdc++, etc, to the 9.10 version on my 9.04 system. That is why I was building from source.

I'll take a look at the PPA and see how that works for me.

Jonathan Marsden (jmarsden) wrote :

Fix commited to bzr.

bibledit 3.7.42-2 packages exist in ~pkgcrosswire PPA and do not seem to have this issue.

Changed in bibledit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bibledit - 3.8-1

---------------
bibledit (3.8-1) unstable; urgency=low

  [ Jonathan Marsden ]
  * New upstream version 3.8.
  * debian/patches/03_fix-64bit-compile.patch: Fixes upstream
      bug #27056: Bibledit 3.8 does not compile on amd64.

  [ Daniel Glassey ]
  * edit 02_bibledit-shutdown-manpage.patch to edit Makefile.in

bibledit (3.7.42-2) unstable; urgency=low

  * New upstream version.
  * debian/control:
    - Add Conflicts: bibledit (<<3.7) to bibledit-data.
      Closes (LP: #370978).
    - Add Build-Depends: on libwebkit-dev.
    - Bump Standards-Version to 3.8.2 (no changes neeeded).
  * debian/patches/*:
    - Remove 01_desktop_file.patch (now included upstream).
    - Add 02_bibledit-shutdown-manpage.patch

 -- Jonathan Marsden <email address hidden> Sat, 15 Aug 2009 17:44:22 +0100

Changed in bibledit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers