betaradio version 1.2-1 failed to build on i386

Bug #803172 reported by Stefano Rivera on 2011-06-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
betaradio (Ubuntu)
Medium
Unassigned

Bug Description

betaradio version 1.2-1 failed to build on i386
Link to failed build: https://launchpad.net/ubuntu/+source/betaradio/1.2-1/+build/2479216

Direct link to the build log: https://launchpad.net/ubuntu/+source/betaradio/1.2-1/+build/2479216/+files/buildlog_ubuntu-oneiric-i386.betaradio_1.2-1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 1918 lines into the build log:

/build/buildd/betaradio-1.2/src/json_soup.c:441: undefined reference to `json_node_get_double'
betaradio-json_soup.o: In function `json_soup_get_bool':
/build/buildd/betaradio-1.2/src/json_soup.c:449: undefined reference to `json_node_get_boolean'
betaradio-json_soup.o: In function `json_soup_length':
/build/buildd/betaradio-1.2/src/json_soup.c:463: undefined reference to `json_array_get_length'
collect2: ld returned 1 exit status
make[3]: *** [betaradio] Error 1
make[3]: Leaving directory `/build/buildd/betaradio-1.2/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/betaradio-1.2'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/betaradio-1.2'
dh_auto_build: make -j1 returned exit code 2
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110505-0204
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/betaradio-1.2

Changed in betaradio (Ubuntu):
importance: Undecided → Medium
Changed in betaradio (Ubuntu):
assignee: nobody → Shih-Yuan Lee (fourdollars)
status: New → Confirmed
Shih-Yuan Lee (fourdollars) wrote :

The root cause is that `pkg-config --libs-only-L gtk+-x11-2.0` returns empty string on oneiric i386.
It supposed to return "-L/usr/lib/i386-linux-gnu" on oneiric i386.

Changed in betaradio (Ubuntu):
status: Confirmed → Invalid
Changed in betaradio (Ubuntu):
status: Invalid → Confirmed
Shih-Yuan Lee (fourdollars) wrote :

No, `pkg-config --libs-only-L gtk+-x11-2.0` returns empty string on oneiric i386 is not the root cause.

Shih-Yuan Lee (fourdollars) wrote :

Fixed in new upstream release.
http://code.google.com/p/betaradio/downloads/detail?name=betaradio-1.3.tar.bz2
Waiting for my sponsor to dput into Debian archive.

Changed in betaradio (Ubuntu):
status: Confirmed → In Progress
Jeremy Bicha (jbicha) wrote :

Fixed with today's accidental sync from Debian.

Changed in betaradio (Ubuntu):
assignee: Shih-Yuan Lee (fourdollars) → nobody
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers