Ubuntu

Totem crashes in fullscreen mode while running Beryl

Reported by saads on 2007-03-26
6
Affects Status Importance Assigned to Milestone
beryl-core (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: totem

When running Beryl, if I open a movie in totem and try to play it in fullscreen mode, totem crashes. It happens both with totem-gstreamer and totem-xine. I tried running totem from the command prompt to see if it would output anything when crashing. Here is the output:

The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 371 error_code 11 request_code 140 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Timothy Babych (tymofiy) wrote :

I experience similar bug with almost any video that is sent to fullscreen : Totem videos and visualizations, mplayer videos.
mplayer with xv driver mode crashes, with sdl driver it crashes Xorg.

Starting playback...
VDec: vo config request - 576 x 478 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.21:1 - prescaling to correct movie aspect.
VO: [xv] 576x478 => 576x478 Planar YV12
X11 error: BadAlloc (insufficient resources for operation)1.6% 4 0

MPlayer interrupted by signal 6 in module: vo_check_events
- MPlayer crashed. This shouldn't happen.

Nvidia drivers, Ubuntu Feisty amd64, beryl uses AIGLX for rendering.

Timothy Babych (tymofiy) wrote :

looks like this issue is described here:
http://wiki.beryl-project.org/wiki/Troubleshooting_AIGLX

Workround: switch to x11 driver in ~/.mplayer/config (vo=x11)

and change to x11 in gstreamer-properties for Totem

Changed in beryl-core:
status: Unconfirmed → Confirmed

Beryl is replaced by Compiz Fusion, so has been removed from Gutsy.

  status invalid
  subscribe

Changed in beryl-core:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers