FTBFS against ocaml 4.02

Bug #1515019 reported by Łukasz Zemczak on 2015-11-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ben (Ubuntu)
Critical
Iain Lane

Bug Description

After performing a no-change rebuild for the ocaml 4.02 transition, ben stopped being able to build. The error is:

ocamlfind ocamlc -c -g -annot -thread -package dynlink -package unix -package pcre -package netstring -package ocamlgraph -package tyxml -package fileutils -package threads -package postgresql -I lib -o lib/benl_utils.cmi lib/benl_utils.mli
+ ocamlfind ocamlc -c -g -annot -thread -package dynlink -package unix -package pcre -package netstring -package ocamlgraph -package tyxml -package fileutils -package threads -package postgresql -I lib -o lib/benl_utils.cmi lib/benl_utils.mli
File "lib/benl_utils.mli", line 36, characters 35-47:
Error: Unbound module Xhtml
Command exited with code 2.
Makefile:66: recipe for target 'ocamlbuild' failed
make[1]: *** [ocamlbuild] Error 10
make[1]: Leaving directory '/«PKGBUILDDIR»'
dh_auto_build: make -j1 returned exit code 2
debian/rules:16: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Looks like some ocaml incompatibility.

tags: added: ftbfs
Steve Langasek (vorlon) wrote :

There is a new version of ben in Debian unstable, awaiting merge, which is probably going to fix this bug.

Iain Lane (laney) wrote :

I got this you guys

Changed in ben (Ubuntu):
status: New → In Progress
assignee: nobody → Iain Lane (laney)
Łukasz Zemczak (sil2100) wrote :

Thanks for the merge! Yes, it fixes the FTBFS nicely.

Launchpad Janitor (janitor) wrote :
Download full text (3.6 KiB)

This bug was fixed in the package ben - 0.7.3ubuntu1

---------------
ben (0.7.3ubuntu1) xenial; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - Show Ubuntu logo.
    - Allow configs to request the Packages/Sources files are not
      redownloaded (so that we can download once and for all at the start).
    - Add an Ubuntu template.
    - Tolerate templates with buildds or critical_bugs entries that return
      None.
  * Fixes FTBFS (LP: #1515019)

ben (0.7.3) unstable; urgency=medium

  * Port to tyxml 3.5
  * Tell curl to follow HTTP redirects

ben (0.7.2) unstable; urgency=medium

  * Use date from last changelog entry in generated documentation to ensure
    a reproducible build.
  * Use http://httpredir.debian.org/debian as a default Debian mirror.
  * Update instructions in example file (Closes: #797100).
  * Set section to "devel" (Closes: #800390).
  * Drop Benl_arg module and use OCaml's Arg module. This change bumps
    minimal required version for OCaml to 4.01.

ben (0.7.1) unstable; urgency=medium

  [ Paul Wise ]
  * cdn.debian.net has been deprecated, replace it with http.debian.net

  [ Mehdi Dogguy ]
  * Ignore potential errors when deleting lock file
  * Use FileUtil.rm instead of calling /bin/rm
  * Replaces uses of Benl_core.list_iteri with List.iteri, which requires
    OCaml >= 4.0.
  * Call dose-debcheck with --deb-native-arch
  * Make build reproducible (Closes: #792054)
  * Add a note about order of command-line flags in documentation (Closes: #747875)
  * Add Json output format in monitor (Closes: #747883)
  * Drop --text, --xhtml and --color in favor of --output-format|-f

  [ Emilio Pozuelo Monfort ]
  * Fix buildd.debian.org compact links

  [ Simon McVittie ]
  * Add a new Partial category for packages that are both good and bad
    (Closes: #795314).

ben (0.7.0) unstable; urgency=medium

  * Add --no-clean to "ben tracker" to leave unknown generated
    HTML files.
  * "ben tracker" will clean up the HTML directory by default from
    now on.
  * Add ability to read uncompressed files by specifying "plain",
    "no" or "none" as a compression format.
  * Remove --output-type from "ben tracker". Support for other output
    types didn't exist anyway and is not planned.
  * Simplify queries so that processing is, a bit, faster.
  * Make templates directory configurable through BEN_TEMPLATES_DIR
    environment variable.
  * Automatically set correct date and revision when generating refman.
  * Bump magic number to BENA0902 because of change in internal format
    of cache file. This requires regeneration of .cache files.
  * Ben should not define any of the modules exported by its library.
    Update the nodefined-map for Ben accordingly.
  * Add libocamlnet-ocaml-dev to Build-Depends, needed by Ben_monitor
    through usage of Netencoding (Closes: #750327).
  * Using -stdin, ben monitor will read its input file from the
    standard input (Closes: #747887).
  * Document how ben query makes the difference between Packages and
    Sources files (Closes: #747879).
  * Use Arg module to process CLI arguments.
  * Parallelize (using ParMap) ben's processing in all frontends, except
    query....

Read more...

Changed in ben (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers