Please remove beid from quantal

Bug #1009449 reported by James Page on 2012-06-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
beid (Ubuntu)
Medium
Unassigned

Bug Description

No longer in Debian - FTBFS in quantal -please remove.

Thanks.

>>>>>>>>>>>

During a rebuild test with default-jdk switched to openjdk-7 (as it is in quantal), a build failure was detected for beid version 3.5.2.dfsg-10ubuntu4.

See attached log for full build failure details.

https://wiki.ubuntu.com/JavaTeam/Java7Default contains more details of how to diagnose and resolve these types of issues.

This log snippet might also be of interest:

In file included from src/beidcommlib/Connection.cpp:5:0:
src/beidcommlib/Connection.h: In constructor 'EIDCommLIB::CConnection::CConnection()':
src/beidcommlib/Connection.h:43:22: warning: 'EIDCommLIB::CConnection::m_pHandler' will be initialized after [-Wreorder]
src/beidcommlib/Connection.h:41:24: warning: 'QSocketDeviceImpl* EIDCommLIB::CConnection::m_pSocket' [-Wreorder]
src/beidcommlib/Connection.cpp:15:1: warning: when initialized here [-Wreorder]
g++ -o src/beidcommlib/ConnectionListener.os -c -Wall -g -O2 -Dlinux -pipe -DQT_THREAD_SUPPORT -D_REENTRANT -fPIC -Wall -g -O2 -DNDEBUG -DNO_DEBUG -I/usr/share/qt3/include -I/usr/include/PCSC -Isrc/beidcommlib src/beidcommlib/ConnectionListener.cpp
g++ -o src/beidcommlib/ConnectionManager.os -c -Wall -g -O2 -Dlinux -pipe -DQT_THREAD_SUPPORT -D_REENTRANT -fPIC -Wall -g -O2 -DNDEBUG -DNO_DEBUG -I/usr/share/qt3/include -I/usr/include/PCSC -Isrc/beidcommlib src/beidcommlib/ConnectionManager.cpp
g++ -o src/beidcommlib/MessageQueue.os -c -Wall -g -O2 -Dlinux -pipe -DQT_THREAD_SUPPORT -D_REENTRANT -fPIC -Wall -g -O2 -DNDEBUG -DNO_DEBUG -I/usr/share/qt3/include -I/usr/include/PCSC -Isrc/beidcommlib src/beidcommlib/MessageQueue.cpp
g++ -o src/beidcommlib/QSocketDeviceImpl.os -c -Wall -g -O2 -Dlinux -pipe -DQT_THREAD_SUPPORT -D_REENTRANT -fPIC -Wall -g -O2 -DNDEBUG -DNO_DEBUG -I/usr/share/qt3/include -I/usr/include/PCSC -Isrc/beidcommlib src/beidcommlib/QSocketDeviceImpl.cpp
g++ -o src/beidcommlib/ServerRecvThread.os -c -Wall -g -O2 -Dlinux -pipe -DQT_THREAD_SUPPORT -D_REENTRANT -fPIC -Wall -g -O2 -DNDEBUG -DNO_DEBUG -I/usr/share/qt3/include -I/usr/include/PCSC -Isrc/beidcommlib src/beidcommlib/ServerRecvThread.cpp
g++ -o src/beidcommlib/libbeidcomm.so.0.0.0 -Wl,--soname=libbeidcomm.so.0 -shared src/beidcommlib/CardMessage.os src/beidcommlib/ConnectionListener.os src/beidcommlib/QSocketDeviceImpl.os src/beidcommlib/Connection.os src/beidcommlib/ConnectionManager.os src/beidcommlib/MessageQueue.os src/beidcommlib/ServerRecvThread.os -L/usr/share/qt3/lib -lqt-mt -lqt-mt -lcrypto -lssl
building 'libbeidcomm.la' from 'libbeidcomm.so.0.0.0'
cd src/beidcommlib && rm -f libbeidcomm.so && ln -s libbeidcomm.so.0.0.0 libbeidcomm.so
cd src/beidcommlib && rm -f libbeidcomm.so.0 && ln -s libbeidcomm.so.0.0.0 libbeidcomm.so.0
g++ -o src/winscarp/ServerPoll.os -c -Wall -g -O2 -Dlinux -pipe -DQT_THREAD_SUPPORT -D_REENTRANT -fPIC -Wall -g -O2 -DNDEBUG -DNO_DEBUG -I/usr/share/qt3/include -I/usr/include/PCSC -Isrc/winscarp -Isrc/eidlib src/winscarp/ServerPoll.cpp
g++ -o src/winscarp/winscarp.os -c -Wall -g -O2 -Dlinux -pipe -DQT_THREAD_SUPPORT -D_REENTRANT -fPIC -Wall -g -O2 -DNDEBUG -DNO_DEBUG -I/usr/share/qt3/include -I/usr/include/PCSC -Isrc/winscarp -Isrc/eidlib src/winscarp/winscarp.cpp
src/winscarp/winscarp.cpp: In function 'LONG SCardEstablishContext(DWORD, LPCVOID, LPCVOID, LPSCARDCONTEXT)':
src/winscarp/winscarp.cpp:440:76: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
src/winscarp/winscarp.cpp: In function 'LONG SCardReleaseContext(SCARDCONTEXT)':
src/winscarp/winscarp.cpp:480:74: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
src/winscarp/winscarp.cpp: In function 'LONG SCardListReaders(SCARDCONTEXT, LPCSTR, LPTSTR, LPDWORD)':
src/winscarp/winscarp.cpp:554:71: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
src/winscarp/winscarp.cpp: In function 'LONG SCardGetStatusChange(SCARDCONTEXT, DWORD, LPSCARD_READERSTATE_A, DWORD)':
src/winscarp/winscarp.cpp:849:75: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
src/winscarp/winscarp.cpp: In function 'LONG SCardConnect(SCARDCONTEXT, LPCSTR, DWORD, DWORD, LPSCARDHANDLE, LPDWORD)':
src/winscarp/winscarp.cpp:949:67: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
src/winscarp/winscarp.cpp: In function 'LONG SCardDisconnect(SCARDHANDLE, DWORD)':
src/winscarp/winscarp.cpp:1017:70: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
src/winscarp/winscarp.cpp: In function 'LONG SCardBeginTransaction(SCARDHANDLE)':
src/winscarp/winscarp.cpp:1057:76: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
src/winscarp/winscarp.cpp: In function 'LONG SCardEndTransaction(SCARDHANDLE, DWORD)':
src/winscarp/winscarp.cpp:1098:74: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
src/winscarp/winscarp.cpp: In function 'LONG SCardStatus(SCARDHANDLE, LPTSTR, LPDWORD, LPDWORD, LPDWORD, LPBYTE, LPDWORD)':
src/winscarp/winscarp.cpp:1155:66: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
src/winscarp/winscarp.cpp: In function 'LONG SCardTransmit(SCARDHANDLE, LPCSCARD_IO_REQUEST, LPCBYTE, DWORD, LPSCARD_IO_REQUEST, LPBYTE, LPDWORD)':
src/winscarp/winscarp.cpp:1266:68: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
src/winscarp/winscarp.cpp: In function 'LONG SCardControl(SCARDHANDLE, DWORD, LPCVOID, DWORD, LPVOID, DWORD, LPDWORD)':
src/winscarp/winscarp.cpp:1395:57: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
src/winscarp/winscarp.cpp: In function 'void FillUserData(EIDCommLIB::CCardMessage*)':
src/winscarp/winscarp.cpp:1498:30: error: 'getpid' was not declared in this scope
scons: *** [src/winscarp/winscarp.os] Error 1
scons: building terminated because of errors.
make: *** [stampdir/build-arch-stamp] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
────────────────────────────────────────────────────────────────────────────────
Build finished at 20120601-2059

Finished
────────

E: Build failure (dpkg-buildpackage died)

tags: added: amd64 auto ftbfs java7-ftbfs

Confirmed with the latest version in Quantal, 3.5.2.dfsg-10ubuntu3.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in beid (Ubuntu):
status: New → Confirmed
James Page (james-page) on 2012-08-15
summary: - beid version 3.5.2.dfsg-10ubuntu4 failed to build with openjdk-7 as
- default-jdk
+ Please remove beid from quantal
description: updated
Changed in beid (Ubuntu):
status: Confirmed → New
importance: Undecided → Medium
tags: removed: java7-ftbfs
Colin Watson (cjwatson) wrote :
Changed in beid (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments