keyboard shortcut has never worked for me under ubuntu

Bug #59387 reported by jens_acamedia on 2006-09-07
6
Affects Status Importance Assigned to Milestone
beagle (Ubuntu)
Undecided
Kevin Kubasik

Bug Description

when i assign a shortcut in keyboard shortcuts (system/preferences) that shortcut brings up the normal medusa search...

and ive never had a working shortcut for beagle - the way i set it in beagle preferences...

any idea why this is and whether we could have the medusa search in keyboard shortcuts use beagle if available?

thanks

Brandon Hale (brandon) wrote :

You need to run beagle in the tray to use the shortcut to pop it up.
Change the launcher to beagle-search --icon.

Changed in beagle:
status: Unconfirmed → Rejected

doesnt it seem strange to have to modify a launcher in order for an application to behave in the way the user expects?

i think this bug remains since nobody would know the advice you just gave me unless they filed a bug-report...

in addition - when i choose a keyboard shortcut for gnome search it brings up medusa search - i thought gnome was supposed to use beagle if available...why doesnt the gnome search window use beagle in this case?

my point is that there is no obvious way for the user to have a keyboard shortcut for beagle...

Changed in beagle:
status: Rejected → Unconfirmed
Brandon Hale (brandon) wrote :

Please don't bring up multiple bugs in one report.
I don't even know what "medusa" is to be honest with you.
I don't have such a binary on my system.

As for the other issue you can kick this upstream if you wish, it is not a packaging/Ubuntu specific bug.

Brandon Hale (brandon) wrote :

Your 2nd bug, about the Gnome global key shortcut, is filed as Launchpad #37176.
Apperantly Medusa was backend search code from ancient times (before Gnome 2.0). I believe what you are refering to now is the binary gnome-search-tool.

Thanks.

Kevin Kubasik (kkubasik) wrote :

This is a mixed bug, it really addresses 2 problems, one is simple user error, and not a but, however, the other is. The beagle-search --icon behavior has been fickle in the past, but the latest beagle should have that fixed, please refile if its still an issue.

Changed in beagle:
assignee: nobody → kkubasik
status: Unconfirmed → Fix Released
Fabio Ornellas (fabio-ornellas) wrote :

This is one more of "that's a feature, not a bug".

I was having trouble with beagle keyboard shortcut also. I almost filled another bug report. If there is a screen "select here the shortcut you wish" and it does not work, it sure IS a bug on the application. A bug in the interface, OK, but it is a bug. An application that can not be used as the screen tells, is buggy. Users are not supposed to dig into launchpad to learn how this wonderful "feature" works.

Also, for me, when I set the shortcut to use Alt+F12, Ctrl+F12, F3 or whatever, it does not work anymore (even with the --icon "feature"). It seems that the F12 is hardcoded, and anything else is ignored someway. Only when I let the default F12 plus --icon it works. This is a bug (I am just not sure if I open another bug report for it).

Also, if it is fixed at some newer beagle, it is not fixed in Feisty. So, either someone makes a patch to fix this issue at Feisty, or every user will have to live with it until the next Ubuntu release. Sure there are priorities, but dismiss this bug report as a feature, I disagree. Let the bug be, may be someone find time to fix this before the next release. I'd fix it myself if I had access to Ubuntu's beagle package. Only changing the launcher to add --icon seems that will avoid problems with more users. A partial but fast fix.

Thank you for your time.

PS: I do not mean to be rude with this, but if Ubuntu ships a software that is buggy, then it is a bug in Ubuntu. Ubuntu may choose not to ship some buggy software, but once it decides so, it is then part of the whole, a bug in the part, is a bug in the whole.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers