Ubuntu

Tracker are installed but the Places - Search menu is not updated

Reported by Dave Crossland on 2006-07-13
42
Affects Status Importance Assigned to Milestone
beagle (Ubuntu)
Undecided
Unassigned
tracker (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: beagle

When Beagle or Tracker are installed, the Places -> Search for files... menu needs updating, because it starts gnome-search tool. Now we have too identic icons (one in Places, the other, for Beagle/Tracker in Applications -> Accessories) for the same kind of action, and two different methods. We should explain better the difference between the two ways, and enhance the way they (don't, at the time) work together.

Brandon Hale (brandon) wrote :

Startup scripts, or rather autostart .desktop files are installed.
The Search menu is only updated on a fresh login. A fresh login will start beagled and use beagle-search in Places.

Changed in beagle:
status: Unconfirmed → Rejected

Nope it does not.

I installed beagle time ago and I just realised that the menu search does not launch beagle search.

Sebastian Breier (tomcat42) wrote :

This *is* a bug. I also have installed beagle a long time ago, and it has never shown up in Places. See dupe.

Changed in beagle:
status: Rejected → Confirmed
VF (vfiend) wrote :

In Edgy, Places->'Search for Files' is replaced by beagle.

In Feisty as of Herd 5, Places->'Search for Files' still calls gnome-search-tool, but beagle installs a notification area icon and Accessories->Search is shown by default and calls Beagle search, so I'm not sure if this _really_ a bug or a is design choice instead. Given that the accessories menu item is now visible I think it might be intentional.

Sebastian Breier (tomcat42) wrote :

I don't know most of the internals of Gnome, but if I read http://svn.gnome.org/viewcvs/nautilus/trunk/libnautilus-private/nautilus-search-engine.c?view=markup correctly, beagle should turn up as default search engine (see "#ifdef HAVE_BEAGLE").

VF (vfiend) wrote :

That's an internal nautilus thing, I believe, and has nothing to do with Places->Search. Nautilus' search uses beagle when available, which is different from gnome-search-tool

Sebastian Breier (tomcat42) wrote :

Yes, looks like you're right. :-)

Milan Bouchet-Valat (nalimilan) wrote :

IMHO, Edgy behavior was better. I would rather go back to this one. What do you think ?

In Feisty, if you want to use Beagle, you have to bear a permanent icon or an applet in your panel, and there's no menu entry to make a Beagle search. Or you have to use Nautilus first.

Previous behavior was nice: in two clicks you could search, and an applet as also available for intensive Beagle users. New behavior may confuse users, that won't understand the different search systems.

(Maybe the ideal would be that beagle-search-tool show a button to run the traditional gnome-search tool, which may be useful for some users.)

Sebastian Breier (tomcat42) wrote :

At least, there should be a manual way to change "Search for files..." to the beagle search or even tracker (for people who use that).

VF (vfiend) wrote :

Milan, beagle search also appears under applications->accessories

VF: OK, thanks, I talked a little quickly... ;-)
Anyway, this is a bit messy: "2 search tools, what are the differences between the two?" may ask a user new to Beagle. We should find a way to make the coexist in a nice way. I think gnome-search-tool is more complex, so we could make it available via beagle-s-t as a supplement (in a future outlook).

description: updated
Kevin Kubasik (kkubasik) on 2007-10-23
Changed in tracker:
status: New → Confirmed
Matt Hickford (matt-h) wrote :

I believe the following key is meant to implement this functionality
/desktop/gnome/applications/main-menu/search_command

In hardy, changing this key has no effect, and gnome-search-tool is launched regardless. please confirm

value for tracker would be tracker-search-tool SEARCH_STRING
and for beagle: beagle-search SEARCH_STRING

Jaap Haitsma (jaap) wrote :

Matt, you are reffering to gnome-main-menu application that's something different than the default gnome main menu

Anyway, the question is broader since if we hide the menu to launch gnome-search-tool, we need a way to start it from Tracker/Beagle (for example). Traditional search may still be needed sometimes.

>Traditional search may still be needed sometimes.

1) Only power users need to meddle with files outside of their own directory (which tracker doesn't index)
2) Power-users can be assumed to be smart enough to enable the desktop entry themselves (it is just unchecked by default)
3) Nautilus search now defaults to search the old way (in the current directory with all the extra possible options, like matching certain file sizes or types). which also allows to search in locations that are not indexed by tracker. The only missing function is regular expressions. But wouldn't people that know regular expressions just use the command line in the first place?
4) An alternative option could be, at least for Intrepid, to ship an all in one search tool, like catfish. I wonder how much trouble it would be to give that tool a simple and advanced mode?

Perhaps a strategy on file-searching and indexing would be a smart move? A specification perrhaps?
I feel this bug is more a sympton of a lacking strategy on this subject. Perhaps we should send a mail to the ubuntu-desktop list to encourage them to define some guidelines on this topic?

However, currently in Nautilus, it now defaults back to traditional searching, so I see little need for it.

Oops the last sentence was a cut&paste left-over ..

This would better be raised in GNOME's desktop-devel or nautilus-devel mailing lists, this is not really an Ubuntu-specific change.

Thomas Hotz (thotz) wrote :

Beagle is not in active development any more: setting to invalid.

Changed in beagle (Ubuntu):
status: Confirmed → Invalid
Thomas Hotz (thotz) on 2012-11-22
summary: - Tracker/Beagle are installed but the Places - Search menu is not updated
+ Tracker are installed but the Places - Search menu is not updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers