Merge beagle 0.3.3-2 from Debian(Unstable)

Bug #193715 reported by Stefan Ebner on 2008-02-20
8
Affects Status Importance Assigned to Milestone
beagle (Debian)
Fix Released
Unknown
beagle (Ubuntu)
Wishlist
Luca Falavigna

Bug Description

Binary package hint: beagle

Debian changelog's entries since latest Ubuntu one:

 beagle (0.3.3-2) unstable; urgency=low

   [ Jose Carlos Garcia Sogo ]
   * Add libtaglib2.0-cil to build dependencies (Closes: #463999)

   [ Mirco Bauer ]
   * debian/rules:
     + Use dh_clistrip instead of custom find commands.
   * debian/control:
     + Updated cli-common-dev build dependency to >= 0.5.4, as we use
       dh_clistrip from it now.
     + Removed debian revision (-1) from libndesk-dbus1.0-cil build dependency,
       to aid backports.
     + Added schedutils | util-linux (>= 2.13.1) to Recommends, as beagle
       optionally uses ionice in /etc/cron.daily/beagle-crawl-system.
       (Closes: #466101)
   * debian/compat:
     + Bumped to 5, we build-depend on debhelper >= 5 already anyhow.
   * debian/rules
     debian/sidebar.xul
     debian/sidebar.css
     debian/beagleSearch.js:
     + Install missing files for the iceweasel plugin. (Closes: #464184)

 -- Mirco Bauer <email address hidden> Mon, 18 Feb 2008 23:27:00 +0100

Remaining changes to be merged:

    - debian/control:
      + B-d on libtaglib2.0-cil
      + Rename ice{weasel,dove}-beagle to {mozilla,thunderbird}-beagle and
        and update the dependencies accordingly.
      + Suggest schedutils for beagle.
      + Change Maintainer to Ubuntu Mono Team.
    - debian/rules:
      + Install the mozilla-beagle and thunderbird-beagle extensions.
    - ice{dove,weasel}.dirs:
      + Renamed to {mozilla,thunderbird}-beagle.dirs.
      + Fixed paths to point to usr/lib/{firefox,thunderbird}

Related branches

Stefan Ebner (sebner) on 2008-02-20
Changed in beagle:
assignee: nobody → hellboy195
Stefan Ebner (sebner) wrote :
Changed in beagle:
assignee: hellboy195 → nobody
status: New → Confirmed
dBera (dbera-web) wrote :

Any progress on this one ?

Stefan Ebner (sebner) wrote :

Well we have to wait until a MOTU looks at it and approves it. But I will take care that his is happening soon :)

Stefan Ebner (sebner) on 2008-03-17
Changed in beagle:
assignee: nobody → dktrkranz
Luca Falavigna (dktrkranz) wrote :

It FTBFS now, see remote bugwatch.

Changed in beagle:
importance: Undecided → Wishlist
dBera (dbera-web) wrote :

This is due to the new gnome in which gconf-sharp dropped its dependency on glib. Fix is given here and is in upstream too http://bugzilla.gnome.org/show_bug.cgi?id=514252

Luca Falavigna (dktrkranz) wrote :

Yes, I already noticed it and I'm test-building it. Anyway, thanks for the pointer :)

Changed in beagle:
status: Unknown → New
Luca Falavigna (dktrkranz) wrote :

Version 0.3.3-2ubuntu1 uploaded.

Changed in beagle:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package beagle - 0.3.3-2ubuntu1

---------------
beagle (0.3.3-2ubuntu1) hardy; urgency=low

  [ Stefan Ebner ]
   * Merge from Debian unstable. (LP: #193715, #194608)
     Remaining Ubuntu changes:
    - debian/control:
      + Rename ice{weasel,dove}-beagle to {mozilla,thunderbird}-beagle and
        and update the dependencies accordingly.
      + Change Maintainer to Ubuntu Mono Team.
    - debian/rules:
      + Install the mozilla-beagle and thunderbird-beagle extensions.
    - ice{dove,weasel}.dirs:
      + Renamed to {mozilla,thunderbird}-beagle.dirs.
      + Fixed paths to point to usr/lib/{firefox,thunderbird}

  [ Luca Falavigna ]
  * debian/patches/glib-sharp-2.0-support.dpatch:
    - Add /glib-sharp-2.0 support, fix FTBFS.

beagle (0.3.3-2) unstable; urgency=low

  [ Jose Carlos Garcia Sogo ]
  * Add libtaglib2.0-cil to build dependencies (Closes: #463999)

  [ Mirco Bauer ]
  * debian/rules:
    + Use dh_clistrip instead of custom find commands.
  * debian/control:
    + Updated cli-common-dev build dependency to >= 0.5.4, as we use
      dh_clistrip from it now.
    + Removed debian revision (-1) from libndesk-dbus1.0-cil build dependency,
      to aid backports.
    + Added schedutils | util-linux (>= 2.13.1) to Recommends, as beagle
      optionally uses ionice in /etc/cron.daily/beagle-crawl-system.
      (Closes: #466101)
  * debian/compat:
    + Bumped to 5, we build-depend on debhelper >= 5 already anyhow.
  * debian/rules
    debian/sidebar.xul
    debian/sidebar.css
    debian/beagleSearch.js:
    + Install missing files for the iceweasel plugin. (Closes: #464184)

 -- Luca Falavigna <email address hidden> Tue, 18 Mar 2008 11:58:20 +0100

Changed in beagle:
status: Fix Committed → Fix Released
Changed in beagle:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.