beagle ftbfs

Bug #134341 reported by Matthias Klose on 2007-08-23
4
Affects Status Importance Assigned to Milestone
beagle (Ubuntu)
High
Sebastien Bacher
Nominated for Gutsy by Kevin Kubasik

Bug Description

Binary package hint: beagle

beagle ftbfs, confirmed by our buildds

Matthias Klose (doko) on 2007-08-23
Changed in beagle:
importance: Undecided → High
status: New → Confirmed
Kevin Kubasik (kkubasik) wrote :

I have just been informed of this issue, I am in the process of testing a patch which fixes, will post debdiff later tonight or tomorrow.

Kevin Kubasik (kkubasik) on 2007-08-24
Changed in beagle:
assignee: nobody → kkubasik
status: Confirmed → In Progress
Kevin Kubasik (kkubasik) wrote :

Ok, the attached branch will build a sane deb using bzr builddeb -w --split

Kevin Kubasik (kkubasik) on 2007-08-30
Changed in beagle:
status: In Progress → Fix Committed
Henrik Nilsen Omma (henrik) wrote :

Seb can you sponsor this fix?

Changed in beagle:
assignee: kkubasik → seb128
Sebastien Bacher (seb128) wrote :

The branch is names "feisty-update", do you recommend using it on gutsy? The package has been slightly modified since, could you update your branch and make the changelog mention your fixes or attach a simple debdiff to fix the bug?

Kevin Kubasik (kkubasik) wrote :

Ok, i've attached the new gutsy branch, it contains all the needed fixes to build, as well as the newest beagle bugfix release (0.2.18).

Kevin Kubasik (kkubasik) wrote :

I understand we are in an upstream freeze, however the changes in this are all bugfixes, no feature additions. In addition, the gutsy branch has significant cleanups to the debian directory, mostly in preparation for the new Beagle 0.3 release which marks a plethora of new features. (and as a result, new sub-packages).

Attached is the debdiff. A list of known upstream changes:

NOTABLE CHANGES BETWEEN 0.2.17 AND 0.2.18
-----------------------------------------

* Build and run against evolution-sharp 0.13.3.

* No longer recrawl directories if we can't set up an inotify watch.
 This fixes the looping bug of death when the screensaver kicks in.

* Greatly improve indexing overhead with the beagle-build-index tool.

* Display a warning in the log if the number of inotify watches runs
 out.

* Fix a problem in which beagle-search wouldn't work after a daemon
 restart. [bgo #463803]

* Fix a bug in which processing large numbers of maildir files could
 cause beagled to run out of file descriptors. [bgo #466891]

* Add support for the ~/.liferea_1.2 directory to the Liferea
 backend. [bgo #426573]

* Add support for PDF keywords, and allow colons in PDF metadata.
 [bgo #463003]

* Ignore legal.xml files in the Docbook filter, since they're largely
 content-less and frequently duplicated.

* Fix the SQL used to retrieve tag information from the Digikam DB.
 [bgo #454656]

* Improve error reporting throughout.

Full set of changes:
http://svn.gnome.org/viewcvs/beagle/tags/BEAGLE_0_2_18/ChangeLog?view=markup

A list of debian modifications can be found in debian/changelog, or the branch commit log.

Kevin Kubasik (kkubasik) wrote :

One last thing, to help with the testing process, I have uploaded this to my PPA.

https://launchpad.net/~kkubasik/+archive

Since pbuilder worked fine, I would assume that this will go well, however, I make no promises, there may not be a successful binary.

Sebastien Bacher (seb128) wrote :

Thank you for the work on that. Looks like there is quite some changes to the debian directory, could you document them in the changelog? You also dropped the "Added beagle as a dependency for mozilla-beagle (LP: #89525)" change

Kevin Kubasik (kkubasik) wrote :

Sorry, looks like it got lost in the shuffle. I'll merge that change in, and flesh out the changelog tonight.

Kevin Kubasik (kkubasik) wrote :

Ok, changes checked in, I merged the changes from that publish I missed, and updated the changelog to be more verbose.

Let me know if theres anything else I can do to help.

Henrik Nilsen Omma (henrik) wrote :

Moving milestone to beta.

Sebastien Bacher (seb128) wrote :

the new version has been uploaded to gutsy

Changed in beagle:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers