Upgrade bcmwl to version 6.20.55.19 (r300276) or greater

Bug #923809 reported by James M. Leddy on 2012-01-30
232
This bug affects 38 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
Precise
High
Unassigned
Quantal
High
Unassigned
bcmwl (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone
Quantal
High
Alberto Milone

Bug Description

[Impact]

 * A lot of machines that came out in the past year have a version of wireless that
   requires this driver. Anyone with these machines will not be able to run Ubuntu
   presently

 * This is solely a newer driver that requires newer hardware

[Test Case]

 * Acquire a machine that has one of the affected cards, eg Vostro 470
 * Install Ubuntu 12.04
 * Observe WiFi is non functional

[Regression Potential]

 * Low, this is an update to a proprietary driver provided by Broadcom
 * This has no impact for machines that don't have Broadcom wireless

[Original Description]

New devices are coming out that necessitate a new driver version for bcmwl. We would like to get these into 12.04 so that we don't lose support for these devices.

summary: - Upgrade to verison 6.20.55.19 (r300276)
+ Upgrade to verison 6.20.55.19 (r300276) or greater
tags: added: blocks-hwcert-enablement
description: updated
Changed in bcmwl (Ubuntu):
status: New → In Progress
summary: - Upgrade to verison 6.20.55.19 (r300276) or greater
+ Upgrade bcmwl to verison 6.20.55.19 (r300276) or greater
Changed in bcmwl (Ubuntu):
status: In Progress → Confirmed
importance: Medium → High

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu Precise):
status: New → Confirmed
Ara Pulido (apulido) on 2012-08-08
tags: added: precise quantal
Ara Pulido (apulido) on 2012-08-16
tags: added: blocks-hwcert
papukaija (papukaija) on 2012-08-16
tags: added: upgrade-software-version
Thomas Hotz (thotz) wrote :

Any chance to get this into quantal?

I'd also like a reply to that, seeing as this is the only criterion I need
for QQ.

Thomas Hotz (thotz) wrote :

Would be nice to have one for QQ kernel 3.5.

Jasmine Hassan (jasmine-aura) wrote :

updated again , some additional fixes, and new support of 3.6.x kernels. Now all kernels are supported w/ cfg80211 :)

http://jas.gemnetworks.com/wireless-bcm43142/

Darklum (lumiru) on 2012-10-27
information type: Public → Public Security
information type: Public Security → Public
Changed in oem-priority:
status: Incomplete → Invalid
pratham (pratham98k) on 2012-11-29
Changed in bcmwl (Ubuntu):
assignee: Alberto Milone (albertomilone) → pratham (pratham98k)
status: Confirmed → New
Changed in bcmwl (Ubuntu):
status: New → Confirmed
assignee: pratham (pratham98k) → Alberto Milone (albertomilone)
Ara Pulido (apulido) on 2012-12-03
summary: - Upgrade bcmwl to verison 6.20.55.19 (r300276) or greater
+ Upgrade bcmwl to version 6.20.55.19 (r300276) or greater
Changed in bcmwl (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.20.155.1+bdcom-0ubuntu1

---------------
bcmwl (6.20.155.1+bdcom-0ubuntu1) raring; urgency=low

  * New upstream release (LP: #923809):
    - Added 43142 support.
    - Added 4331 support.
  * debian/control:
    - depend on the different flavours of the linux-headers.
  * Refresh 0002-Makefile.patch and 0001-MODULE_LICENSE.patch.
 -- Alberto Milone <email address hidden> Tue, 11 Dec 2012 17:06:22 +0100

Changed in bcmwl (Ubuntu):
status: In Progress → Fix Released
Chris Van Hoof (vanhoof) on 2013-01-08
Changed in bcmwl (Ubuntu Precise):
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in bcmwl (Ubuntu):
milestone: ubuntu-12.04 → ubuntu-13.04
Changed in bcmwl (Ubuntu Quantal):
milestone: ubuntu-12.04 → quantal-updates
Changed in bcmwl (Ubuntu Precise):
milestone: none → precise-updates
description: updated
Alberto Milone (albertomilone) wrote :

this seems to cause a kernel panic on some machines, see bug #1098225

Alberto Milone (albertomilone) wrote :

the problem affects only Linux >= 3.6 and it's fixed in Raring

Ara Pulido (apulido) wrote :

Are we going to be able to have this fixed in Precise -updates?

Chris Van Hoof (vanhoof) wrote :

@Ara -- Yes, that is the plan.

Hello James, or anyone else affected,

Accepted bcmwl into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/bcmwl/6.20.155.1+bdcom-0ubuntu0.0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bcmwl (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
TienFu Chen (ctf) wrote :

Confirmed bcmwl-kernel-source.6.20.155.1+bdcom-0ubuntu0.0.1 supports Broadcom 4365, tried on two systems with Precise.

Ara Pulido (apulido) on 2013-01-18
tags: added: verification-done
removed: verification-needed
Bernardo Reino (reinob) wrote :

I can also verify that bcmwl-kernel-source from precise-proposed works OK (I'm using kernel 3.5 from quantal).

The only issue I found that that the kernel log is flooded (2 messages every 5 seconds):

ERROR @wl_cfg80211_get_station : Could not get rate (-1)
ERROR @wl_cfg80211_get_station : Could not get rssi (-1)

I applied the user-ioctl.patch patch found here: https://aur.archlinux.org/packages.php?ID=19514, and this removed those two error/warning messages. Everything else continued to work OK.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.20.155.1+bdcom-0ubuntu0.0.1

---------------
bcmwl (6.20.155.1+bdcom-0ubuntu0.0.1) precise-proposed; urgency=low

  [ Alberto Milone ]
  * New upstream release (LP: #923809).
  * Add 0004-Add-support-for-Linux-3.2.patch:
    - Make sure the patch can always be applied.
  * Add 0005-Add-support-for-Linux-3.4.0.patch:
    - Thanks to Eugene San for the patch (LP: #994255).
  * debian/control:
    - Drop all the dependencies on the linux-headers.
  * debian/dkms.conf.in:
    - Always apply all patches (LP: #1020059).

  [ Martin Pitt ]
  * debian/bcmwl-kernel-source.postinst:
    - Silence the errors from rmmod about the modules not being
      loaded. This is fully expected, and just causes confusion,
      as well as autopkgtest failures.
    - Mirror the actions of the installed modprobe.d files,
      i.e. rmmod the b43 driver and try to modprobe wl, so
      that this package works right after installation.
      (LP: #1065827)
    - Drop duplicate #DEBHELPER# token. It does not currently
      expand to anything, but it looks confusing.
  * debian/rules, debian/bcmwl-kernel-source.modaliases:
    - Drop parsing of src/src/wl/sys/wl_linux.c, as the current
      upstream version dropped all useful vendor matches in its
      pci_device_id struct and now has a broken modalias. Keep
      a static debian/bcmwl-kernel-source.modaliases instead
      which matches on any Broadcom network device (vendor 14E4
      class 02 subclass 80). This brings back a proper
      "Modaliases:" package header (LP: #1089943).
 -- Alberto Milone <email address hidden> Thu, 17 Jan 2013 12:38:17 +0100

Changed in bcmwl (Ubuntu Precise):
status: Fix Committed → Fix Released
NVieville (nicolas-vieville) wrote :

Hello,

Last update on Ubuntu 12.04 installed this package and no more wireless connection was available after reboot.
My wireless device is a bcm4313 on HP mini 210. I had to revert to 5.100.82.112 version of the bcmwl-kernel-source package in order to get wireless working again. To avoid useless update of this package again I added /etc/apt/preferences.d/bcmwl-kernel-source file containing:

Package: bcmwl-kernel-source
Pin: version 5.100.82.112+bdcom*
Pin-Priority: 1001

Since this 6.20.155.1 version of this device driver come from the 6.20.55.19 one, and this last one was made for bcm43142 aka bcm4365 or Dell 1704 device, wouldn't be accurate to try too keep names or versions of these two packages different. Doing so could avoid unneeded automatic update and let users making explicitly the choice to get one or the other.

To be complete, the Broadcom support Web page states that the last supported driver for bcm4313 hybrid bluetooth/wireless device (and others) is 5.100.82.112 (see http://www.broadcom.com/support/802.11/linux_sta.php). Maybe it would be very difficult to make the devices listed in the README file of this page working with this 6.20.155.1 driver. while bcm43142 device should just work correctly.

Cordially,

--
NVieville

huynhlv_54 (huynhlv54) wrote :

I installed Ubuntu 12.04 (daily built image) on a Dell Vostro 3460 (bcm 43142 + ar 8161). Wi-Fi worked, but ethernet did not. Then I installed ar8161 driver from source (http://www.linuxfoundation.org/collaborate/workgroups/networking/alx). Now ethernet works, but Wi-Fi does not!

It seems that driver packages for these two devices conflict.

sudo modprobe wl
FATAL: Error inserting wl (/lib/modules/3.5.0-23-generic/updates/dkms/wl.ko): Invalid argument

dmesg | grep wl
[ 6.259784] wl: module license 'MIXED/Proprietary' taints kernel.
[ 6.260912] wl: disagrees about version of symbol cfg80211_scan_done
[ 6.260914] wl: Unknown symbol cfg80211_scan_done (err -22)
[ 6.260936] wl: disagrees about version of symbol cfg80211_disconnected
[ 6.260937] wl: Unknown symbol cfg80211_disconnected (err -22)
[ 6.260952] wl: disagrees about version of symbol wiphy_register
[ 6.260953] wl: Unknown symbol wiphy_register (err -22)
[ 6.260957] wl: disagrees about version of symbol wiphy_new
[ 6.260958] wl: Unknown symbol wiphy_new (err -22)
[ 6.260961] wl: disagrees about version of symbol cfg80211_put_bss
[ 6.260962] wl: Unknown symbol cfg80211_put_bss (err -22)
[ 6.260965] wl: disagrees about version of symbol cfg80211_roamed
...

James M. Leddy (jm-leddy) wrote :

Please don't install alx from source. We already have the alx driver in the linux-backports-modules-cw-3.4-precise-generic-pae package, and are working on SRUing it for anyone that doesn't want to run the compat-wireless stack.

information type: Public → Public Security
information type: Public Security → Public
TienFu Chen (ctf) on 2013-02-19
tags: added: taipei-lab
tags: added: 201202-10605
Jeff Lane (bladernr) wrote :

Jockey did not pick this driver up from the restricted updates. I had to manually install bcmwl-kernel-source via apt-get to get the STA driver. Once I did that, i got the updated version listed above.

Jeff Marcom (jeffmarcom) wrote :

This update still didn't work for me unfortunately.

The following NEW packages will be installed:
  bcmwl-kernel-source
0 upgraded, 1 newly installed, 0 to remove and 325 not upgraded.
Need to get 0 B/1,344 kB of archives.
After this operation, 4,274 kB of additional disk space will be used.
Selecting previously unselected package bcmwl-kernel-source.
(Reading database ... 152206 files and directories currently installed.)
Unpacking bcmwl-kernel-source (from .../bcmwl-kernel-source_6.20.155.1+bdcom-0ubuntu0.0.1_amd64.deb) ...
Setting up bcmwl-kernel-source (6.20.155.1+bdcom-0ubuntu0.0.1) ...
Loading new bcmwl-6.20.155.1+bdcom DKMS files...
Building only for 3.2.0-29-generic
Building for architecture x86_64
Building initial module for 3.2.0-29-generic
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-29-generic/updates/dkms/

depmod.....

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-29-generic

ubuntu@201204-10857:~$ modinfo wl
filename: /lib/modules/3.2.0-29-generic/updates/dkms/wl.ko
license: MIXED/Proprietary
srcversion: 620417839200A53FF5C4AB5
alias: pci:v*d*sv*sd*bc02sc80i*
depends: cfg80211,lib80211
vermagic: 3.2.0-29-generic SMP mod_unload modversions
parm: oneonly:int
parm: piomode:int
parm: instance_base:int
parm: nompc:int
parm: intf_name:string

dmesg | grep -i wireless
Broadcom BCM4727 802.11 Hybrid Wireless Controller 6.20.155.1 (r326264)

ubuntu@201204-10857:~$ sudo iwlist eth1 scan
eth1 Interface doesn't support scanning : Invalid argument

Jeff Marcom (jeffmarcom) wrote :

ubuntu@201204-10857:~$ sudo lshw | grep -i wirel
                description: Wireless interface
                product: BCM4313 802.11b/g/n Wireless LAN Controller
                capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=wl0 driverversion=6.20.155.1 (r326264) latency=0 multicast=yes wireless=IEEE 802.11abg

Jeff Marcom (jeffmarcom) on 2013-02-21
tags: added: 201202-10575
tags: added: lexington-lab
James M. Leddy (jm-leddy) wrote :

After having re-read this bug, my belief is that the driver update is a regression for some of the older hardware, despite the fact that it is required to get the new hardware to work. I think it is unfortunate that we have already included the old pci-ids in the new driver, but if we can verify, we may be able to work on a fix for this.

NVieville (nicolas-vieville) wrote :

Hello,

According to my last post (#25), and IMHO this driver is only accurate for the bcm43142 aka bcm4365 or Dell 1704 device. All other Broadcom wireless devices that were compatible with the 5.100.82.112 device driver should just use this one and not the new one proposed here.
If you "google" for 6.20.55.19 broadcom wireless device driver, you should find the discussions about building deb files for new Ubuntu distribution, since this original wireless device driver was only provided by Dell with old Ubuntu/laptops. So it would be probably a good choice (IMHO) to keep the two drivers in two different deb files and let the users make their choices according to their respective hardware. Maybe keeping the originals pci-ids included in each driver as they were initially would help users to make their own choices. Maybe it would be then necessary to rename the .ko file of one of these drivers (the last one seems a good choice in order to keep old systems working) in order to achieve this task.

That was my modest two cents in trying to keep a working Ubuntu LTS distribution for the next 2 years.

Cordially,

--
NVieville

Please try this solution that should work in Ubuntu 12.10 (64-bit version):

First install the prerequisites:

sudo apt-get install linux-headers-generic build-essential dkms

Install the package:

http://jas.gemnetworks.com/debian/pool/main/w/wireless-bcm43142/wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb

Answer found in:

http://askubuntu.com/questions/175104/how-do-i-install-bcm43142-wireless-drivers-for-dell-vostro-3460-3560/215923#215923

and also found in

https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/222647

Chris Johnston (cjohnston) wrote :

On quantal today I had to install linux-headers-3.5.0-26-generic and linux-source in order for my wireless to work. I have bcmwl-kernel-source 5.100.82.112+bdcom-0ubuntu3

Trying to install 5.100.82.38 on 13.04, i386, got this:
Loading new bcmwl-5.100.82.38+bdcom DKMS files...
Building only for 3.8.0-19-generic
Building for architecture i686
Building initial module for 3.8.0-19-generic
Error! Bad return status for module build on kernel: 3.8.0-19-generic (i686)
Consult /var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/make.log for more information.
update-initramfs: deferring update (trigger activated)

Adam Porter (alphapapa) wrote :

This driver utterly fails for my BCM4313. My wifi worked perfectly under Quantal. I upgraded to Raring and it was unusable. Then I installed bcmwl-kernel-source 5.100.82.112 from Quantal, and it works perfectly again.

This driver MUST be split, and the 5.100.82.112 driver MUST be used for older devices. This is a MAJOR REGRESSION.

Adam Porter (alphapapa) wrote :

The regression may be tracked in bug 1154219.

Adam Porter (alphapapa) wrote :

Actually, this bug was filed in January but left unfixed: 1097519

NVieville (nicolas-vieville) wrote :

@Adam Porter

Maybe you should add this bug report too: https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1157880

Actually, unofficial 6.30.223.30 Broadcom device driver works correctly for me with the same device as you (BCM4313) on Fedora 18 with 3.9.x kernels, but I didn't tried with 3.10.x kernels (professional usage of my laptop). I proposed in the bug report mentioned above a patch that makes this driver to compile for 3.10 kernel, but I can't say if it is working with such a kernel (never tested).

Hope this will help you to solve this problem.

Cordially,

--
NVieville

Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in bcmwl (Ubuntu Quantal):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.