bcmwl-kernel-package does not update modprobe blacklist when upgraded (e.g. brcm80211)

Bug #776165 reported by WangLu on 2011-05-03
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Medium
Daniel van Vugt
Natty
Undecided
Unassigned

Bug Description

SRU information for this bug:

Rationale
In the natty cycle, the brcm80211 module was added to the blacklist file that gets created when the bcmwl package is installed. For some users, there may be problems if the wl module and the brcm80211 module are both loaded. The natty bcmwl package only creates the blacklist file if it doesn't already exist, thereby preventing brcm80211 from being added to the blacklist.

Regression potential
The regression potential is low to none, given that the blacklist file is only created/removed when the bcmwl package is installed/removed, and users are unlikely to be editing this aprticular files, so it should be safe to re-create at every upgrade of bcmwl.

How to reproduce (can be done on any system, even one without broadcom wireless hardware)
1. Create a dummy file, and save it as /etc/modprobe.d/blacklist-bcm43.conf.
2. Install the bcmwl package.
3. Check the contents of /etc/modprobe.d/blacklist-bcm43.conf and notice that the file is still empty, even though it should be populated with blacklist entries.

Once the updated natty package is installed, you should be able to follow the above steps, and have a fully populated blacklist in /etc/modprobe.d/blacklist-bcm43.conf.

Original bug report follows:

I ungraded to 11.04 from 10.10.

While jockey-gtk tells me that I have broadcom sta driver installed, in fact using 'lsmod' I see that both brcm80211 and wl are enabled, and a bug of brcm80211 makes my kernel unstable.

I found the 'postinst' script in the package which add a line 'blacklist brcm80211' to /etc/modprobe.d/blacklist-bcm43, but it is NOT called when upgraded

Related branches

Daniel Hahler (blueyed) on 2011-05-06
summary: - the package bcmwl-kernel-package does not update modprobe blacklist when
- upgraded
+ bcmwl-kernel-package does not update modprobe blacklist when upgraded
+ (e.g. brcm80211)
Changed in bcmwl (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in bcmwl (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Triaged → In Progress
Daniel van Vugt (vanvugt) wrote :

Note: This bug presently prevents people from getting the fix for bug 747002 if they do a dist upgrade. So it has the potential to break wifi for a lot of people upgrading to natty.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 5.100.82.38+bdcom-0ubuntu4

---------------
bcmwl (5.100.82.38+bdcom-0ubuntu4) oneiric; urgency=low

  [ Daniel van Vugt ]
  * debian/bcmwl-kernel-source.prerm:
    - Don't error out if we can't remove bcmwl module. LP: #776439
  * debian/bcmwl-kernel-source.postinst:
    - Unconditionally update the blacklist (i.e. even on upgrade).
      LP: #776165
 -- Michael Terry <email address hidden> Wed, 01 Jun 2011 13:57:27 -0400

Changed in bcmwl (Ubuntu):
status: In Progress → Fix Released
Luke Yelavich (themuso) on 2011-06-03
description: updated

Accepted bcmwl into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in bcmwl (Ubuntu Natty):
status: New → Fix Committed
tags: added: verification-needed
Jean-Baptiste Lallement (jibel) wrote :

bcmwl 5.100.82.38+bdcom-0ubuntu3.1 introduce the regression reported in bug 793890

tags: added: verification-failed
removed: verification-needed
tags: added: regression-proposed
Chris Halse Rogers (raof) wrote :

Hello WangLu, or anyone else affected,

Accepted bcmwl into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
WangLu (coolwanglu) wrote :

Sorry I don't get my ubuntu machine connected to the Internet right now.

But ~vanvugt/ubuntu/oneiric/bcmwl/fix-776165 seems fine to me.

Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 5.100.82.38+bdcom-0ubuntu3.2

---------------
bcmwl (5.100.82.38+bdcom-0ubuntu3.2) natty-proposed; urgency=low

  * debian/bcmwl-kernel-source.postinst: fix merge mistake in the previous
    revision resulting in failure to install (LP: #793890)

bcmwl (5.100.82.38+bdcom-0ubuntu3.1) natty-proposed; urgency=low

  [ Daniel van Vugt ]
  * debian/bcmwl-kernel-source.prerm:
    - Don't error out if we can't remove bcmwl module. LP: #776439
  * debian/bcmwl-kernel-source.postinst:
    - Unconditionally update the blacklist (i.e. even on upgrade).
      LP: #776165
 -- Daniel van Vugt <email address hidden> Fri, 08 Jul 2011 11:42:26 +0800

Changed in bcmwl (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions