Ubuntu

bcmwl bcmwl-kernel-source 5.100.82.38+bdcom-0ubuntu1 fails to build

Reported by C de-Avillez on 2011-01-08
300
This bug affects 33 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Alberto Milone

Bug Description

latest bcmwl kernel module fails to build, with the obvious impact on wireless users.

Setting up bcmwl-kernel-source (5.100.82.38+bdcom-0ubuntu1) ...
Loading new bcmwl-5.100.82.38+bdcom DKMS files...
Building only for 2.6.37-12-generic
Building for architecture x86_64
Building initial module for 2.6.37-12-generic

Error! Bad return status for module build on kernel: 2.6.37-12-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/ for more information.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: bcmwl-kernel-source 5.60.246.2+bdcom-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
NonfreeKernelModules: wl nvidia
Architecture: amd64
Date: Fri Jan 7 17:54:36 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
SourcePackage: bcmwl

Related branches

C de-Avillez (hggdh2) wrote :
tags: added: qa
C de-Avillez (hggdh2) wrote :

init_MUTEX is undeclared. Unfortunately, the logs got deleted when I downgraded back to 5.60.246*.

C de-Avillez (hggdh2) wrote :

Setting importance to High -- all dependent on this module (quite a large portion of the laptop users) will get hit.

Changed in bcmwl (Ubuntu):
importance: Undecided → High

init_MUTEX is now sema_init i think

Changed in bcmwl (Ubuntu):
status: New → Confirmed
Anton Gladky (gladky-anton) wrote :

Ups, sorry. I did not change anything in description.

description: updated
C de-Avillez (hggdh2) on 2011-01-08
tags: added: patch

Although it'll compile i still get

eth%d: 5.100.82.38 driver failed with code 21

on modprobe and no wireless so it'll obviously need a closer look

pnr (rusyaev-gmail) wrote :

I have used this solution to fix this issue:
http://ubuntuforums.org/showthread.php?t=1662447

C de-Avillez (hggdh2) wrote :

@pnr: these is not the same issue. The issue here is the kernel module failing to build/work, yours is the BCM firmware link missing.

Stepan Bakshaev (step2back) wrote :

Driver is built with your patch, but does not up wireless interface. I checked some logs: kernel.log, debug, but didn't find the reason. I switched to b43 with firmware, but it gives me less network speed.

Stephan (stephan-troyer) wrote :

/var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/make.log contains:

DKMS make.log for bcmwl-5.100.82.38+bdcom for kernel 2.6.37-12-generic (i686)
So 9. Jan 12:23:42 CET 2011
make: Gehe in Verzeichnis '/usr/src/linux-headers-2.6.37-12-generic'
  LD /var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/built-in.o
  CC [M] /var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/src/shared/linux_osl.o
  CC [M] /var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/src/wl/sys/wl_linux.o
/var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/src/wl/sys/wl_linux.c: In function ‘wl_attach’:
/var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/src/wl/sys/wl_linux.c:487:3: error: implicit declaration of function ‘init_MUTEX’
make[1]: *** [/var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/src/wl/sys/wl_linux.o] Fehler 1
make: *** [_module_/var/lib/dkms/bcmwl/5.100.82.38+bdcom/build] Fehler 2
make: Verlasse Verzeichnis '/usr/src/linux-headers-2.6.37-12-generic'

PeterPall (peterpall) wrote :

Found in some mailing list that this problem is fixed in the svn version of the driver.

PeterPall (peterpall) wrote :

Found the source again: Was http://madwifi-project.org/ticket/2370

PeterPall (peterpall) wrote :

Did look at it again. Was for the wrong project, so ignore my last 2 comments.

emperor (emperor2000) wrote :

Peter I somehow think that this problem from over 1 year ago you linked to does not relate to the current problem.

Anyways. Being a bit of programmer myself I have already tried the same as SevenMachines - error I get now is

WARNING: modpost: missing MODULE_LICENSE() in /home/emperor/Downloads/drv/wl.o
see include/linux/module.h for more information

And on insmod:
insmod: error inserting 'wl.o': -1 Invalid module format

Hope it gets fixed :)

emperor (emperor2000) wrote :

OOps:
insmod: error inserting 'wl.ko': -1 Unknown symbol in module

PeterPall (peterpall) wrote :

The "Unknown symbol in module" I got when trying to compile bcmwl with the headers from linux-headers-2.6.37-11-generic instead of the linux-headers-2.6.37-12-generic that would have matched my kernel. Another time I got this message was when after installing a new kernel I tried to compile the module for the new one --- and the Makefile compiled it for the old one, instead. Seems like the tracking which kernel to compile the module for is somehow critical. Don't know if that can help you; The missing MODULE_LICENSE does AFAIK just indicate that the module does claim not to be GPL (which is a choice made by the creator: It hinders the module from being debugged and thus from being reverse-engineered) but does not tell which license it conforms to, instead. So this message should be therefore just a administrative matter.

PeterPall (peterpall) wrote :

Tried the patch from seven_machines. Works fine for on my machine (natty, current alpha)

Changed in bcmwl (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 5.100.82.38+bdcom-0ubuntu2

---------------
bcmwl (5.100.82.38+bdcom-0ubuntu2) natty; urgency=low

  [ Henrik Rydberg ]
  * debian/patches0003-Make-up-for-missing-init_MUTEX.patch:
    - Make up for missing init_MUTEX (LP: #700176).
 -- Alberto Milone <email address hidden> Mon, 10 Jan 2011 11:51:03 +0100

Changed in bcmwl (Ubuntu):
status: Confirmed → Fix Released
Henrik Rydberg (rydberg) wrote :

Fully updated natty confirmed to be working for a BCM43224 802.11a/b/g/n (rev 01). Thanks!

For Lucid users there's fantastic news :)

Just download the natty package from

http://packages.ubuntu.com/natty/amd64/bcmwl-kernel-source/download

ok well thats for 64-bit.

anyway you just install that, and everything builds fine and once again you can use the wireless networks. I believe we get this trouble when we run newer kernels than those that are in lucid-updates.

I'd imagine the same solution would work for maverick users. and it also upgrades the existing bcmwl-kernel-source driver so you benefit from the latest fixes too!

Oh that reminds me. .. no point of trying the driver on broadcom's website. if the distro one does not compile, that one won't either. they even mentioned it clearly in the readme file. its just the same process with both drivers just different places where we get them from.

can't install the natty package (is for 64-bit, as you say)

cariboo907 (cariboo907) wrote :

I installed the updated Natty package from the repositories on Monday on my 32-bit netbook with no problems. Just make sure it is the correct version:

5.100.82.38+bdcom-0ubuntu2

I also do not have problems with the last update.

Anton

On Thu, Jan 13, 2011 at 2:28 AM, cariboo907 <email address hidden> wrote:
> I installed the updated Natty package from the repositories on Monday on
> my 32-bit netbook with no problems. Just make sure it is the correct
> version:
>
> 5.100.82.38+bdcom-0ubuntu2
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (699915).
> https://bugs.launchpad.net/bugs/700176
>
> Title:
>  bcmwl bcmwl-kernel-source 5.100.82.38+bdcom-0ubuntu1 fails to build
>
> Status in “bcmwl” package in Ubuntu:
>  Fix Released
>
> Bug description:
>  latest bcmwl kernel module fails to build, with the obvious impact on
>  wireless users.
>
>  Setting up bcmwl-kernel-source (5.100.82.38+bdcom-0ubuntu1) ...
>  Loading new bcmwl-5.100.82.38+bdcom DKMS files...
>  Building only for 2.6.37-12-generic
>  Building for architecture x86_64
>  Building initial module for 2.6.37-12-generic
>
>  Error! Bad return status for module build on kernel: 2.6.37-12-generic (x86_64)
>  Consult the make.log in the build directory
>  /var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/ for more information.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: bcmwl-kernel-source 5.60.246.2+bdcom-0ubuntu3
>  ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
>  Uname: Linux 2.6.37-12-generic x86_64
>  NonfreeKernelModules: wl nvidia
>  Architecture: amd64
>  Date: Fri Jan  7 17:54:36 2011
>  EcryptfsInUse: Yes
>  InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
>  SourcePackage: bcmwl
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/700176/+subscribe
>

ok, I'll try again as soon as I come back to my laptop

anyway, what you say seems quite strange to me, I've correctly downloaded one of those packages from the link posted by Eshwar Andhavarapu (http://packages.ubuntu.com/natty/amd64/bcmwl-kernel-source/download), but, as I try to install it, the system says it can't be installed because is for a 64-bit architecture

maybe there's something I'm missing, I'm an Ububtu beginner

Naveen Agarwal (nav.coder) wrote :

@Lorenzo Fedele

As your architecture is i386 use this link : http://packages.ubuntu.com/natty/i386/bcmwl-kernel-source/download

Please post your results back .

finally I've managed to install the 64-bit version, but something still does not sem to work, since I've received a crash report during the installation of the fglrx package (report just submitted)

should I try to install the 32-bit package (thank you very much Naveen Agarwal)?

Scott Kemper (sdkemper) wrote :

Thanks for the help everyone.

phl (ubuntu-leledy) wrote :

I have this same bug with latest bcmwl-kernel-source 5.100.82.38+bdcom-0ubuntu3 on natty (Ubuntu 11.04)
2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 i686 i386 GNU/Linux.

I did a dpkg-reconfigure bcmwl-kernel-source to be sure it's not a build issue. I still have

eth%d: 5.100.82.38 driver failed with code 21

when I do modprobe wl.

Philippe Lelédy

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.