Ubuntu

Maverick: Very slow and unstable wireless connection with BCM4322 on 5,5 Macbook pro

Reported by Paul Koerbitz on 2010-12-09
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

Ever since installing Maverick (Ubuntu 10.10 amd64) the wireless connection has been very bad. It is unstable (looses the connection or is unable to connect to an access point with full signal) and very slow when connected. I am positive that this is not due to the access point, as I have tried with several APs and my current workaround is to use the USB-tethering of my phone with the same AP.

EDIT: package version: 5.60.48.36+bdcom-0ubuntu5

There is also a thread on ubuntuforums with quite a few people reporting this issue:
http://ca.ubuntuforums.org/showthread.php?t=1596061

I'll be glad to provide more info.

thank you
Paul

description: updated
Mike (bild85) wrote :

similar experience on 6,2 MBP. Running on battery causes extreme slowness; plugging it back in resolves it. This is repeatable.

Paul Koerbitz (paul-koerbitz) wrote :

> Running on battery causes extreme slowness; plugging it back in resolves it.

I have read that before, however for me it is slow on battery _and_ when on ac power!

Leonardo Ecco (leonardo-ecco) wrote :

MB 5,1 running Ubuntu 10.10 32 bits. Same probem here... Running slow on battery and when on ac power...

I have the same problem on a MB 5,3. The following workaround works for me:

- Disable power management: iwconfig eth1 power off
- In Network Manager, enter a specific BSSID to disable roaming: Right click on applet -> Edit Connections -> Wireless tab -> Name of connection -> BSSID field . You get the BSSID from iwconfig, look for "Access Point: XX:XX:XX:XX:XX:XX" when connected to your network. The "XX:XX:XX:XX:XX:XX" is the BSSID.

I also had problems in 10.04, but only with WPA enabled.

Paul Koerbitz (paul-koerbitz) wrote :

Anders, thank you for sharing this workaround, it seems to work quite well for me too!
I am using a WPA encrypted access point, that doesn't seem to cause problems.
happy xmas
Paul

Anders Logg (logg) wrote :

Workaround seems to work for me too! Thanks!

I'm now down to stable pings of ca 1ms to my wireless router. Before applying the workaround it varied between 10ms - 500ms.

The strange thing is iwconfig is still reporting Access Point: Not-Associated even though I manually entered the BSSID in Network Manager and restarted the connection.

Salvador Diaz (salvadordiaz) wrote :

Running 10.10 on a MacbookPro6,2, I have the same problem, and applying the powermode and BSSID workaround seems to solve slowness problems.

Mark Smith (tntc-tig) wrote :

I encountered the same bug on my 13" Macbook Pro 7,1. I decided to try the new Broadcom driver released December 22, 2010 (Version 5.100.82.38), and it seemed to resolve these issues. This is the driver used in Natty, IIRC. Any chance of seeing a backport?

Changed in bcmwl (Ubuntu):
status: New → Confirmed
mavosaure (mavosaure) wrote :

I encountered the same bug on two Dell laptops with different Broadcom chipsets, using Broadcom STA driver :
Dell Studio 1558 with BCM43224 (Ubuntu 10.10 amd64)
Dell Studio 1737 with BCM 4322 (Ubuntu 10.10 i386)

Both are working with Ubuntu Maverick.

Using Anders Hessellund Jensen's workaround (comment #4) make a real improvement for me! It allows to get a good, stable and reliable connexion, but if someone is able to find a patch...

Or maybe we'll have to try the natty package? Could it be backported, as Mark Smith has ever asked it (#8)?

Workaround helps but its incomplete. When you remove the power cable from the laptop, the wifi power mode will get re-enabled. I just wrote a little bash script that will check and disable powermode every 10 seconds. Just change variable "DEVICE" to your wlan device name. Usually its "eth1". Copy the script to /usr/bin and add it to /etc/rc.local so it will get autostarted on every boot. Hope it helps ;-)

Jan Faber (mail-janfaber) wrote :

I'm using Natty,
I did not have to set BSSID.
The thing I did to get this solved is.

1) create a file named 'wireless' in /etc/pm/power.d
2) edit this file and enter the following text:

#!/bin/sh
iwconfig eth1 power off

That's all.

With this approach the normal 'wireless' routine is overruled.

Barak Naveh (barak-naveh) wrote :

@Jan, I tried your solution on MacBook Pro 6,2 running Ubuntu 10.10 and it seems to work.
Thanks!

Xing Zhou (dekom-dev) wrote :

Same thing happens on MacbookPro6,2 with 12.04.

Momentarily have switching from power all to power off in /usr/lib/pm-utils/power.d/wireless

line 49, switch $iwconfig_batt to $iwconfig_ac

Zygmunt Krynicki (zkrynicki) wrote :

I'm marking this as wont-fix as Maverick is no longer supported

Changed in bcmwl (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers